~ubuntu-branches/ubuntu/trusty/emma/trusty

« back to all changes in this revision

Viewing changes to debian/patches/fix_module_import_order.patch

  • Committer: Bazaar Package Importer
  • Author(s): Emanuele Gentili
  • Date: 2008-07-13 02:44:01 UTC
  • mfrom: (2.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080713024401-kdw65mjj7h6qgq70
Tags: 0.6-2ubuntu1
* Merge from debian unstable, remaining changes:
 + debian/control:
  - Added Ubuntu MOTU Maintainer field, moved the old one to
    Original-Maintainer
  - Replaced python build-dep with python-dev

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- emma-0.6.orig/emmalib/__init__.py
 
2
+++ emma-0.6/emmalib/__init__.py
 
3
@@ -28,11 +28,6 @@
 
4
 import bz2
 
5
 
 
6
 try:
 
7
-       import gtk
 
8
-       from gtk import keysyms
 
9
-       import gobject
 
10
-       import gtk.gdk
 
11
-       import gtk.glade
 
12
        if __name__ != "__main__":
 
13
                from emmalib import __file__ as emmalib_file
 
14
                from emmalib.mysql_host import *
 
15
@@ -41,6 +36,11 @@
 
16
                emmalib_file = __file__
 
17
                from mysql_host import *
 
18
                from mysql_query_tab import *
 
19
+       import gtk
 
20
+       from gtk import keysyms
 
21
+       import gobject
 
22
+       import gtk.gdk
 
23
+       import gtk.glade
 
24
 except:
 
25
        print "no gtk. you will not be able to start emma."