~ubuntu-branches/ubuntu/trusty/expect/trusty

« back to all changes in this revision

Viewing changes to debian/patches/06-pkgindex.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2011-08-17 21:50:29 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20110817215029-0cfarscc630tfc5v
Tags: 5.45-1
* New upstream release.
* Removed unnecessary patches.
* Removed the expectk package because expectk was dropped from the upstream
  distribution. See NEWS.Debian for possible workarounds.
* Updated package to standards version 3.9.2 (no changes needed).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Author: Michael A. Cleverly <michael@cleverly.com>, Sergei Golovan <sgolovan@debian.org>
2
2
Description:
3
 
 Fixes stupid typo in pkgIndex.in (Closes: #186179).
4
3
 Adjusted for new soname (Closes: #381052).
5
4
 Replaced [package require Expect] by direct loading libexpect library in all tests
6
5
 because package management can't load the library from its build location.
7
6
Last-Modified: 2009-11-18
8
7
 
9
 
--- expect-5.44.1.15.orig/Makefile.in
10
 
+++ expect-5.44.1.15/Makefile.in
11
 
@@ -330,8 +330,10 @@
12
 
        ( echo pkg_mkIndex . $(PKG_LIB_FILE) \; exit; ) | $(TCLSH)
13
 
 
 
8
--- expect-5.45.orig/Makefile.in
 
9
+++ expect-5.45/Makefile.in
 
10
@@ -331,7 +331,7 @@
14
11
 pkgIndex.tcl-hand:
15
 
-       (echo 'package ifneeded Expect $(PACKAGE_VERSION) \
 
12
        (echo 'if {![package vsatisfies [package provide Tcl] @TCL_VERSION@]} {return}' ; \
 
13
         echo 'package ifneeded Expect $(PACKAGE_VERSION) \
16
14
-           [list load [file join $$dir $(PKG_LIB_FILE)]]'\
17
 
+       (echo 'if {[package vcompare [info tclversion] @TCL_VERSION@] < 0} return' ; \
18
 
+        echo '' ; \
19
 
+        echo 'package ifneeded Expect $(PACKAGE_VERSION) \
20
15
+           [list load [file join @prefix@ lib libexpect.so.@PACKAGE_VERSION@]]'\
21
16
        ) > pkgIndex.tcl
22
17
 
23
18
 #========================================================================
24
 
--- expect-5.44.1.15.orig/pkgIndex.in
25
 
+++ expect-5.44.1.15/pkgIndex.in
26
 
@@ -7,4 +7,6 @@
27
 
 # script is sourced, the variable $dir must contain the
28
 
 # full path name of this file's directory.
 
19
--- expect-5.45.orig/tests/all.tcl
 
20
+++ expect-5.45/tests/all.tcl
 
21
@@ -7,7 +7,7 @@
 
22
 package require tcltest
 
23
 # do this in a way that is backward compatible for Tcl 8.3
 
24
 namespace import ::tcltest::test ::tcltest::cleanupTests
 
25
-package require Expect
 
26
+load [lindex [glob libexpect*.so] 0]
29
27
 
30
 
+if {[package vcompare [info tclversion] @TCL_VERSION@] < 0} return
31
 
+
32
 
-package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. @EXP_SHARED_LIB_FILE@]]
33
 
+package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join @prefix@ lib libexpect.so.@PACKAGE_VERSION@]]
34
 
--- expect-5.44.1.15.orig/tests/cat.test
35
 
+++ expect-5.44.1.15/tests/cat.test
 
28
 set ::tcltest::testSingleFile false
 
29
 set ::tcltest::testsDirectory [file dirname [info script]]
 
30
--- expect-5.45.orig/tests/cat.test
 
31
+++ expect-5.45/tests/cat.test
36
32
@@ -9,7 +9,7 @@
37
33
     # do this in a way that is backward compatible for Tcl 8.3
38
34
     namespace import ::tcltest::test ::tcltest::cleanupTests
42
38
 
43
39
 #exp_internal -f /dev/ttyp5 0
44
40
 
45
 
--- expect-5.44.1.15.orig/tests/expect.test
46
 
+++ expect-5.44.1.15/tests/expect.test
 
41
--- expect-5.45.orig/tests/expect.test
 
42
+++ expect-5.45/tests/expect.test
47
43
@@ -9,7 +9,7 @@
48
44
     # do this in a way that is backward compatible for Tcl 8.3
49
45
     namespace import ::tcltest::test ::tcltest::cleanupTests
53
49
 
54
50
 catch {unset x}
55
51
 
56
 
--- expect-5.44.1.15.orig/tests/logfile.test
57
 
+++ expect-5.44.1.15/tests/logfile.test
 
52
--- expect-5.45.orig/tests/logfile.test
 
53
+++ expect-5.45/tests/logfile.test
58
54
@@ -9,7 +9,7 @@
59
55
     # do this in a way that is backward compatible for Tcl 8.3
60
56
     namespace import ::tcltest::test ::tcltest::cleanupTests
64
60
 
65
61
 test logfile-1.1 {basic logfile} {
66
62
     set filename /tmp/logfile.[pid]
67
 
--- expect-5.44.1.15.orig/tests/pid.test
68
 
+++ expect-5.44.1.15/tests/pid.test
 
63
--- expect-5.45.orig/tests/pid.test
 
64
+++ expect-5.45/tests/pid.test
69
65
@@ -9,7 +9,7 @@
70
66
     # do this in a way that is backward compatible for Tcl 8.3
71
67
     namespace import ::tcltest::test ::tcltest::cleanupTests
75
71
 
76
72
 catch {unset x}
77
73
 
78
 
--- expect-5.44.1.15.orig/tests/send.test
79
 
+++ expect-5.44.1.15/tests/send.test
80
 
@@ -9,7 +9,7 @@
81
 
     # do this in a way that is backward compatible for Tcl 8.3
82
 
     namespace import ::tcltest::test ::tcltest::cleanupTests
83
 
 }
84
 
-package require Expect
85
 
+load [lindex [glob libexpect*.so] 0]
86
 
 
87
 
 log_user 0
88
 
 
89
 
--- expect-5.44.1.15.orig/tests/spawn.test
90
 
+++ expect-5.44.1.15/tests/spawn.test
91
 
@@ -9,7 +9,7 @@
92
 
     # do this in a way that is backward compatible for Tcl 8.3
93
 
     namespace import ::tcltest::test ::tcltest::cleanupTests
94
 
 }
95
 
-package require Expect
96
 
+load [lindex [glob libexpect*.so] 0]
97
 
 
98
 
 log_user 0
99
 
 
100
 
--- expect-5.44.1.15.orig/tests/stty.test
101
 
+++ expect-5.44.1.15/tests/stty.test
 
74
--- expect-5.45.orig/tests/send.test
 
75
+++ expect-5.45/tests/send.test
 
76
@@ -9,7 +9,7 @@
 
77
     # do this in a way that is backward compatible for Tcl 8.3
 
78
     namespace import ::tcltest::test ::tcltest::cleanupTests
 
79
 }
 
80
-package require Expect
 
81
+load [lindex [glob libexpect*.so] 0]
 
82
 
 
83
 log_user 0
 
84
 
 
85
--- expect-5.45.orig/tests/spawn.test
 
86
+++ expect-5.45/tests/spawn.test
 
87
@@ -9,7 +9,7 @@
 
88
     # do this in a way that is backward compatible for Tcl 8.3
 
89
     namespace import ::tcltest::test ::tcltest::cleanupTests
 
90
 }
 
91
-package require Expect
 
92
+load [lindex [glob libexpect*.so] 0]
 
93
 
 
94
 log_user 0
 
95
 
 
96
--- expect-5.45.orig/tests/stty.test
 
97
+++ expect-5.45/tests/stty.test
102
98
@@ -9,7 +9,7 @@
103
99
     # do this in a way that is backward compatible for Tcl 8.3
104
100
     namespace import ::tcltest::test ::tcltest::cleanupTests