~ubuntu-branches/ubuntu/trusty/expect/trusty

« back to all changes in this revision

Viewing changes to debian/patches/05-makefile-soname.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Baumann
  • Date: 2009-08-03 12:00:29 UTC
  • Revision ID: james.westby@ubuntu.com-20090803120029-mdxnz1e7vyu06ji6
* Adding patch from Adam Tkac <atkac@redhat.com> to compile with
  tcl8.5, but not yet enabling it.
* Updating vcs fields in control file.
* Using patch-stamp rather than patch in rules file.
* Replacing obsolete dh_clean -k with dh_prep.
* Using correct rfc-2822 date formats in changelog.
* Updating package to standards version 3.8.2.
* Adding misc depends.
* Removing shlibs file.
* Using quilt rather than dpatch.
* Adding patch from fedora to fix header comments.
* Adding patch from fedora to fix permissions when accessing logfiles.
* Adding patch from Vitezslav Crhonek <vcrhonek@redhat.com> for tcl
  8.5.6, but not yet enabling it.
* Minimizing rules file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#!/bin/sh /usr/share/dpatch/dpatch-run
2
 
## 05-makefile-soname.dpatch by Mike Markley <mike@markley.org>
3
 
##
4
 
## DP: Adds '-soname' to the Makefile.
5
 
 
6
 
@DPATCH@
7
 
 
8
 
diff -Naur expect-5.43.0.orig/Makefile.in expect-5.43.0/Makefile.in
9
 
--- expect-5.43.0.orig/Makefile.in      2004-05-07 18:10:30.000000000 +0000
10
 
+++ expect-5.43.0/Makefile.in   2006-07-10 16:57:18.000000000 +0000
11
 
@@ -413,7 +413,7 @@
12
 
 expect-shared-lib-file :: $(EXP_SHARED_LIB_FILE)
13
 
 $(EXP_SHARED_LIB_FILE): $(OFILES)
14
 
        -rm -f $(EXP_SHARED_LIB_FILE)
15
 
-       @TCL_SHLIB_LD@ -o $(EXP_SHARED_LIB_FILE) $(SHARED_OFILES) @EXP_LD_SEARCH_FLAGS@ @EXP_SHLIB_LD_LIBS@
16
 
+       @TCL_SHLIB_LD@ -o $(EXP_SHARED_LIB_FILE) $(SHARED_OFILES) @EXP_LD_SEARCH_FLAGS@ @EXP_SHLIB_LD_LIBS@ -Wl,-soname,$(SONAME)
17
 
 
18
 
 .PHONY: install-info install info
19
 
 install-info: