~ubuntu-branches/ubuntu/trusty/gcc-4.8/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/goarch-aarch64.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-11-29 19:09:33 UTC
  • Revision ID: package-import@ubuntu.com-20131129190933-6x3ul8h73c3hv763
Tags: 4.8.2-7ubuntu1
* Merge with Debian; remaining changes:
  - Build from the upstream source.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Introduce aarch64 goarch.
 
2
 
 
3
--- a/src/libgo/go/go/build/syslist.go
 
4
+++ a/src/libgo/go/go/build/syslist.go
 
5
@@ -5,4 +5,4 @@
 
6
 package build
 
7
 
 
8
 const goosList = "darwin dragonfly freebsd linux netbsd openbsd plan9 windows solaris "
 
9
-const goarchList = "386 amd64 arm alpha m68k mipso32 mipsn32 mipsn64 mipso64 ppc ppc64 sparc sparc64 "
 
10
+const goarchList = "386 amd64 arm aarch64 alpha m68k mipso32 mipsn32 mipsn64 mipso64 ppc ppc64 sparc sparc64 "
 
11
--- a/src/libgo/configure.ac
 
12
+++ a/src/libgo/configure.ac
 
13
@@ -172,6 +172,7 @@
 
14
 
 
15
 dnl N.B. Keep in sync with gcc/testsuite/go.test/go-test.exp (go-set-goarch).
 
16
 is_386=no
 
17
+is_aarch64=no
 
18
 is_alpha=no
 
19
 is_arm=no
 
20
 is_m68k=no
 
21
@@ -183,6 +184,10 @@
 
22
 is_x86_64=no
 
23
 GOARCH=unknown
 
24
 case ${host} in
 
25
+  aarch64*-*-*)
 
26
+    is_aarch64=yes
 
27
+    GOARCH=aarch64
 
28
+    ;;
 
29
   alpha*-*-*)
 
30
     is_alpha=yes
 
31
     GOARCH=alpha
 
32
@@ -265,6 +270,7 @@
 
33
     ;;
 
34
 esac
 
35
 AM_CONDITIONAL(LIBGO_IS_386, test $is_386 = yes)
 
36
+AM_CONDITIONAL(LIBGO_IS_AARCH64, test $is_aarch64 = yes)
 
37
 AM_CONDITIONAL(LIBGO_IS_ALPHA, test $is_alpha = yes)
 
38
 AM_CONDITIONAL(LIBGO_IS_ARM, test $is_arm = yes)
 
39
 AM_CONDITIONAL(LIBGO_IS_M68K, test $is_m68k = yes)
 
40
--- a/src/gcc/testsuite/go.test/go-test.exp
 
41
+++ a/src/gcc/testsuite/go.test/go-test.exp
 
42
@@ -187,6 +187,9 @@
 
43
     global target_triplet
 
44
 
 
45
     switch -glob $target_triplet {
 
46
+       "aarch64*-*-*" {
 
47
+           set goarch "aarch64"
 
48
+       }
 
49
        "alpha*-*-*" {
 
50
            set goarch "alpha"
 
51
        }