~ubuntu-branches/ubuntu/trusty/gccgo-4.9/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ada-link-lib.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2014-07-17 15:51:15 UTC
  • mfrom: (1.1.7)
  • Revision ID: package-import@ubuntu.com-20140717155115-usmcxg0rqk69vqtk
Tags: 4.9.1-0ubuntu1
* Upload the final GCC 4.9.1 release.
* Merge changes from gcc-4.9 4.9.0-2ubuntu1, including:
  - Fix PR go/60931, garbage collector issue with non 4kB system page size.
    LP: #1304754.
  - Fix wrong-code issue in the little endian vector API (ppc64el).
    LP: #1311128.
  - Fix ABI incompatibility between POWER and Z HTM builtins and intrinsics.
    LP: #1320292.
  - Fix an ICE with invalid code. PR c++/61046. LP: #1313102.
  - gccgo: Don't overwrite memory if an archive has a bad file name.
* Include the cc1 binary into the gccgo-4.9 package.
* Do not build-depend on sdt-systemtap for the trusty upload.
* Warn about ppc ELFv2 ABI issues, which will change in GCC 4.10.

Show diffs side-by-side

added added

removed removed

Lines of Context:
108
108
 
109
109
 # Make arch match the current multilib so that the RTS selection code
110
110
 # picks up the right files. For a given target this must be coherent
111
 
@@ -1423,6 +1396,11 @@
 
111
@@ -1450,6 +1423,11 @@
112
112
   LIBRARY_VERSION := $(LIB_VERSION)
113
113
 endif
114
114
 
120
120
 # HP/PA HP-UX 10
121
121
 ifeq ($(strip $(filter-out hppa% hp hpux10%,$(target_cpu) $(target_vendor) $(target_os))),)
122
122
   LIBGNAT_TARGET_PAIRS = \
123
 
@@ -2446,151 +2424,6 @@
 
123
@@ -2481,151 +2459,6 @@
124
124
   $(patsubst %$(objext),%.adb,$(GNATRTL_OBJS)), \
125
125
   $(ADA_EXCLUDE_SRCS))
126
126
 
272
272
 ../stamp-gnatlib-$(RTSDIR):
273
273
        @if [ ! -f stamp-gnatlib-$(RTSDIR) ] ; \
274
274
        then \
275
 
@@ -2627,14 +2460,10 @@
 
275
@@ -2662,14 +2495,10 @@
276
276
 #     Also install the .dSYM directories if they exist (these directories
277
277
 #     contain the debug information for the shared libraries on darwin)
278
278
        for file in gnat gnarl; do \
289
289
           if [ -d $(RTSDIR)/lib$${file}$(hyphen)$(LIBRARY_VERSION)$(soext).dSYM ]; then \
290
290
              $(CP) -r $(RTSDIR)/lib$${file}$(hyphen)$(LIBRARY_VERSION)$(soext).dSYM \
291
291
                $(DESTDIR)$(ADA_RTL_OBJ_DIR); \
292
 
@@ -2647,19 +2476,7 @@
 
292
@@ -2682,19 +2511,7 @@
293
293
        cd $(DESTDIR)$(ADA_INCLUDE_DIR); $(CHMOD) a-wx *.adb
294
294
        cd $(DESTDIR)$(ADA_INCLUDE_DIR); $(CHMOD) a-wx *.ads
295
295
 
310
310
        $(RMDIR) $(RTSDIR)
311
311
        $(MKDIR) $(RTSDIR)
312
312
        $(CHMOD) u+w $(RTSDIR)
313
 
@@ -2724,7 +2541,7 @@
 
313
@@ -2759,7 +2576,7 @@
314
314
 # Example: cd $(RTSDIR); ar rc libfoo.a $(LONG_LIST_OF_OBJS)
315
315
 # is guaranteed to overflow the buffer.
316
316
 
319
319
 # C files
320
320
        $(MAKE) -C $(RTSDIR) \
321
321
                CC="`echo \"$(GCC_FOR_TARGET)\" \
322
 
@@ -2761,32 +2578,47 @@
 
322
@@ -2796,32 +2613,47 @@
323
323
 
324
324
 # Warning: this target assumes that LIBRARY_VERSION has been set correctly.
325
325
 gnatlib-shared-default:
383
383
 
384
384
 gnatlib-shared-dual:
385
385
        $(MAKE) $(FLAGS_TO_PASS) \
386
 
@@ -2795,17 +2627,15 @@
 
386
@@ -2830,17 +2662,15 @@
387
387
             GNATLIBCFLAGS_FOR_C="$(GNATLIBCFLAGS_FOR_C)" \
388
388
             MULTISUBDIR="$(MULTISUBDIR)" \
389
389
             THREAD_KIND="$(THREAD_KIND)" \
404
404
 
405
405
 gnatlib-shared-dual-win32:
406
406
        $(MAKE) $(FLAGS_TO_PASS) \
407
 
@@ -2815,17 +2645,15 @@
 
407
@@ -2850,17 +2680,15 @@
408
408
             PICFLAG_FOR_TARGET="$(PICFLAG_FOR_TARGET)" \
409
409
             MULTISUBDIR="$(MULTISUBDIR)" \
410
410
             THREAD_KIND="$(THREAD_KIND)" \
425
425
 
426
426
 # ??? we need to add the option to support auto-import of arrays/records to
427
427
 # the GNATLIBFLAGS when this will be supported by GNAT. At this point we will
428
 
@@ -2963,28 +2791,6 @@
 
428
@@ -2998,28 +2826,6 @@
429
429
             THREAD_KIND="$(THREAD_KIND)" \
430
430
             PICFLAG_FOR_TARGET="$(PICFLAG_FOR_TARGET)" gnatlib
431
431
 
1018
1018
 
1019
1019
-dependencies = { module=all-gnattools; on=all-target-libada; };
1020
1020
+dependencies = { module=all-gnattools; on=all-libada; };
 
1021
 dependencies = { module=all-gnattools; on=all-target-libstdc++-v3; };
1021
1022
 
1022
1023
 dependencies = { module=all-lto-plugin; on=all-libiberty; };
1023
 
 
1024
1024
Index: b/src/Makefile.in
1025
1025
===================================================================
1026
1026
--- a/src/Makefile.in
1033
1033
     maybe-configure-gnattools \
1034
1034
     maybe-configure-lto-plugin
1035
1035
 .PHONY: configure-target
1036
 
@@ -1069,6 +1070,7 @@
 
1036
@@ -1071,6 +1072,7 @@
1037
1037
 all-host: maybe-all-tk
1038
1038
 all-host: maybe-all-libtermcap
1039
1039
 all-host: maybe-all-utils
1041
1041
 all-host: maybe-all-gnattools
1042
1042
 @if lto-plugin-no-bootstrap
1043
1043
 all-host: maybe-all-lto-plugin
1044
 
@@ -1169,6 +1171,7 @@
 
1044
@@ -1171,6 +1173,7 @@
1045
1045
 info-host: maybe-info-tk
1046
1046
 info-host: maybe-info-libtermcap
1047
1047
 info-host: maybe-info-utils
1049
1049
 info-host: maybe-info-gnattools
1050
1050
 info-host: maybe-info-lto-plugin
1051
1051
 
1052
 
@@ -1252,6 +1255,7 @@
 
1052
@@ -1254,6 +1257,7 @@
1053
1053
 dvi-host: maybe-dvi-tk
1054
1054
 dvi-host: maybe-dvi-libtermcap
1055
1055
 dvi-host: maybe-dvi-utils
1057
1057
 dvi-host: maybe-dvi-gnattools
1058
1058
 dvi-host: maybe-dvi-lto-plugin
1059
1059
 
1060
 
@@ -1335,6 +1339,7 @@
 
1060
@@ -1337,6 +1341,7 @@
1061
1061
 pdf-host: maybe-pdf-tk
1062
1062
 pdf-host: maybe-pdf-libtermcap
1063
1063
 pdf-host: maybe-pdf-utils
1065
1065
 pdf-host: maybe-pdf-gnattools
1066
1066
 pdf-host: maybe-pdf-lto-plugin
1067
1067
 
1068
 
@@ -1418,6 +1423,7 @@
 
1068
@@ -1420,6 +1425,7 @@
1069
1069
 html-host: maybe-html-tk
1070
1070
 html-host: maybe-html-libtermcap
1071
1071
 html-host: maybe-html-utils
1073
1073
 html-host: maybe-html-gnattools
1074
1074
 html-host: maybe-html-lto-plugin
1075
1075
 
1076
 
@@ -1501,6 +1507,7 @@
 
1076
@@ -1503,6 +1509,7 @@
1077
1077
 TAGS-host: maybe-TAGS-tk
1078
1078
 TAGS-host: maybe-TAGS-libtermcap
1079
1079
 TAGS-host: maybe-TAGS-utils
1081
1081
 TAGS-host: maybe-TAGS-gnattools
1082
1082
 TAGS-host: maybe-TAGS-lto-plugin
1083
1083
 
1084
 
@@ -1584,6 +1591,7 @@
 
1084
@@ -1586,6 +1593,7 @@
1085
1085
 install-info-host: maybe-install-info-tk
1086
1086
 install-info-host: maybe-install-info-libtermcap
1087
1087
 install-info-host: maybe-install-info-utils
1089
1089
 install-info-host: maybe-install-info-gnattools
1090
1090
 install-info-host: maybe-install-info-lto-plugin
1091
1091
 
1092
 
@@ -1667,6 +1675,7 @@
 
1092
@@ -1669,6 +1677,7 @@
1093
1093
 install-pdf-host: maybe-install-pdf-tk
1094
1094
 install-pdf-host: maybe-install-pdf-libtermcap
1095
1095
 install-pdf-host: maybe-install-pdf-utils
1097
1097
 install-pdf-host: maybe-install-pdf-gnattools
1098
1098
 install-pdf-host: maybe-install-pdf-lto-plugin
1099
1099
 
1100
 
@@ -1750,6 +1759,7 @@
 
1100
@@ -1752,6 +1761,7 @@
1101
1101
 install-html-host: maybe-install-html-tk
1102
1102
 install-html-host: maybe-install-html-libtermcap
1103
1103
 install-html-host: maybe-install-html-utils
1105
1105
 install-html-host: maybe-install-html-gnattools
1106
1106
 install-html-host: maybe-install-html-lto-plugin
1107
1107
 
1108
 
@@ -1833,6 +1843,7 @@
 
1108
@@ -1835,6 +1845,7 @@
1109
1109
 installcheck-host: maybe-installcheck-tk
1110
1110
 installcheck-host: maybe-installcheck-libtermcap
1111
1111
 installcheck-host: maybe-installcheck-utils
1113
1113
 installcheck-host: maybe-installcheck-gnattools
1114
1114
 installcheck-host: maybe-installcheck-lto-plugin
1115
1115
 
1116
 
@@ -1916,6 +1927,7 @@
 
1116
@@ -1918,6 +1929,7 @@
1117
1117
 mostlyclean-host: maybe-mostlyclean-tk
1118
1118
 mostlyclean-host: maybe-mostlyclean-libtermcap
1119
1119
 mostlyclean-host: maybe-mostlyclean-utils
1121
1121
 mostlyclean-host: maybe-mostlyclean-gnattools
1122
1122
 mostlyclean-host: maybe-mostlyclean-lto-plugin
1123
1123
 
1124
 
@@ -1999,6 +2011,7 @@
 
1124
@@ -2001,6 +2013,7 @@
1125
1125
 clean-host: maybe-clean-tk
1126
1126
 clean-host: maybe-clean-libtermcap
1127
1127
 clean-host: maybe-clean-utils
1129
1129
 clean-host: maybe-clean-gnattools
1130
1130
 clean-host: maybe-clean-lto-plugin
1131
1131
 
1132
 
@@ -2082,6 +2095,7 @@
 
1132
@@ -2084,6 +2097,7 @@
1133
1133
 distclean-host: maybe-distclean-tk
1134
1134
 distclean-host: maybe-distclean-libtermcap
1135
1135
 distclean-host: maybe-distclean-utils
1137
1137
 distclean-host: maybe-distclean-gnattools
1138
1138
 distclean-host: maybe-distclean-lto-plugin
1139
1139
 
1140
 
@@ -2165,6 +2179,7 @@
 
1140
@@ -2167,6 +2181,7 @@
1141
1141
 maintainer-clean-host: maybe-maintainer-clean-tk
1142
1142
 maintainer-clean-host: maybe-maintainer-clean-libtermcap
1143
1143
 maintainer-clean-host: maybe-maintainer-clean-utils
1145
1145
 maintainer-clean-host: maybe-maintainer-clean-gnattools
1146
1146
 maintainer-clean-host: maybe-maintainer-clean-lto-plugin
1147
1147
 
1148
 
@@ -2303,6 +2318,7 @@
 
1148
@@ -2305,6 +2320,7 @@
1149
1149
     maybe-check-tk \
1150
1150
     maybe-check-libtermcap \
1151
1151
     maybe-check-utils \
1153
1153
     maybe-check-gnattools \
1154
1154
     maybe-check-lto-plugin
1155
1155
 
1156
 
@@ -2412,6 +2428,7 @@
1157
 
     maybe-install-tk \
1158
 
     maybe-install-libtermcap \
1159
 
     maybe-install-utils \
1160
 
+    maybe-install-libada \
1161
 
     maybe-install-gnattools \
1162
 
     maybe-install-lto-plugin
1163
 
 
1164
 
@@ -2459,6 +2476,7 @@
1165
 
     maybe-install-tk \
1166
 
     maybe-install-libtermcap \
1167
 
     maybe-install-utils \
1168
 
+    maybe-install-libada \
1169
 
     maybe-install-gnattools \
1170
 
     maybe-install-lto-plugin
1171
 
 
1172
 
@@ -2562,6 +2580,7 @@
 
1156
@@ -2414,6 +2430,7 @@
 
1157
     maybe-install-tk \
 
1158
     maybe-install-libtermcap \
 
1159
     maybe-install-utils \
 
1160
+    maybe-install-libada \
 
1161
     maybe-install-gnattools \
 
1162
     maybe-install-lto-plugin
 
1163
 
 
1164
@@ -2461,6 +2478,7 @@
 
1165
     maybe-install-tk \
 
1166
     maybe-install-libtermcap \
 
1167
     maybe-install-utils \
 
1168
+    maybe-install-libada \
 
1169
     maybe-install-gnattools \
 
1170
     maybe-install-lto-plugin
 
1171
 
 
1172
@@ -2564,6 +2582,7 @@
1173
1173
     maybe-install-strip-tk \
1174
1174
     maybe-install-strip-libtermcap \
1175
1175
     maybe-install-strip-utils \
1177
1177
     maybe-install-strip-gnattools \
1178
1178
     maybe-install-strip-lto-plugin
1179
1179
 
1180
 
@@ -29448,6 +29467,331 @@
 
1180
@@ -29883,6 +29902,331 @@
1181
1181
 
1182
1182
 
1183
1183
 
1509
1509
 .PHONY: configure-gnattools maybe-configure-gnattools
1510
1510
 maybe-configure-gnattools:
1511
1511
 @if gcc-bootstrap
1512
 
@@ -29508,12 +29852,6 @@
 
1512
@@ -29943,12 +30287,6 @@
1513
1513
 maybe-check-gnattools: check-gnattools
1514
1514
 
1515
1515
 check-gnattools:
1522
1522
 
1523
1523
 @endif gnattools
1524
1524
 
1525
 
@@ -29554,24 +29892,8 @@
 
1525
@@ -29989,24 +30327,8 @@
1526
1526
 @if gnattools
1527
1527
 maybe-info-gnattools: info-gnattools
1528
1528
 
1549
1549
 
1550
1550
 @endif gnattools
1551
1551
 
1552
 
@@ -29580,24 +29902,8 @@
 
1552
@@ -30015,24 +30337,8 @@
1553
1553
 @if gnattools
1554
1554
 maybe-dvi-gnattools: dvi-gnattools
1555
1555
 
1576
1576
 
1577
1577
 @endif gnattools
1578
1578
 
1579
 
@@ -29632,24 +29938,8 @@
 
1579
@@ -30067,24 +30373,8 @@
1580
1580
 @if gnattools
1581
1581
 maybe-html-gnattools: html-gnattools
1582
1582
 
1603
1603
 
1604
1604
 @endif gnattools
1605
1605
 
1606
 
@@ -29658,24 +29948,8 @@
 
1606
@@ -30093,24 +30383,8 @@
1607
1607
 @if gnattools
1608
1608
 maybe-TAGS-gnattools: TAGS-gnattools
1609
1609
 
1630
1630
 
1631
1631
 @endif gnattools
1632
1632
 
1633
 
@@ -29684,25 +29958,8 @@
 
1633
@@ -30119,25 +30393,8 @@
1634
1634
 @if gnattools
1635
1635
 maybe-install-info-gnattools: install-info-gnattools
1636
1636
 
1658
1658
 
1659
1659
 @endif gnattools
1660
1660
 
1661
 
@@ -29765,24 +30022,8 @@
 
1661
@@ -30200,24 +30457,8 @@
1662
1662
 @if gnattools
1663
1663
 maybe-installcheck-gnattools: installcheck-gnattools
1664
1664
 
1685
1685
 
1686
1686
 @endif gnattools
1687
1687
 
1688
 
@@ -41970,13 +42211,8 @@
 
1688
@@ -42405,13 +42646,8 @@
1689
1689
 @if target-libada
1690
1690
 maybe-check-target-libada: check-target-libada
1691
1691
 
1700
1700
 
1701
1701
 @endif target-libada
1702
1702
 
1703
 
@@ -41985,13 +42221,8 @@
 
1703
@@ -42420,13 +42656,8 @@
1704
1704
 @if target-libada
1705
1705
 maybe-install-target-libada: install-target-libada
1706
1706
 
1716
1716
 
1717
1717
 @endif target-libada
1718
1718
 
1719
 
@@ -42000,13 +42231,8 @@
 
1719
@@ -42435,13 +42666,8 @@
1720
1720
 @if target-libada
1721
1721
 maybe-install-strip-target-libada: install-strip-target-libada
1722
1722
 
1732
1732
 
1733
1733
 @endif target-libada
1734
1734
 
1735
 
@@ -42017,24 +42243,8 @@
 
1735
@@ -42452,24 +42678,8 @@
1736
1736
 @if target-libada
1737
1737
 maybe-info-target-libada: info-target-libada
1738
1738
 
1759
1759
 
1760
1760
 @endif target-libada
1761
1761
 
1762
 
@@ -42043,24 +42253,8 @@
 
1762
@@ -42478,24 +42688,8 @@
1763
1763
 @if target-libada
1764
1764
 maybe-dvi-target-libada: dvi-target-libada
1765
1765
 
1786
1786
 
1787
1787
 @endif target-libada
1788
1788
 
1789
 
@@ -42095,24 +42289,8 @@
 
1789
@@ -42530,24 +42724,8 @@
1790
1790
 @if target-libada
1791
1791
 maybe-html-target-libada: html-target-libada
1792
1792
 
1813
1813
 
1814
1814
 @endif target-libada
1815
1815
 
1816
 
@@ -42121,24 +42299,8 @@
 
1816
@@ -42556,24 +42734,8 @@
1817
1817
 @if target-libada
1818
1818
 maybe-TAGS-target-libada: TAGS-target-libada
1819
1819
 
1840
1840
 
1841
1841
 @endif target-libada
1842
1842
 
1843
 
@@ -42147,25 +42309,8 @@
 
1843
@@ -42582,25 +42744,8 @@
1844
1844
 @if target-libada
1845
1845
 maybe-install-info-target-libada: install-info-target-libada
1846
1846
 
1868
1868
 
1869
1869
 @endif target-libada
1870
1870
 
1871
 
@@ -42228,24 +42373,8 @@
 
1871
@@ -42663,24 +42808,8 @@
1872
1872
 @if target-libada
1873
1873
 maybe-installcheck-target-libada: installcheck-target-libada
1874
1874
 
1895
1895
 
1896
1896
 @endif target-libada
1897
1897
 
1898
 
@@ -46729,7 +46858,7 @@
1899
 
 all-stageprofile-libcpp: maybe-all-stageprofile-intl
1900
 
 all-stagefeedback-libcpp: maybe-all-stagefeedback-intl
1901
 
 all-fixincludes: maybe-all-libiberty
 
1898
@@ -47248,7 +47377,7 @@
 
1899
 all-stage4-fixincludes: maybe-all-stage4-libiberty
 
1900
 all-stageprofile-fixincludes: maybe-all-stageprofile-libiberty
 
1901
 all-stagefeedback-fixincludes: maybe-all-stagefeedback-libiberty
1902
1902
-all-gnattools: maybe-all-target-libada
1903
1903
+all-gnattools: maybe-all-libada
 
1904
 all-gnattools: maybe-all-target-libstdc++-v3
1904
1905
 all-lto-plugin: maybe-all-libiberty
1905
1906
 
1906
 
 all-stage1-lto-plugin: maybe-all-stage1-libiberty
1907
1907
Index: b/src/configure.ac
1908
1908
===================================================================
1909
1909
--- a/src/configure.ac