~ubuntu-branches/ubuntu/trusty/gmusicbrowser/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/shimmer-layouts

  • Committer: Package Import Robot
  • Author(s): Jackson Doak
  • Date: 2014-03-08 06:19:26 UTC
  • mfrom: (1.2.8)
  • Revision ID: package-import@ubuntu.com-20140308061926-853dpa53gr1yy8lu
Tags: 1.1.12-1
* New upstream release
* debian/rules: Use make distclean rather than make clean
* debian/control:
  - Add myself to uploaders
  - Add build-depends on markdown

Show diffs side-by-side

added added

removed removed

Lines of Context:
14
14
 
15
15
--- a/gmbrc.default
16
16
+++ b/gmbrc.default
17
 
@@ -9,6 +9,16 @@
18
 
 # of the plugin found at the top of the plugin file :
 
17
@@ -10,6 +10,16 @@
19
18
 PLUGIN_LYRICS: 1
20
19
 PLUGIN_FETCHCOVER: 1
 
20
 PLUGIN_AUTOSAVE: 1
21
21
+PLUGIN_ARTISTINFO: 1
22
22
+PLUGIN_MPRIS2: 1
23
23
+
33
33
 #Layout: Small player
34
34
--- a/gmusicbrowser.pl
35
35
+++ b/gmusicbrowser.pl
36
 
@@ -497,9 +497,9 @@ our @cMenuAA=
 
36
@@ -500,9 +500,9 @@ our @cMenuAA=
37
37
 (      { label => _"Lock",     code => sub { ToggleLock($_[0]{lockfield}); }, check => sub { $::TogLock && $::TogLock eq $_[0]{lockfield}}, mode => 'P',
38
38
          test  => sub { $_[0]{field} eq $_[0]{lockfield} || $_[0]{gid} == Songs::Get_gid($::SongID,$_[0]{lockfield}); },
39
39
        },
105
105
                event   => 'Picture_artist',
106
106
                update  => \&Layout::AAPicture::Changed,
107
107
                noinit  => 1,
108
 
@@ -1588,7 +1601,7 @@ use base 'Gtk2::Window';
 
108
@@ -1594,7 +1607,7 @@ use base 'Gtk2::Window';
109
109
 sub new
110
110
 {      my ($class,$layout,%options)=@_;
111
111
        my @original_args=@_;
145
145
 }
146
146
 
147
147
 ### selected functions
148
 
@@ -1591,6 +1591,7 @@ our %Pages=
 
148
@@ -1593,6 +1593,7 @@ our %Pages=
149
149
 our @MenuMarkupOptions=
150
150
 (      "%a",
151
151
        "<b>%a</b>%Y\n<small>%s <small>%l</small></small>",
153
153
        "<b>%a</b>%Y\n<small>%b</small>",
154
154
        "<b>%a</b>%Y\n<small>%b</small>\n<small>%s <small>%l</small></small>",
155
155
        "<b>%y %a</b>",
156
 
@@ -1607,6 +1608,7 @@ my @mpicsize_menu=
 
156
@@ -1609,6 +1610,7 @@ my @mpicsize_menu=
157
157
        _("medium size")        => 64,
158
158
        _("big size")           => 96,
159
159
        _("huge size")          => 128,
161
161
 );
162
162
 my @cloudstats_menu=
163
163
 (      _("number of songs")    => 'count',
164
 
@@ -3309,7 +3311,7 @@ sub new
 
164
@@ -3312,7 +3314,7 @@ sub new
165
165
                my $BAlblist=::NewIconButton('gmb-playlist',undef,undef,'none');
166
166
                $BAlblist->signal_connect(button_press_event => \&AlbumListButton_press_cb);
167
167
                $BAlblist->set_tooltip_text(_"Choose Album From this Artist");
170
170
        }
171
171
 
172
172
        my $drgsrc=$aa eq 'album' ? ::DRAG_ALBUM : ::DRAG_ARTIST;
173
 
@@ -4601,6 +4603,16 @@ sub button_press_cb
 
173
@@ -4598,6 +4600,16 @@ sub button_press_cb
174
174
                else    { $self->{pressed}=1; }
175
175
                return 0;
176
176
        }
187
187
        if ($but==3)
188
188
        {       my ($i,$j,$key)=$self->coord_to_index($event->get_coords);
189
189
                if (defined $key && !exists $self->{selected}{$key})
190
 
@@ -5526,7 +5538,7 @@ sub new
 
190
@@ -5522,7 +5534,7 @@ sub new
191
191
        my $default= $::Options{"DefaultOptions_$name"} || {};
192
192
 
193
193
        %$opt=( @DefaultOptions, %$default, %$opt );
196
196
 
197
197
        #create widgets used to draw the songtree as a treeview, would be nice to do without but it's not possible currently
198
198
        $self->{stylewidget}=Gtk2::TreeView->new;
199
 
@@ -5592,6 +5604,16 @@ sub new
 
199
@@ -5588,6 +5600,16 @@ sub new
200
200
        $self->AddColumn($_) for split / +/,$opt->{cols};
201
201
        unless ($self->{cells}) { $self->AddColumn('title'); } #to ensure there is at least 1 column
202
202