~ubuntu-branches/ubuntu/trusty/gnomeradio/trusty

« back to all changes in this revision

Viewing changes to debian/patches/gnomeradio-about.patch

  • Committer: Package Import Robot
  • Author(s): POJAR GEORGE
  • Date: 2013-09-11 15:06:44 UTC
  • Revision ID: package-import@ubuntu.com-20130911150644-l8x3ubsyqmrvnkh8
Tags: 1.8-2ubuntu20
* Updated debian/patches/gnomeradio-station_list.patch: Prevent to parse
  malformed/incomplete/invalid XML file.
* Updated debian/patches/gnomeradio-auto_device.patch:
  - Automatically detect radio device when users type auto in settings field.
  - Updated error messages to be clear and precise.
* Updated debian/patches/gnomeradio-alsamixer.patch: Make presets list the
  default widget when open settings dialog. Presets are the most common
  settings for users than devices settings.
* Updated debian/patches/gnomeradio-about.patch: It is not safe in principle
  to write raw UTF-8 in narrow string literals, made to be multibyte
  encodings.
* debian/patches/gnomeradio-prefs.patch: Renamed to
  debian/patches/gnomeradio-about.patch.
* debian/patches/gnomeradio-preferences.patch: Make sentence capitalization in
  text and increased preferences dialog.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## Forwarded: no
6
6
Index: gnomeradio-1.8/src/gui.c
7
7
===================================================================
8
 
--- gnomeradio-1.8.orig/src/gui.c       2013-09-06 11:51:53.831095776 +0000
9
 
+++ gnomeradio-1.8/src/gui.c    2013-09-06 12:36:22.851016435 +0000
 
8
--- gnomeradio-1.8.orig/src/gui.c       2013-09-14 23:28:41.916435000 +0000
 
9
+++ gnomeradio-1.8/src/gui.c    2013-09-14 23:39:12.717222588 +0000
10
10
@@ -793,43 +793,58 @@
11
11
 }
12
12
 */
40
40
        static GtkWidget *about;
41
41
-       const char *authors[] = {"Jörgen Scheibengruber <mfcn@gmx.de>", NULL};
42
42
-       char *text;
43
 
+       const char *authors[] = {"Jörgen Scheibengruber <mfcn@gmx.de>", NULL};
 
43
+       const char *authors[] = {"J\xc3\xb6rgen Scheibengruber <mfcn@gmx.de>", NULL};
44
44
        
45
45
        /* Feel free to put your names here translators :-) */
46
46
        char *translators = _("TRANSLATORS");
75
75
-                               "logo", app_icon, NULL);
76
76
+       gtk_show_about_dialog (NULL,
77
77
+                              "version", VERSION,
78
 
+                              "copyright", _("Copyright \xc2\xa9 2001 - 2006 Jörgen Scheibengruber"),
 
78
+                              "copyright", _("Copyright \xc2\xa9 2001 - 2006 J\xc3\xb6rgen Scheibengruber"),
79
79
+                              "comments", _("Listen to FM radio"),
80
80
+                              "authors", authors,
81
81
+                              "translator-credits", strcmp("TRANSLATORS", translators) ? translators : NULL,
93
93
                                                        strcmp("TRANSLATORS", translators) ? translators : NULL, 
94
94
Index: gnomeradio-1.8/data/icons/Makefile.am
95
95
===================================================================
96
 
--- gnomeradio-1.8.orig/data/icons/Makefile.am  2013-09-06 11:51:53.831095776 +0000
97
 
+++ gnomeradio-1.8/data/icons/Makefile.am       2013-09-06 11:51:53.827095776 +0000
 
96
--- gnomeradio-1.8.orig/data/icons/Makefile.am  2013-09-14 23:28:41.916435000 +0000
 
97
+++ gnomeradio-1.8/data/icons/Makefile.am       2013-09-14 23:28:41.916435000 +0000
98
98
@@ -1,11 +1,13 @@
99
99
 SUBDIRS = 16x16 22x22 24x24 32x32 48x48 scalable
100
100