~ubuntu-branches/ubuntu/trusty/hardinfo/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/00-makefile-lib.patch

  • Committer: Package Import Robot
  • Author(s): Julien Lavergne
  • Date: 2012-12-20 14:56:55 UTC
  • mfrom: (3.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20121220145655-765johf2jxuh2iya
Tags: 0.5.1-1.2ubuntu1
* Merge from Debian testing. Ubuntu remaining changes :
* debian/rules:
 - Don't install anything in /usr/local, otherwise FTBFS.
 - Add quilt support.
* debian/control:
 - Add homepage field
 - Build-Depends on quilt.
 - Add ${misc:Depends} to hardinfo runtime Depends field.
 - Recommends lm-sensors to read information from sensors. (LP: #178600)
* debian/patches:
 - 00-makefile-lib: Convert previous source modification to quilt patch.
 - 01-truncated_description.patch: Add to fix LP: #357189.
 - 02-fix-distro-crash.patch: From upstream, fix a crash when trying to get
   distro informations. (LP: #450447).
 - 03-detect-lxde.patch: Detect LXDE and Lubuntu from XDG_CURRENT_DESKTOP and
   DESKTOP_SESSION environment variables.  (LP: #778148)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- hardinfo-0.5.1.orig/binreloc.c
 
2
+++ hardinfo-0.5.1/binreloc.c
 
3
@@ -594,7 +594,7 @@ gchar *gbr_find_lib_dir(const gchar * de
 
4
     }
 
5
 
 
6
 #ifdef ARCH_x86_64
 
7
-    dir = g_build_filename(prefix, "lib64", NULL);
 
8
+    dir = g_build_filename(prefix, "lib", NULL);
 
9
 #else
 
10
     dir = g_build_filename(prefix, "lib", NULL);
 
11
 #endif
 
12
--- /dev/null
 
13
+++ hardinfo-0.5.1/config.h
 
14
@@ -0,0 +1,17 @@
 
15
+#ifndef __CONFIG_H__
 
16
+#define __CONFIG_H__
 
17
+
 
18
+#define VERSION "0.5.1"
 
19
+#define ARCH_i386
 
20
+#define ARCH     "ARCH_i386"
 
21
+#define PLATFORM "Linux"
 
22
+#define KERNEL   "2.6.30-1-686"
 
23
+#define HOSTNAME "comanche"
 
24
+#define PREFIX "/usr/share/hardinfo/"
 
25
+#define LIBPREFIX "/usr/lib/hardinfo/"
 
26
+#define HAS_LINUX_WE
 
27
+#define DEBUG(...)
 
28
+#define ENABLE_BINRELOC 1
 
29
+#define RELEASE 1
 
30
+
 
31
+#endif /* __CONFIG_H__ */
 
32
--- /dev/null
 
33
+++ hardinfo-0.5.1/Makefile
 
34
@@ -0,0 +1,97 @@
 
35
+GTK_LIBS = -lpthread -lgthread-2.0 -lrt -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lgio-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0  
 
36
+GTK_CFLAGS = -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  
 
37
+SOUP_LIBS = 
 
38
+SOUP_CFLAGS = 
 
39
+PACKAGE = hardinfo-0.5.1
 
40
+ARCHOPTS = 
 
41
+LIBDIR = /usr/lib
 
42
+
 
43
+CCFLAGS = -fPIC -pipe -Wall -g 
 
44
+CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I.
 
45
+CC = gcc $(ARCHOPTS) -g
 
46
+CCSLOW = gcc -O0 -g
 
47
+
 
48
+# ----------------------------------------------------------------------------
 
49
+
 
50
+OBJECTS = hardinfo.o shell.o util.o iconcache.o loadgraph.o  \
 
51
+               menu.o stock.o callbacks.o expr.o report.o binreloc.o \
 
52
+               vendor.o socket.o syncmanager.o
 
53
+BENCHMARK_OBJECTS = fbench.o sha1.o blowfish.o md5.o nqueens.o fftbench.o
 
54
+
 
55
+MODULES = computer.so devices.so benchmark.so network.so
 
56
+
 
57
+all:   $(OBJECTS) $(MODULES)
 
58
+       $(CC) $(CCFLAGS) -o hardinfo -Wl,-export-dynamic $(OBJECTS) $(GTK_LIBS) \
 
59
+               $(SOUP_LIBS)
 
60
+
 
61
+md5.o:
 
62
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c md5.c -o $@
 
63
+
 
64
+blowfish.o:
 
65
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c blowfish.c -o $@
 
66
+
 
67
+sha1.o:
 
68
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c sha1.c -o $@
 
69
+
 
70
+fbench.o:
 
71
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c fbench.c -o $@
 
72
+
 
73
+fftbench.o:
 
74
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c fftbench.c -o $@
 
75
+
 
76
+nqueens.o:
 
77
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c nqueens.c -o $@
 
78
+
 
79
+benchmark.so:  benchmark.c
 
80
+       make $(BENCHMARK_OBJECTS)
 
81
+       $(CCSLOW) $(CCFLAGS) $(CFLAGS) -o $@ -shared $< $(BENCHMARK_OBJECTS) \
 
82
+               $(GTK_FLAGS) $(GTK_LIBS)
 
83
+       ln -sf ../$@ modules
 
84
+
 
85
+%.so:  %.c
 
86
+       $(CC) $(CCFLAGS) $(CFLAGS) -o $@ -shared $< $(GTK_FLAGS) $(GTK_LIBS)
 
87
+       ln -sf ../$@ modules
 
88
+       
 
89
+clean:
 
90
+       rm -rf .xvpics pixmaps/.xvpics *.o *.so hardinfo modules/*.so report
 
91
+       find . -name \*~ -exec rm -v {} \;
 
92
+       find . -name x86 -type l -exec rm -v {} \;
 
93
+
 
94
+dist-clean:    clean
 
95
+       rm -rf Makefile debian/hardinfo/ config.h arch/this
 
96
+
 
97
+package:       dist-clean
 
98
+       @echo "Creating tar.gz..."
 
99
+       cd .. && tar czf $(PACKAGE).tar.gz $(PACKAGE)/* && cd $(PACKAGE)
 
100
+       @echo "Creating tar.bz2..."
 
101
+       cd .. && tar cjf $(PACKAGE).tar.bz2 $(PACKAGE)/* && cd $(PACKAGE)
 
102
+
 
103
+deb:   dist-clean
 
104
+       @echo "Creating deb..."
 
105
+       dpkg-buildpackage -rfakeroot -k${USER}
 
106
+
 
107
+install:       all
 
108
+       rm -rf ${DESTDIR}${LIBDIR}/hardinfo/modules ${DESTDIR}/usr/share/hardinfo/pixmaps
 
109
+
 
110
+       mkdir -p ${DESTDIR}/usr/bin
 
111
+       mkdir -p ${DESTDIR}/usr/local
 
112
+       mkdir -p ${DESTDIR}/usr/share/applications
 
113
+       mkdir -p ${DESTDIR}${LIBDIR}/hardinfo/modules
 
114
+       mkdir -p ${DESTDIR}/usr/share/hardinfo/pixmaps
 
115
+
 
116
+       cp hardinfo.desktop ${DESTDIR}/usr/share/applications
 
117
+
 
118
+       cp hardinfo ${DESTDIR}/usr/bin/hardinfo
 
119
+
 
120
+       cp -Lr modules/*.so ${DESTDIR}${LIBDIR}/hardinfo/modules
 
121
+
 
122
+       cp -Lr pixmaps/* ${DESTDIR}/usr/share/hardinfo/pixmaps
 
123
+
 
124
+       cp benchmark.conf ${DESTDIR}/usr/share/hardinfo
 
125
+       cp benchmark.data ${DESTDIR}/usr/share/hardinfo
 
126
+
 
127
+       chmod 755 ${DESTDIR}/usr/bin/hardinfo
 
128
+
 
129
+installer:
 
130
+       makepackage
 
131
+       
 
132
--- hardinfo-0.5.1.orig/configure
 
133
+++ hardinfo-0.5.1/configure
 
134
@@ -56,7 +56,7 @@ case $PROC in
 
135
        x86_64)
 
136
                ln -sf linux/x86_64 arch/this
 
137
                ARCH="ARCH_x86_64"
 
138
-               LIBDIR="/usr/lib64" ;;
 
139
+               LIBDIR="/usr/lib" ;;
 
140
        mips*)
 
141
                ln -sf linux/mips arch/this
 
142
                ARCH="ARCH_MIPS" ;;