~ubuntu-branches/ubuntu/trusty/hfsprogs/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/00-create_makefiles.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rogério Brito
  • Date: 2009-03-03 11:26:11 UTC
  • Revision ID: james.westby@ubuntu.com-20090303112611-prd4w8vuqk34qbvc
Tags: 332.14-6
debian/patches/*: include description (lintian).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: hfsprogs-332.14/Makefile.lnx
2
 
===================================================================
3
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4
 
+++ hfsprogs-332.14/Makefile.lnx        2008-10-07 05:08:06.000000000 -0300
 
1
Author: Rogério Brito <rbrito@ime.usp.br>
 
2
Description:
 
3
 Create short Makefiles for compiling just the necessary parts for a
 
4
 Debian-based (and possibly other distributions) HFS+ filesystem
 
5
 utilities.
 
6
--- /dev/null
 
7
+++ b/Makefile.lnx
5
8
@@ -0,0 +1,8 @@
6
9
+CC := gcc
7
10
+CFLAGS := -g3 -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1
11
14
+       for d in $(SUBDIRS); do $(MAKE) -C $$d -f Makefile.lnx $@; done
12
15
+
13
16
+export CC CFLAGS
14
 
Index: hfsprogs-332.14/fsck_hfs.tproj/Makefile.lnx
15
 
===================================================================
16
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
17
 
+++ hfsprogs-332.14/fsck_hfs.tproj/Makefile.lnx 2008-10-07 05:08:06.000000000 -0300
 
17
--- /dev/null
 
18
+++ b/fsck_hfs.tproj/Makefile.lnx
18
19
@@ -0,0 +1,15 @@
19
20
+CFILES = fsck_hfs.c strings.c utilities.c cache.c
20
21
+OFILES = $(CFILES:.c=.o)
31
32
+       $(MAKE) -C dfalib -f Makefile.lnx clean
32
33
+
33
34
+.PHONY : FORCE clean
34
 
Index: hfsprogs-332.14/fsck_hfs.tproj/dfalib/Makefile.lnx
35
 
===================================================================
36
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
37
 
+++ hfsprogs-332.14/fsck_hfs.tproj/dfalib/Makefile.lnx  2008-10-07 05:08:06.000000000 -0300
 
35
--- /dev/null
 
36
+++ b/fsck_hfs.tproj/dfalib/Makefile.lnx
38
37
@@ -0,0 +1,15 @@
39
38
+CFILES = hfs_endian.c BlockCache.c\
40
39
+         BTree.c BTreeAllocate.c BTreeMiscOps.c \
51
50
+
52
51
+clean:
53
52
+       $(RM) $(OFILES) libdfa.a
54
 
Index: hfsprogs-332.14/newfs_hfs.tproj/Makefile.lnx
55
 
===================================================================
56
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
57
 
+++ hfsprogs-332.14/newfs_hfs.tproj/Makefile.lnx        2008-10-07 05:08:06.000000000 -0300
 
53
--- /dev/null
 
54
+++ b/newfs_hfs.tproj/Makefile.lnx
58
55
@@ -0,0 +1,12 @@
59
56
+CFILES = hfs_endian.c makehfs.c newfs_hfs.c
60
57
+OFILES = $(CFILES:.c=.o)