~ubuntu-branches/ubuntu/trusty/ibus/trusty

« back to all changes in this revision

Viewing changes to debian/patches/ibus-530711-preload-sys.patch

  • Committer: Package Import Robot
  • Author(s): Ikuya Awashiro
  • Date: 2014-02-03 22:34:56 UTC
  • mfrom: (39.1.11 sid)
  • Revision ID: package-import@ubuntu.com-20140203223456-amzf73jp5qt59rrr
Tags: 1.5.5-1ubuntu1
* Merge with Debian (LP: #1276143); remaining changes: 
  - debian/rules:
    + Build with dh_translations. Add dh-translations build dependency.
  - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
    Methods"
  - debian/patches/ibus-no-notification.patch: Don't show the notification
    if not actually upgrading from a previous version. (LP: #1255542).
* debian/patches/03_dont_run_dconf_update.patch: added
  -  Don't run "dconf update" if $(DESTDIR) is set
    + https://github.com/ibus/ibus/commit/e6ec45d64a32d16245770f8b80e795a63e6ad553

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From d566bc83a4672b88a38fa5de25741b99ebaeae62 Mon Sep 17 00:00:00 2001
 
1
From a6d4b9ac9a22c5b88c362b659eaf6fd59a0cf5bd Mon Sep 17 00:00:00 2001
2
2
From: fujiwarat <takao.fujiwara1@gmail.com>
3
 
Date: Fri, 20 Sep 2013 17:20:09 +0900
 
3
Date: Tue, 14 Jan 2014 15:30:24 +0900
4
4
Subject: [PATCH] Reload preload engines until users customize the list.
5
5
 
6
6
The idea is, if users don't customize the preload_engines with ibus-setup,
24
24
 ui/gtk3/panel.vala   | 93 ++++++++++++++++++++++++++++++++++++++++++++++++++++
25
25
 5 files changed, 210 insertions(+), 9 deletions(-)
26
26
 
 
27
diff --git a/data/ibus.schemas.in b/data/ibus.schemas.in
 
28
index 8fd7e15..28d2219 100644
27
29
--- a/data/ibus.schemas.in
28
30
+++ b/data/ibus.schemas.in
29
31
@@ -2,6 +2,30 @@
57
59
       <key>/schemas/desktop/ibus/general/preload_engines</key>
58
60
       <applyto>/desktop/ibus/general/preload_engines</applyto>
59
61
       <owner>ibus</owner>
 
62
diff --git a/setup/main.py b/setup/main.py
 
63
index d3f4414..235ef9c 100644
60
64
--- a/setup/main.py
61
65
+++ b/setup/main.py
62
 
@@ -187,16 +187,30 @@
 
66
@@ -187,16 +187,30 @@ class Setup(object):
63
67
                                     'active',
64
68
                                     Gio.SettingsBindFlags.DEFAULT)
65
69
 
94
98
 
95
99
         self.__treeview = self.__builder.get_object("treeview_engines")
96
100
         self.__treeview.set_engines(engines)
97
 
@@ -246,8 +260,8 @@
 
101
@@ -246,8 +260,8 @@ class Setup(object):
98
102
     def __combobox_notify_active_engine_cb(self, combobox, property):
99
103
         engine = self.__combobox.get_active_engine()
100
104
         button = self.__builder.get_object("button_engine_add")
105
109
 
106
110
     def __get_engine_setup_exec_args(self, engine):
107
111
         args = []
108
 
@@ -267,6 +281,13 @@
 
112
@@ -267,6 +281,13 @@ class Setup(object):
109
113
             args.append(path.basename(setup_path))
110
114
         return args
111
115
 
119
123
     def __treeview_notify_cb(self, treeview, prop):
120
124
         if prop.name not in ("active-engine", "engines"):
121
125
             return
122
 
@@ -318,6 +339,43 @@
 
126
@@ -318,6 +339,43 @@ class Setup(object):
123
127
             del self.__engine_setup_exec_list[name]
124
128
         self.__engine_setup_exec_list[name] = os.spawnl(os.P_NOWAIT, *args)
125
129
 
163
167
     def __init_bus(self):
164
168
         self.__bus = IBus.Bus()
165
169
         if self.__bus.is_connected():
 
170
diff --git a/setup/setup.ui b/setup/setup.ui
 
171
index 65dcee4..a6a001b 100644
166
172
--- a/setup/setup.ui
167
173
+++ b/setup/setup.ui
168
174
@@ -669,7 +669,23 @@
208
214
                       </packing>
209
215
                     </child>
210
216
                   </object>
 
217
diff --git a/src/ibustypes.h b/src/ibustypes.h
 
218
index 86fc2cc..cb9eb22 100644
211
219
--- a/src/ibustypes.h
212
220
+++ b/src/ibustypes.h
213
 
@@ -204,6 +204,16 @@
 
221
@@ -206,6 +206,16 @@ typedef enum {
214
222
 } IBusError;
215
223
 
216
224
 /**
227
235
  * IBusRectangle:
228
236
  * @x: x coordinate.
229
237
  * @y: y coordinate.
 
238
diff --git a/ui/gtk3/panel.vala b/ui/gtk3/panel.vala
 
239
index 1da7966..fc60fd4 100644
230
240
--- a/ui/gtk3/panel.vala
231
241
+++ b/ui/gtk3/panel.vala
232
 
@@ -130,6 +130,10 @@
 
242
@@ -136,6 +136,10 @@ class Panel : IBus.PanelService {
233
243
                                null);
234
244
         });
235
245
 
240
250
         m_settings_general.changed["switcher-delay-time"].connect((key) => {
241
251
                 set_switcher_delay_time();
242
252
         });
243
 
@@ -493,7 +497,96 @@
 
253
@@ -524,7 +528,96 @@ class Panel : IBus.PanelService {
244
254
             init_gkbd();
245
255
         }
246
256
 
319
329
+                preload_engines += name;
320
330
+        }
321
331
+
322
 
+        if ("".joinv(",", orig_preload_engines) !=
323
 
+            "".joinv(",", preload_engines))
 
332
+        if (string.joinv(",", orig_preload_engines) !=
 
333
+            string.joinv(",", preload_engines))
324
334
+            m_settings_general.set_strv("preload-engines", preload_engines);
325
335
+
326
336
+        return true;
337
347
     }
338
348
 
339
349
     private void update_xkb_engines() {
 
350
-- 
 
351
1.8.0
 
352