~ubuntu-branches/ubuntu/trusty/indicator-sync/trusty

« back to all changes in this revision

Viewing changes to debian/patches/upstream-watchers-client-test.patch

  • Committer: Package Import Robot
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2012-08-28 16:25:25 UTC
  • mfrom: (1.1.1)
  • Revision ID: package-import@ubuntu.com-20120828162525-v3mx9o332fqrseu8
Tags: 12.10.1-0ubuntu1
* New upstream release.
* debian/control:
  - rename gir1.2-syncclient-12.10 to gir1.2-syncmenu-0.1.
  - rename libindicator-sync-client1 to libsync-menu1.
  - rename libindicator-sync-client-dev to libsync-menu-dev.
  - add gir1.2-dbusmenu-glib-0.4 to Build-Depends.
  - add dbus-test-runner to Build-Depends.
* debian/*.install:
  - rename files as per package name changes.
  - update libsync-menu-dev.install to the library name.
  - update libsync-menu1.install to the library name.
  - update libsync-menu1.symbols to the library name.
  - rename /usr/include/indicator-sync-0.1 to /usr/include/sync-menu-0.1.
* debian/patches/upstream-soname-versioning.patch,
  debian/patches/upstream-pkgconfig-fixes.patch: dropped, no longer needed.
* debian/libsync-menu1.symbols:
  - update symbols that were renamed; keep the old ones as missing.
* debian/patches/upstream-watchers-client-test.patch: fix up the client test
  to avoid failing due to watchers not being allowed to connect.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Charles Kerr <charles.kerr@canonical.com>
 
2
Subject: Unset INDICATOR_ALLOW_NO_WATCHERS.
 
3
 
 
4
---
 
5
 test/test-client.cpp |    1 +
 
6
 1 file changed, 1 insertion(+)
 
7
 
 
8
Index: b/test/test-client.cpp
 
9
===================================================================
 
10
--- a/test/test-client.cpp
 
11
+++ b/test/test-client.cpp
 
12
@@ -29,6 +29,7 @@ class ClientTest : public ::testing::Tes
 
13
       if (!ran_once_init)
 
14
         {
 
15
           g_type_init();
 
16
+          g_unsetenv ("INDICATOR_ALLOW_NO_WATCHERS");
 
17
           g_unsetenv ("INDICATOR_SERVICE_REPLACE_MODE");
 
18
           ran_once_init = true;
 
19
         }