~ubuntu-branches/ubuntu/trusty/irssi-plugin-xmpp/trusty

« back to all changes in this revision

Viewing changes to debian/patches/hardening.patch

  • Committer: Package Import Robot
  • Author(s): Florian Schlichting
  • Date: 2013-05-06 00:03:37 UTC
  • mfrom: (2.2.6 sid)
  • Revision ID: package-import@ubuntu.com-20130506000337-mx1lxwp0tu15j1eb
Tags: 0.52-2
* Added hardening.patch to actually use the dpkg-buildflags.
* Dropped version on irssi(-dev) dependency
* Email change: Florian Schlichting -> fsfs@debian.org
* Patches plucked from upstream CVS:
  + kill-the-stroneline-function (closes: #693079)
  + fix-crash-on-empty-resource
  + replace-deprecated-g_strncasecmp

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: enable the use of dh-provided hardening flags
 
2
Author: Florian Schlichting <fsfs@debian.org>
 
3
 
 
4
--- a/config.mk
 
5
+++ b/config.mk
 
6
@@ -22,8 +22,8 @@
 
7
 LIBS = ${LIB_LIBS}
 
8
 
 
9
 # flags
 
10
-CFLAGS = -fPIC -std=c99 -DUOFF_T_LONG
 
11
-LDFLAGS = -shared
 
12
+CFLAGS += -fPIC -std=c99 -DUOFF_T_LONG
 
13
+LDFLAGS += -shared
 
14
 
 
15
 # debug
 
16
 #CFLAGS += -W -g -Wall -Wno-unused-parameter
 
17
--- a/src/rules.mk
 
18
+++ b/src/rules.mk
 
19
@@ -9,7 +9,7 @@
 
20
 all: ${LIBSO}
 
21
 
 
22
 .c.o:
 
23
-       ${CC} ${CFLAGS} ${INCS} -o $@ -c $<
 
24
+       ${CC} ${CPPFLAGS} ${CFLAGS} ${INCS} -o $@ -c $<
 
25
 
 
26
 ${LIBSO}: ${OBJS}
 
27
        ${CC} ${LDFLAGS} -o $@ ${OBJS} ${LIBS}