~ubuntu-branches/ubuntu/trusty/libdv/trusty

« back to all changes in this revision

Viewing changes to debian/patches/10_zap_config_h.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Kobras
  • Date: 2006-09-26 14:22:15 UTC
  • mfrom: (1.3.1 upstream) (3.1.4 edgy)
  • Revision ID: james.westby@ubuntu.com-20060926142215-q2arp4stpw6lrb5p
Tags: 1.0.0-1
* New upstream version.
* Removed patches:
  + [01_changelog_update_CVS]
  + [10_amd64_linkage_fix_CVS]
  + [10_inline_fixes_CVS]
  + [20_no_exec_stack_CVS]
  + [30_unload_memleak_fix_CVS]
  + [40_playdv_exit_fix_CVS]
  + [50_gcc41_asm_constraint_fixes_CVS]
    All of the above are part of the new upstream version.
* debian/control: In Build-Depends, remove alternative dependencies on
  obsolete SDL and X packages.
* debian/control: Complies with version 3.7.2 of Debian policy.
* debian/libdv4.README.Debian: Document lack of position-independent code
  in i386 version of libdv's shared library as mandated by recent versions
  of Debian policy.

Show diffs side-by-side

added added

removed removed

Lines of Context:
28
28
exit 0
29
29
 
30
30
@DPATCH@
31
 
diff -urNad /home/kobras/src/debian/libdv/libdv/dv_types.h libdv/libdv/dv_types.h
32
 
--- /home/kobras/src/debian/libdv/libdv/dv_types.h      2004-01-19 13:06:50.000000000 +0100
33
 
+++ libdv/libdv/dv_types.h      2004-01-19 22:54:06.000000000 +0100
 
31
diff -urNad --exclude=CVS --exclude=.svn ./libdv/dv_types.h /tmp/dpep-work.X4gSie/libdv/libdv/dv_types.h
 
32
--- ./libdv/dv_types.h  2005-07-10 19:31:16.000000000 +0200
 
33
+++ /tmp/dpep-work.X4gSie/libdv/libdv/dv_types.h        2005-07-10 19:58:28.000000000 +0200
34
34
@@ -26,10 +26,11 @@
35
35
 #ifndef DV_TYPES_H
36
36
 #define DV_TYPES_H
48
48
 #include <popt.h>
49
49
 #endif // HAVE_LIBPOPT
50
50
@@ -38,11 +39,11 @@
51
 
 #include <stdint.h>
 
51
 #include <inttypes.h>
52
52
 #include <stdio.h>
53
53
 #include <time.h>
54
54
-#if HAVE_ENDIAN_H
63
63
 
64
64
 /* please tell me these are defined somewhere standard??? */
65
65
 #ifndef FALSE
66
 
@@ -61,11 +62,22 @@
 
66
@@ -61,16 +62,33 @@
67
67
 #define CLAMP(a,x,b) (MIN(b,MAX(a,x)))
68
68
 #endif
69
69
 
70
 
+/* FIXME This value indicates whether libdv was built with asm optimizations.
71
 
+ * It had better be AC_SUBSTed, but for the purpose of the Debian package,
72
 
+ * we can easily guess the correct value from standard compiler macros.
 
70
+/* FIXME These values indicate whether libdv was built with asm optimizations.
 
71
+ * It had better be AC_SUBSTed, but for the purpose of the Debian package, we
 
72
+ * can easily guess the correct value from standard compiler macros.
73
73
+ */
74
 
+#ifndef ARCH_X86
75
 
+# ifdef i386
 
74
+#if !defined(ARCH_X86) && !defined(ARCH_X86_64)
 
75
+# if defined (__x86_64)
 
76
+#  define ARCH_X86 0
 
77
+#  define ARCH_X86_64 1
 
78
+# elif defined(i386)
76
79
+#  define ARCH_X86 1
 
80
+#  define ARCH_X86_64 0
77
81
+# else
78
82
+#  define ARCH_X86 0
 
83
+#  define ARCH_X86_64 0
79
84
+# endif
80
85
+#endif
 
86
+                              
81
87
 // For now assume ARCH_X86 means GCC with hints.
82
 
-#define HAVE_GCC ARCH_X86
 
88
 #ifdef ARCH_X86
 
89
-#define HAVE_GCC 1
 
90
+#define LIBDV_HAVE_GCC 1
 
91
 #endif
 
92
 #ifdef ARCH_X86_64
 
93
-#define HAVE_GCC 1
 
94
+#define LIBDV_HAVE_GCC 1
 
95
 #endif
83
96
-//#define HAVE_GCC 0
84
 
+#define LIBDV_HAVE_GCC ARCH_X86
85
97
+//#define LIBDV_HAVE_GCC 0
86
98
 
87
99
-#if HAVE_GCC