~ubuntu-branches/ubuntu/trusty/lv/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bts.660358.diff

  • Committer: Package Import Robot
  • Author(s): HIGUCHI Daisuke (VDR dai)
  • Date: 2014-03-15 03:42:28 UTC
  • Revision ID: package-import@ubuntu.com-20140315034228-6lcwgjiug8rym3wc
Tags: 4.51-2.2
* Non-maintainer upload.
* debian/control, debian/rules, debian/compat: use dh9.
* debian/control
  - add Vcs-* tags.
  - add Homepage: tag.
  - add ${misc:Depends} to Depends:.
  - add xz-utils to Recommends:.
* debian/source/format: set 3.0 (quilt).
* debian/patches/*: rename from debian/patch* and add DEP-3 headers.
* debian/copyright: convert to DEP-5.
* debian/patches/fix-hyphen-used-as-minus-sign.diff: new file.
* debian/lv.doc-base: new file.
* bump up Standards-Version 3.9.5

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: support automatic xz and lzma decompression.
 
2
Author: "A. N. Other" <a.n.other.debian@gmail.com>
 
3
Last-Update: 2012-02-18
 
4
 
 
5
--- a/src/stream.c
 
6
+++ b/src/stream.c
 
7
@@ -43,6 +43,8 @@
 
8
 
 
9
 private byte *gz_filter = "zcat";
 
10
 private byte *bz2_filter = "bzcat";
 
11
+private byte *lzma_filter = "lzcat";
 
12
+private byte *xz_filter = "xzcat";
 
13
 
 
14
 private stream_t *StreamAlloc()
 
15
 {
 
16
@@ -75,10 +77,14 @@ public stream_t *StreamOpen( byte *file )
 
17
       filter = gz_filter;
 
18
     else if( !strcmp( "bz2", exts ) || !strcmp( "BZ2", exts ) )
 
19
       filter = bz2_filter;
 
20
+    else if ( !strcmp( "lzma", exts ) )
 
21
+      filter = lzma_filter;
 
22
+    else if ( !strcmp( "xz", exts ) )
 
23
+      filter = xz_filter;
 
24
   }
 
25
   if( NULL != filter ){
 
26
     /*
 
27
-     * zcat or bzcat
 
28
+     * zcat, bzcat etc.
 
29
      */
 
30
     if( NULL == (st->fp = (FILE *)tmpfile()) )
 
31
       perror( "temporary file" ), exit( -1 );
 
32
 
 
33