~ubuntu-branches/ubuntu/trusty/mediatomb/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ffmpeg_headers_location.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2009-01-08 11:18:48 UTC
  • Revision ID: james.westby@ubuntu.com-20090108111848-n3li11ga4hhlyvcg
Tags: 0.11.0-3ubuntu2
Added ffmpeg_headers_location.patch to fix ffmpeg headers location,
fixes FTBFS (LP: #311180).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: mediatomb-0.11.0/configure
 
2
===================================================================
 
3
--- mediatomb-0.11.0.orig/configure     2009-01-08 10:55:30.000000000 +0100
 
4
+++ mediatomb-0.11.0/configure  2009-01-08 10:55:53.000000000 +0100
 
5
@@ -26123,9 +26123,9 @@
 
6
 if test "x$FFMPEG_OK" = xyes; then
 
7
     if test -n "$FFMPEG_SEARCH_HEADERS" ; then
 
8
         CPPFLAGS="-I$FFMPEG_SEARCH_HEADERS"
 
9
-        as_ac_Header=`echo "ac_cv_header_$FFMPEG_SEARCH_HEADERS/ffmpeg/avformat.h" | $as_tr_sh`
 
10
-{ echo "$as_me:$LINENO: checking for $FFMPEG_SEARCH_HEADERS/ffmpeg/avformat.h" >&5
 
11
-echo $ECHO_N "checking for $FFMPEG_SEARCH_HEADERS/ffmpeg/avformat.h... $ECHO_C" >&6; }
 
12
+        as_ac_Header=`echo "ac_cv_header_$FFMPEG_SEARCH_HEADERS/libavformat/avformat.h" | $as_tr_sh`
 
13
+{ echo "$as_me:$LINENO: checking for $FFMPEG_SEARCH_HEADERS/libavformat/avformat.h" >&5
 
14
+echo $ECHO_N "checking for $FFMPEG_SEARCH_HEADERS/libavformat/avformat.h... $ECHO_C" >&6; }
 
15
 if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
 
16
   echo $ECHO_N "(cached) $ECHO_C" >&6
 
17
 else
 
18
@@ -26141,7 +26141,7 @@
 
19
 
 
20
 
 
21
 
 
22
-#include <$FFMPEG_SEARCH_HEADERS/ffmpeg/avformat.h>
 
23
+#include <$FFMPEG_SEARCH_HEADERS/libavformat/avformat.h>
 
24
 _ACEOF
 
25
 rm -f conftest.$ac_objext
 
26
 if { (ac_try="$ac_compile"
 
27
@@ -26187,8 +26187,8 @@
 
28
 
 
29
 
 
30
     else
 
31
-        { echo "$as_me:$LINENO: checking for ffmpeg/avformat.h" >&5
 
32
-echo $ECHO_N "checking for ffmpeg/avformat.h... $ECHO_C" >&6; }
 
33
+        { echo "$as_me:$LINENO: checking for libavformat/avformat.h" >&5
 
34
+echo $ECHO_N "checking for libavformat/avformat.h... $ECHO_C" >&6; }
 
35
 if test "${ac_cv_header_ffmpeg_avformat_h+set}" = set; then
 
36
   echo $ECHO_N "(cached) $ECHO_C" >&6
 
37
 else
 
38
@@ -26204,7 +26204,7 @@
 
39
 
 
40
 
 
41
 
 
42
-#include <ffmpeg/avformat.h>
 
43
+#include <libavformat/avformat.h>
 
44
 _ACEOF
 
45
 rm -f conftest.$ac_objext
 
46
 if { (ac_try="$ac_compile"
 
47
@@ -26241,9 +26241,9 @@
 
48
 
 
49
                 CPPFLAGS="-I$SEARCH_DIR_HEADERS"
 
50
                 unset ac_cv_header_ffmpeg_avformat_h
 
51
-                as_ac_Header=`echo "ac_cv_header_$SEARCH_DIR_HEADERS/ffmpeg/avformat.h" | $as_tr_sh`
 
52
-{ echo "$as_me:$LINENO: checking for $SEARCH_DIR_HEADERS/ffmpeg/avformat.h" >&5
 
53
-echo $ECHO_N "checking for $SEARCH_DIR_HEADERS/ffmpeg/avformat.h... $ECHO_C" >&6; }
 
54
+                as_ac_Header=`echo "ac_cv_header_$SEARCH_DIR_HEADERS/libavformat/avformat.h" | $as_tr_sh`
 
55
+{ echo "$as_me:$LINENO: checking for $SEARCH_DIR_HEADERS/libavformat/avformat.h" >&5
 
56
+echo $ECHO_N "checking for $SEARCH_DIR_HEADERS/libavformat/avformat.h... $ECHO_C" >&6; }
 
57
 if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
 
58
   echo $ECHO_N "(cached) $ECHO_C" >&6
 
59
 else
 
60
@@ -26259,7 +26259,7 @@
 
61
 
 
62
 
 
63
 
 
64
-#include <$SEARCH_DIR_HEADERS/ffmpeg/avformat.h>
 
65
+#include <$SEARCH_DIR_HEADERS/libavformat/avformat.h>
 
66
 _ACEOF
 
67
 rm -f conftest.$ac_objext
 
68
 if { (ac_try="$ac_compile"
 
69
@@ -26846,7 +26846,7 @@
 
70
 
 
71
                 #define __STDC_CONSTANT_MACROS
 
72
                 #include <stdint.h>
 
73
-                #include <ffmpeg/avformat.h>
 
74
+                #include <libavformat/avformat.h>
 
75
 
 
76
 int
 
77
 main ()
 
78
@@ -26895,7 +26895,7 @@
 
79
                     #define __STDC_CONSTANT_MACROS
 
80
                     #include <stdint.h>
 
81
                     extern "C" {
 
82
-                        #include <ffmpeg/avformat.h>
 
83
+                        #include <libavformat/avformat.h>
 
84
                     }
 
85
 
 
86
 int
 
87
Index: mediatomb-0.11.0/configure.ac
 
88
===================================================================
 
89
--- mediatomb-0.11.0.orig/configure.ac  2009-01-08 10:56:02.000000000 +0100
 
90
+++ mediatomb-0.11.0/configure.ac       2009-01-08 10:56:20.000000000 +0100
 
91
@@ -2327,7 +2327,7 @@
 
92
 if test "x$FFMPEG_OK" = xyes; then
 
93
     if test -n "$FFMPEG_SEARCH_HEADERS" ; then
 
94
         CPPFLAGS="-I$FFMPEG_SEARCH_HEADERS"
 
95
-        AC_CHECK_HEADER($FFMPEG_SEARCH_HEADERS/ffmpeg/avformat.h,
 
96
+        AC_CHECK_HEADER($FFMPEG_SEARCH_HEADERS/libavformat/avformat.h,
 
97
                 [
 
98
                     FFMPEG_CXXFLAGS="-I$FFMPEG_SEARCH_HEADERS"
 
99
                 ],
 
100
@@ -2340,12 +2340,12 @@
 
101
                 ]
 
102
         )
 
103
     else 
 
104
-        AC_CHECK_HEADER(ffmpeg/avformat.h,
 
105
+        AC_CHECK_HEADER(libavformat/avformat.h,
 
106
             [],
 
107
             [
 
108
                 CPPFLAGS="-I$SEARCH_DIR_HEADERS"
 
109
                 unset ac_cv_header_ffmpeg_avformat_h
 
110
-                AC_CHECK_HEADER($SEARCH_DIR_HEADERS/ffmpeg/avformat.h,
 
111
+                AC_CHECK_HEADER($SEARCH_DIR_HEADERS/libavformat/avformat.h,
 
112
                     [
 
113
                         FFMPEG_CXXFLAGS="-I$SEARCH_DIR_HEADERS"
 
114
                     ],
 
115
@@ -2447,7 +2447,7 @@
 
116
             [
 
117
                 #define __STDC_CONSTANT_MACROS
 
118
                 #include <stdint.h>
 
119
-                #include <ffmpeg/avformat.h>
 
120
+                #include <libavformat/avformat.h>
 
121
             ],
 
122
             [
 
123
                 av_register_all();
 
124
@@ -2462,7 +2462,7 @@
 
125
                     #define __STDC_CONSTANT_MACROS
 
126
                     #include <stdint.h>
 
127
                     extern "C" {
 
128
-                        #include <ffmpeg/avformat.h>
 
129
+                        #include <libavformat/avformat.h>
 
130
                     }
 
131
                 ],
 
132
                 [
 
133
Index: mediatomb-0.11.0/src/metadata/ffmpeg_handler.cc
 
134
===================================================================
 
135
--- mediatomb-0.11.0.orig/src/metadata/ffmpeg_handler.cc        2009-01-08 10:56:32.000000000 +0100
 
136
+++ mediatomb-0.11.0/src/metadata/ffmpeg_handler.cc     2009-01-08 10:56:45.000000000 +0100
 
137
@@ -56,7 +56,7 @@
 
138
 {
 
139
 #endif
 
140
 
 
141
-#include <ffmpeg/avformat.h>
 
142
+#include <libavformat/avformat.h>
 
143
 
 
144
 #ifdef FFMPEG_NEEDS_EXTERN_C
 
145
 } // extern "C"