~ubuntu-branches/ubuntu/trusty/miro/trusty

« back to all changes in this revision

Viewing changes to debian/patches/50_miro_debug_fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Uwe Hermann
  • Date: 2010-07-31 20:00:43 UTC
  • mfrom: (1.4.9 upstream) (1.7.4 sid)
  • Revision ID: james.westby@ubuntu.com-20100731200043-0r2gn1z0amlsndas
Tags: 3.0.3-1
* New upstream release (Closes: #588299).
   + Upstream now uses webkit instead of xulrunner (Closes: 499652).
   + Fixes broken Youtube downloads.
* debian/copyright: Various updates, drop obsolete entries.
* README.Debian: Mention libwebkit-1.0-2-dbg as useful for debugging.
* Standards-Version: 3.9.1 (no changes required).
* debian/patches/:
   + 10_movies_dir.patch: Update.
   + 50_miro_debug_fix.patch: Update.
   + 102_xulrunner_bug_workaround.patch: Drop, obsolete.
   + Make all patches work with -p1 and add descriptions for all of them.
* Use new '3.0 (quilt)' source format.
* No longer use deprecated cdbs 'simple-patchsys.mk'.
* Drop no longer needed build-dependencies:
  + python-libtorrent (>= 0.14.10-2)
  + libtorrent-rasterbar-dev (>= 0.14.10-2)
  + python-gnome2-extras-dev (>= 2.19.1)
  + xulrunner-dev (>= 1.9.1)
  + libxv-dev
  + libssl-dev
  + libffi-dev
* Drop no longer needed dependencies:
  + python-gtkmozembed (>= 2.19.1) | python-gnome2-extras (>= 2.19.1)
  + xulrunner-1.9.1
* Drop democracyplayer, democracyplayer-data transitional packages.
* Use versioned python-dbus (>= 0.83.1) dependency (Closes: #587963).
* Use versioned python-gst0.10 (>= 0.10.18-2) dependency (Closes: #580609).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- platform/gtk-x11/setup.py.orig      2009-02-28 17:29:13.000000000 +0100
2
 
+++ platform/gtk-x11/setup.py   2009-02-28 17:29:26.000000000 +0100
3
 
@@ -330,7 +330,7 @@
 
1
Fix non-working gdb invokation.
 
2
 
 
3
--- a/platform/gtk-x11/setup.py.orig    2010-07-31 18:04:19.000000000 +0200
 
4
+++ b/platform/gtk-x11/setup.py 2010-07-31 18:04:46.000000000 +0200
 
5
@@ -241,7 +241,7 @@
4
6
         exit;
5
7
     fi
6
8
 
7
 
-    %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
8
 
+    %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON /usr/bin/miro.real --sync "$@"
 
9
-    $GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
 
10
+    $GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON /usr/bin/miro.real --sync "$@"
9
11
 else
10
 
     %(runtimelib)smiro.real "$@"
 
12
     miro.real "$@"
11
13
 fi