~ubuntu-branches/ubuntu/trusty/openimageio/trusty

« back to all changes in this revision

Viewing changes to debian/patches/0099-libOpenImageIO-underlinked.patch

  • Committer: Package Import Robot
  • Author(s): Adam Conrad
  • Date: 2013-12-19 19:06:30 UTC
  • Revision ID: package-import@ubuntu.com-20131219190630-u3j15p75s3nbnxrb
Tags: 1.2.3~dfsg0-1ubuntu1
* 0099-as-needed-fix.patch: Move -latomic to the right part of the link
  line to resolve FTBFS with as-needed on -latomic arches like powerpc.
* 0099-libOpenImageIO-underlinked.patch: Link libOpenImageIO with -ldl.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Link libOpenImageIO with -ldl to resolve dlopen()
 
2
Author: Adam Conrad <adconrad@ubuntu.com>
 
3
 
 
4
--- openimageio-1.1.13~dfsg0.orig/src/libOpenImageIO/CMakeLists.txt
 
5
+++ openimageio-1.1.13~dfsg0/src/libOpenImageIO/CMakeLists.txt
 
6
@@ -207,7 +207,7 @@ else ()
 
7
 endif ()
 
8
 target_link_libraries (OpenImageIO
 
9
                            ${VISIBILITY_COMMAND} ${VISIBILITY_MAP_COMMAND}
 
10
-                           ${Boost_LIBRARIES} atomic)
 
11
+                           ${Boost_LIBRARIES} atomic ${CMAKE_DL_LIBS})
 
12
 
 
13
 # Link against system TBB library if specified
 
14
 if (USE_TBB AND USE_EXTERNAL_TBB)