~ubuntu-branches/ubuntu/trusty/openssl/trusty

« back to all changes in this revision

Viewing changes to debian/patches/defaults.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2014-01-08 15:57:24 UTC
  • mfrom: (11.1.46 sid)
  • Revision ID: package-import@ubuntu.com-20140108155724-kl61on9fyqmod2z9
Tags: 1.0.1f-1ubuntu1
* Merge with Debian, remaining changes.
  - debian/libssl1.0.0.postinst:
    + Display a system restart required notification on libssl1.0.0
      upgrade on servers.
    + Use a different priority for libssl1.0.0/restart-services depending
      on whether a desktop, or server dist-upgrade is being performed.
  - debian/{libssl1.0.0-udeb.dirs, control, rules}: Create
    libssl1.0.0-udeb, for the benefit of wget-udeb (no wget-udeb package
    in Debian).
  - debian/{libcrypto1.0.0-udeb.dirs, libssl1.0.0.dirs, libssl1.0.0.files,
    rules}: Move runtime libraries to /lib, for the benefit of
    wpasupplicant.
  - debian/patches/perlpath-quilt.patch: Don't change perl #! paths under
    .pc.
  - debian/rules:
    + Don't run 'make test' when cross-building.
    + Use host compiler when cross-building.  Patch from Neil Williams.
    + Don't build for processors no longer supported: i586 (on i386)
    + Fix Makefile to properly clean up libs/ dirs in clean target.
    + Replace duplicate files in the doc directory with symlinks.
  - debian/control: Mark Debian Vcs-* as XS-Debian-Vcs-*
  - debian/patches/ubuntu_deb676533_arm_asm.patch: Enable arm assembly
    code.
  - debian/rules: Enable optimized 64bit elliptic curve code contributed
    by Google.
* Dropped changes:
  - debian/patches/arm64-support: included in debian-targets.patch
  - debian/patches/no_default_rdrand.patch: upstream
  - debian/patches/openssl-1.0.1e-env-zlib.patch: zlib is now completely
    disabled in debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Kurt Roeckx <kurt@roeckx.be>
 
2
Subject: Change default bit size and digest
 
3
Date: Fri, 01 Nov 2013 20:47:14 +0100
 
4
 
 
5
Index: openssl-1.0.1e/apps/openssl.cnf
 
6
===================================================================
 
7
--- openssl-1.0.1e.orig/apps/openssl.cnf        2013-12-22 15:36:37.179274819 +0100
 
8
+++ openssl-1.0.1e/apps/openssl.cnf     2013-12-22 15:36:37.175274904 +0100
 
9
@@ -103,7 +103,7 @@
 
10
 
 
11
 ####################################################################
 
12
 [ req ]
 
13
-default_bits           = 1024
 
14
+default_bits           = 2048
 
15
 default_keyfile        = privkey.pem
 
16
 distinguished_name     = req_distinguished_name
 
17
 attributes             = req_attributes
 
18
Index: openssl-1.0.1e/crypto/dsa/dsa_ameth.c
 
19
===================================================================
 
20
--- openssl-1.0.1e.orig/crypto/dsa/dsa_ameth.c  2013-12-22 15:36:37.179274819 +0100
 
21
+++ openssl-1.0.1e/crypto/dsa/dsa_ameth.c       2013-12-22 15:36:37.175274904 +0100
 
22
@@ -628,7 +628,7 @@
 
23
 #endif
 
24
 
 
25
                case ASN1_PKEY_CTRL_DEFAULT_MD_NID:
 
26
-               *(int *)arg2 = NID_sha1;
 
27
+               *(int *)arg2 = NID_sha256;
 
28
                return 2;
 
29
 
 
30
                default:
 
31
Index: openssl-1.0.1e/crypto/ec/ec_ameth.c
 
32
===================================================================
 
33
--- openssl-1.0.1e.orig/crypto/ec/ec_ameth.c    2013-12-22 15:36:37.179274819 +0100
 
34
+++ openssl-1.0.1e/crypto/ec/ec_ameth.c 2013-12-22 15:36:37.175274904 +0100
 
35
@@ -615,7 +615,7 @@
 
36
 #endif
 
37
 
 
38
                case ASN1_PKEY_CTRL_DEFAULT_MD_NID:
 
39
-               *(int *)arg2 = NID_sha1;
 
40
+               *(int *)arg2 = NID_sha256;
 
41
                return 2;
 
42
 
 
43
                default:
 
44
Index: openssl-1.0.1e/crypto/hmac/hm_ameth.c
 
45
===================================================================
 
46
--- openssl-1.0.1e.orig/crypto/hmac/hm_ameth.c  2013-12-22 15:36:37.179274819 +0100
 
47
+++ openssl-1.0.1e/crypto/hmac/hm_ameth.c       2013-12-22 15:36:37.175274904 +0100
 
48
@@ -89,7 +89,7 @@
 
49
        switch (op)
 
50
                {
 
51
                case ASN1_PKEY_CTRL_DEFAULT_MD_NID:
 
52
-               *(int *)arg2 = NID_sha1;
 
53
+               *(int *)arg2 = NID_sha256;
 
54
                return 1;
 
55
 
 
56
                default:
 
57
Index: openssl-1.0.1e/crypto/rsa/rsa_ameth.c
 
58
===================================================================
 
59
--- openssl-1.0.1e.orig/crypto/rsa/rsa_ameth.c  2013-12-22 15:36:37.179274819 +0100
 
60
+++ openssl-1.0.1e/crypto/rsa/rsa_ameth.c       2013-12-22 15:36:37.175274904 +0100
 
61
@@ -435,7 +435,7 @@
 
62
 #endif
 
63
 
 
64
                case ASN1_PKEY_CTRL_DEFAULT_MD_NID:
 
65
-               *(int *)arg2 = NID_sha1;
 
66
+               *(int *)arg2 = NID_sha256;
 
67
                return 1;
 
68
 
 
69
                default:
 
70
Index: openssl-1.0.1e/apps/gendh.c
 
71
===================================================================
 
72
--- openssl-1.0.1e.orig/apps/gendh.c    2013-12-22 15:36:37.179274819 +0100
 
73
+++ openssl-1.0.1e/apps/gendh.c 2013-12-22 15:36:37.175274904 +0100
 
74
@@ -78,7 +78,7 @@
 
75
 #include <openssl/x509.h>
 
76
 #include <openssl/pem.h>
 
77
 
 
78
-#define DEFBITS        512
 
79
+#define DEFBITS        2048
 
80
 #undef PROG
 
81
 #define PROG gendh_main
 
82
 
 
83
Index: openssl-1.0.1e/apps/genrsa.c
 
84
===================================================================
 
85
--- openssl-1.0.1e.orig/apps/genrsa.c   2013-12-22 15:36:37.179274819 +0100
 
86
+++ openssl-1.0.1e/apps/genrsa.c        2013-12-22 15:36:37.175274904 +0100
 
87
@@ -78,7 +78,7 @@
 
88
 #include <openssl/pem.h>
 
89
 #include <openssl/rand.h>
 
90
 
 
91
-#define DEFBITS        1024
 
92
+#define DEFBITS        2048
 
93
 #undef PROG
 
94
 #define PROG genrsa_main
 
95
 
 
96
Index: openssl-1.0.1e/apps/dhparam.c
 
97
===================================================================
 
98
--- openssl-1.0.1e.orig/apps/dhparam.c  2013-12-22 15:37:05.438669443 +0100
 
99
+++ openssl-1.0.1e/apps/dhparam.c       2013-12-22 15:38:18.417105946 +0100
 
100
@@ -130,7 +130,7 @@
 
101
 #undef PROG
 
102
 #define PROG   dhparam_main
 
103
 
 
104
-#define DEFBITS        512
 
105
+#define DEFBITS        2048
 
106
 
 
107
 /* -inform arg - input format - default PEM (DER or PEM)
 
108
  * -outform arg - output format - default PEM
 
109
@@ -253,7 +253,7 @@
 
110
                BIO_printf(bio_err," -C            Output C code\n");
 
111
                BIO_printf(bio_err," -2            generate parameters using  2 as the generator value\n");
 
112
                BIO_printf(bio_err," -5            generate parameters using  5 as the generator value\n");
 
113
-               BIO_printf(bio_err," numbits       number of bits in to generate (default 512)\n");
 
114
+               BIO_printf(bio_err," numbits       number of bits in to generate (default 2048)\n");
 
115
 #ifndef OPENSSL_NO_ENGINE
 
116
                BIO_printf(bio_err," -engine e     use engine e, possibly a hardware device.\n");
 
117
 #endif