~ubuntu-branches/ubuntu/trusty/pango1.0/trusty

« back to all changes in this revision

Viewing changes to debian/patches/13_pango-view-undefined-references.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2009-03-22 15:11:40 UTC
  • mfrom: (1.2.58 upstream)
  • Revision ID: james.westby@ubuntu.com-20090322151140-82q75bew60hvjxyg
Tags: 1.24.0-1
* New upstream release:
  + debian/patches/90_relibtoolize.patch:
    - Updated for the new version.
  + debian/control.in:
    - Update build dependencies.
  + debian/rules,
    debian/libpango1.0-0.symbols:
    - Update for API additions.
* debian/patches/13_pango-view-undefined-references.patch:
  + Fix linking of pango-view for the udeb.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- pango/pango-view/viewer-cairo.c.old 2009-03-22 15:06:45.000000000 +0100
 
2
+++ pango/pango-view/viewer-cairo.c     2009-03-22 15:07:39.000000000 +0100
 
3
@@ -30,6 +30,7 @@
 
4
 
 
5
 
 
6
 #ifdef HAVE_CAIRO_XLIB
 
7
+#ifdef HAVE_X
 
8
 #include "viewer-x.h"
 
9
 #include <cairo-xlib.h>
 
10
 
 
11
@@ -72,6 +73,7 @@
 
12
   cairo_x_view_iface_create_surface,
 
13
   cairo_x_view_iface_paint_background
 
14
 };
 
15
+#endif /* HAVE_X */
 
16
 #endif /* HAVE_CAIRO_XLIB */
 
17
 
 
18
 
 
19
@@ -348,11 +350,13 @@
 
20
     return ret;
 
21
 
 
22
 #ifdef HAVE_CAIRO_XLIB
 
23
+#ifdef HAVE_X
 
24
   if (opt_display)
 
25
     {
 
26
       *iface = &cairo_x_viewer_iface;
 
27
       return (*iface)->backend_class->create ((*iface)->backend_class);
 
28
     }
 
29
+#endif /* HAVE_X */
 
30
 #endif /* HAVE_CAIRO_XLIB */
 
31
 
 
32
   *iface = &cairo_image_viewer_iface;
 
33
--- pango/pango-view/pango-view.c.old   2009-03-22 15:09:48.000000000 +0100
 
34
+++ pango/pango-view/pango-view.c       2009-03-22 15:09:51.000000000 +0100
 
35
@@ -7,7 +7,7 @@
 
36
 extern const PangoViewer pangox_viewer;
 
37
 
 
38
 const PangoViewer *viewers[] = {
 
39
-#ifdef HAVE_CAIRO_XLIB
 
40
+#ifdef HAVE_CAIRO
 
41
   &pangocairo_viewer,
 
42
 #endif
 
43
 #ifdef HAVE_XFT