~ubuntu-branches/ubuntu/trusty/pdfresurrect/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/makefile_add_ldflags.patch

  • Committer: Package Import Robot
  • Author(s): Francois Marier
  • Date: 2012-05-29 22:41:14 UTC
  • mfrom: (1.1.6)
  • Revision ID: package-import@ubuntu.com-20120529224114-7xfrkyijzw3m5hh5
Tags: 0.11-1
* New upstream release:
  - drop all existing patches except the manpage path one

* Switch to machine-readable copyright file
* Update homepage URL

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Add support for LDFLAGS in the Makefile
2
 
Forwarded: yes
3
 
Author: Francois Marier <francois@debian.org>
4
 
Last-Update: 2012-05-28
5
 
 
6
 
--- a/Makefile.in
7
 
+++ b/Makefile.in
8
 
@@ -3,12 +3,13 @@ MANPAGE = pdfresurrect.1
9
 
 OBJS = main.o pdf.o
10
 
 CC = @CC@
11
 
 CFLAGS = @CFLAGS@ $(EXTRA_CFLAGS)
12
 
+LDFLAGS = @LDFLAGS@
13
 
 PREFIX = @prefix@
14
 
 
15
 
 all: $(OBJS) $(APP)
16
 
 
17
 
 $(APP): $(OBJS)
18
 
-       $(CC) -o $@ $(OBJS) $(CFLAGS)
19
 
+       $(CC) -o $@ $(OBJS) $(CFLAGS) $(LDFLAGS)
20
 
 
21
 
 %.o: %.c
22
 
        $(CC) -o $@ -c $< $(CFLAGS)