~ubuntu-branches/ubuntu/trusty/pdl/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/40_additional_transform_fixes.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stephan Hermann
  • Date: 2005-10-09 21:25:50 UTC
  • mfrom: (2.1.1 sarge)
  • Revision ID: james.westby@ubuntu.com-20051009212550-5uri1xdwwpswy3zu
Tags: 1:2.4.2-3ubuntu1
debian/control: added libgl1-mesa-dev and libglu1-mesa-dev to build deps
(GL/GLU Transition)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 40_additional_transform_fixes.dpatch by Henning Glawe <glaweh@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: additional fixes for transform.pd
 
6
 
 
7
@DPATCH@
 
8
diff -urNad pdl-2.4.2/Lib/Transform/transform.pd /tmp/dpep.pT50KV/pdl-2.4.2/Lib/Transform/transform.pd
 
9
--- pdl-2.4.2/Lib/Transform/transform.pd        2005-01-15 15:27:15.000000000 +0100
 
10
+++ /tmp/dpep.pT50KV/pdl-2.4.2/Lib/Transform/transform.pd       2005-01-15 15:39:35.000000000 +0100
 
11
@@ -1588,7 +1588,7 @@
 
12
 
 
13
 
 
14
   ### The first argument is a dummy to set $GENERIC.
 
15
-  $idx = PDL_Double($idx) unless($idx->type == PDL_Double);
 
16
+  $idx = double($idx) unless($idx->type == double);
 
17
   &PDL::_map_int( $in2->flat->index(0), 
 
18
        $in2, $o2, $idx, 
 
19
        $bound, $method, $big, $blur, $svmin, $flux );