~ubuntu-branches/ubuntu/trusty/phonon/trusty-updates

« back to all changes in this revision

Viewing changes to debian/patches/no_rpath.patch

  • Committer: Bazaar Package Importer
  • Author(s): Modestas Vainius
  • Date: 2011-03-11 21:39:20 UTC
  • mfrom: (6.1.4 experimental)
  • Revision ID: james.westby@ubuntu.com-20110311213920-pvkmqc1gdpy88uzx
Tags: 4:4.6.0really4.4.4-2
* Drop phonon-backends-dbg from phonon-dbg Recommends/Breaks. No longer
  needed.
* Readd packaging copyright/licensing to debian/copyright.
* Bump libphonon-dev Breaks/Replaces to << 4:4.6.0really4.4.4 for
  libphononexperimental-dev. experimental/avcaptureinterface.h header which
  used to be there up to 4.4.4 (see changelog below).
* Switch debian/rules build engine to dhmk (qt-kde-team/2/*):
  - build-depend on pkg-kde-tools >= 0.11;
  - port debian/rules to dhmk keeping it dh compatible as much as possible.
* Drop unused ${shlibs:Depends} from libphonon-dev and
  libphononexperimental-dev packages.
* Add README.Debian to phonon-backend-null package.
* Remove phonon-backend-null.lintian-overrides: phonon-backend-null is no
  longer and empty package due to README.Debian (see above).
* Release to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Modestas Vainius <modax@debian.org>
 
2
Subject: Do not set install RPATH to /usr/lib by default
 
3
Forwarded: no
 
4
Origin: vendor
 
5
Last-Update: 2011-02-20
 
6
 
 
7
Use proper code in order to avoid setting INSTALL_RPATH to /usr/lib. It is
 
8
disallowed on Debian systems and is a bad practise in general.
 
9
 
 
10
--- a/cmake/FindPhononInternal.cmake
 
11
+++ b/cmake/FindPhononInternal.cmake
 
12
@@ -233,7 +233,10 @@ endif(APPLE)
 
13
 # RPATH directories outside the current CMAKE_BINARY_DIR and also the library 
 
14
 # install directory. Alex
 
15
 set(CMAKE_INSTALL_RPATH_USE_LINK_PATH  TRUE)
 
16
-set(CMAKE_INSTALL_RPATH "${LIB_INSTALL_DIR}")
 
17
+list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemLibDir)
 
18
+if("${_isSystemLibDir}" STREQUAL "-1")
 
19
+   set(CMAKE_INSTALL_RPATH "${LIB_INSTALL_DIR}")
 
20
+endif("${_isSystemLibDir}" STREQUAL "-1")
 
21
 
 
22
 
 
23
 # Uninstall Target