~ubuntu-branches/ubuntu/trusty/php-memcache/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_paths_m4.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jose Carlos Medeiros
  • Date: 2008-03-25 01:48:13 UTC
  • mfrom: (1.1.3 upstream) (2.1.2 lenny)
  • Revision ID: james.westby@ubuntu.com-20080325014813-rtboss248a42dh43
* New upstream release
* Enable memcache modules by default. (Closes: #471177)
* debian/control added ${shlibs:Depends}.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: config9.m4
2
2
===================================================================
3
 
--- config9.m4.orig     2007-09-21 16:11:54.000000000 +0000
4
 
+++ config9.m4  2007-10-25 00:53:48.000000000 +0000
5
 
@@ -61,32 +61,13 @@
6
 
     fi
 
3
--- config9.m4.orig     2007-11-26 16:12:54.000000000 -0200
 
4
+++ config9.m4  2007-12-12 16:46:22.000000000 -0200
 
5
@@ -62,37 +62,12 @@
7
6
     PHP_ADD_INCLUDE($PHP_ZLIB_INCDIR)
8
7
   fi
9
 
 
8
  
10
9
-  if test "$PHP_MEMCACHE_SESSION" != "no"; then 
11
10
-       AC_MSG_CHECKING([for session includes])
12
11
-    session_inc_path=""
17
16
-      session_inc_path="$abs_srcdir"
18
17
-    elif test -f "$phpincludedir/ext/session/php_session.h"; then
19
18
-      session_inc_path="$phpincludedir"
 
19
-    else
 
20
-      for i in php php4 php5 php6; do
 
21
-        if test -f "$prefix/include/$i/ext/session/php_session.h"; then
 
22
-          session_inc_path="$prefix/include/$i"
 
23
-        fi
 
24
-      done
20
25
-    fi
21
26
-
22
27
-    if test "$session_inc_path" = ""; then
25
30
-      AC_MSG_RESULT([$session_inc_path])
26
31
-    fi
27
32
-  fi
28
 
 
 
33
-
29
34
   AC_MSG_CHECKING([for memcache session support])
30
35
   if test "$PHP_MEMCACHE_SESSION" != "no"; then
31
36
     AC_MSG_RESULT([enabled])
32
37
     AC_DEFINE(HAVE_MEMCACHE_SESSION,1,[Whether memcache session handler is enabled])
33
38
     AC_DEFINE(HAVE_MEMCACHE,1,[Whether you want memcache support])
34
 
-    PHP_NEW_EXTENSION(memcache, memcache.c memcache_session.c memcache_standard_hash.c memcache_consistent_hash.c, $ext_shared,,-I$session_inc_path)
35
 
+    PHP_NEW_EXTENSION(memcache, memcache.c memcache_session.c memcache_standard_hash.c memcache_consistent_hash.c, $ext_shared,,)
 
39
-    PHP_NEW_EXTENSION(memcache, memcache.c memcache_pool.c memcache_queue.c memcache_ascii_protocol.c memcache_binary_protocol.c memcache_standard_hash.c memcache_consistent_hash.c memcache_session.c, $ext_shared,,-I$session_inc_path)
 
40
+    PHP_NEW_EXTENSION(memcache, memcache.c memcache_pool.c memcache_queue.c memcache_ascii_protocol.c memcache_binary_protocol.c memcache_standard_hash.c memcache_consistent_hash.c memcache_session.c, $ext_shared,,)
36
41
     ifdef([PHP_ADD_EXTENSION_DEP],
37
42
     [
38
43
       PHP_ADD_EXTENSION_DEP(memcache, session)