~ubuntu-branches/ubuntu/trusty/pidgin/trusty

« back to all changes in this revision

Viewing changes to debian/patches/70_farstream_rename.patch

  • Committer: Package Import Robot
  • Author(s): Ken VanDine
  • Date: 2012-04-04 17:02:58 UTC
  • Revision ID: package-import@ubuntu.com-20120404170258-m6yhyj8syg6m6fbc
Tags: 1:2.10.2-1ubuntu2
* debian/patches/70_farstream_rename.patch
  - updated patch from the upstream bug report
    http://developer.pidgin.im/ticket/14936

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'configure.ac'
2
 
Index: pidgin-2.10.2/configure.ac
 
1
Description: Ported from farsight2 to farstream
 
2
Forwarded: http://developer.pidgin.im/ticket/14936
 
3
Author: Olivier Crete
 
4
Last-Update: 2012-04-04
 
5
 
 
6
Index: pidgin/configure.ac
3
7
===================================================================
4
 
--- pidgin-2.10.2.orig/configure.ac     2012-03-16 12:33:22.628064519 +0100
5
 
+++ pidgin-2.10.2/configure.ac  2012-03-16 12:34:07.828066238 +0100
6
 
@@ -792,7 +792,7 @@
7
 
        [AC_HELP_STRING([--disable-farsight], [compile without farsight support])],
8
 
        enable_farsight="$enableval", enable_farsight="yes")
9
 
 if test "x$enable_farsight" != "xno"; then
 
8
--- pidgin.orig/configure.ac    2012-04-04 16:31:44.457483230 -0400
 
9
+++ pidgin/configure.ac 2012-04-04 16:31:57.669483665 -0400
 
10
@@ -786,18 +786,18 @@
 
11
 fi
 
12
 
 
13
 dnl #######################################################################
 
14
-dnl # Check for Farsight
 
15
+dnl # Check for Farstream
 
16
 dnl #######################################################################
 
17
-AC_ARG_ENABLE(farsight,
 
18
-       [AC_HELP_STRING([--disable-farsight], [compile without farsight support])],
 
19
-       enable_farsight="$enableval", enable_farsight="yes")
 
20
-if test "x$enable_farsight" != "xno"; then
10
21
-       PKG_CHECK_MODULES(FARSIGHT, [farsight2-0.10 >= 0.0.9], [
11
 
+       PKG_CHECK_MODULES(FARSIGHT, [farstream-0.1 >= 0.1.1], [
12
 
                AC_DEFINE(USE_FARSIGHT, 1, [Use Farsight for voice and video])
13
 
                AC_SUBST(FARSIGHT_CFLAGS)
14
 
                AC_SUBST(FARSIGHT_LIBS)
15
 
Index: pidgin-2.10.2/libpurple/media/backend-fs2.c
16
 
===================================================================
17
 
--- pidgin-2.10.2.orig/libpurple/media/backend-fs2.c    2012-03-14 06:27:59.000000000 +0100
18
 
+++ pidgin-2.10.2/libpurple/media/backend-fs2.c 2012-03-16 12:34:07.832066238 +0100
19
 
@@ -34,8 +34,8 @@
 
22
-               AC_DEFINE(USE_FARSIGHT, 1, [Use Farsight for voice and video])
 
23
-               AC_SUBST(FARSIGHT_CFLAGS)
 
24
-               AC_SUBST(FARSIGHT_LIBS)
 
25
+AC_ARG_ENABLE(farstream,
 
26
+       [AC_HELP_STRING([--disable-farstream], [compile without farstream support])],
 
27
+       enable_farstream="$enableval", enable_farstream="yes")
 
28
+if test "x$enable_farstream" != "xno"; then
 
29
+       PKG_CHECK_MODULES(FARSTREAM, [farstream-0.1], [
 
30
+               AC_DEFINE(USE_FARSTREAM, 1, [Use Farstream for voice and video])
 
31
+               AC_SUBST(FARSTREAM_CFLAGS)
 
32
+               AC_SUBST(FARSTREAM_LIBS)
 
33
        ], [
 
34
-               enable_farsight="no"
 
35
+               enable_farstream="no"
 
36
        ])
 
37
 fi
 
38
 
 
39
@@ -808,20 +808,20 @@
 
40
        [AC_HELP_STRING([--disable-vv], [compile without voice and video support])],
 
41
        enable_vv="$enableval", enable_vv="yes")
 
42
 if test "x$enable_vv" != "xno"; then
 
43
-       if test "x$enable_gstreamer" != "xno" -a "x$enable_gstinterfaces" != "xno" -a "x$enable_farsight" != "xno"; then
 
44
+       if test "x$enable_gstreamer" != "xno" -a "x$enable_gstinterfaces" != "xno" -a "x$enable_farstream" != "xno"; then
 
45
                AC_DEFINE(USE_VV, 1, [Use voice and video])
 
46
        else
 
47
                enable_vv="no"
 
48
                if test "x$force_deps" = "xyes"; then
 
49
                        AC_MSG_ERROR([
 
50
 Dependencies for voice/video were not met.
 
51
-Install the necessary gstreamer and farsight packages first.
 
52
+Install the necessary gstreamer and farstream packages first.
 
53
 Or use --disable-vv if you do not need voice/video support.
 
54
                        ])
 
55
                fi
 
56
        fi
 
57
 fi
 
58
-AM_CONDITIONAL(USE_VV, test "x$enable_gstreamer" != "xno" -a "x$enable_gstinterfaces" != "xno" -a "x$enable_farsight" != "xno")
 
59
+AM_CONDITIONAL(USE_VV, test "x$enable_gstreamer" != "xno" -a "x$enable_gstinterfaces" != "xno" -a "x$enable_farstream" != "xno")
 
60
 
 
61
 dnl #######################################################################
 
62
 dnl # Check for Internationalized Domain Name support
 
63
Index: pidgin/libpurple/Makefile.am
 
64
===================================================================
 
65
--- pidgin.orig/libpurple/Makefile.am   2012-03-05 11:29:07.780354000 -0500
 
66
+++ pidgin/libpurple/Makefile.am        2012-04-04 16:31:57.685483665 -0400
 
67
@@ -306,7 +306,7 @@
 
68
        $(LIBXML_LIBS) \
 
69
        $(NETWORKMANAGER_LIBS) \
 
70
        $(INTLLIBS) \
 
71
-       $(FARSIGHT_LIBS) \
 
72
+       $(FARSTREAM_LIBS) \
 
73
        $(GSTREAMER_LIBS) \
 
74
        $(GSTINTERFACES_LIBS) \
 
75
        $(IDN_LIBS) \
 
76
@@ -322,7 +322,7 @@
 
77
        $(DEBUG_CFLAGS) \
 
78
        $(DBUS_CFLAGS) \
 
79
        $(LIBXML_CFLAGS) \
 
80
-       $(FARSIGHT_CFLAGS) \
 
81
+       $(FARSTREAM_CFLAGS) \
 
82
        $(GSTREAMER_CFLAGS) \
 
83
        $(GSTINTERFACES_CFLAGS) \
 
84
        $(IDN_CFLAGS) \
 
85
Index: pidgin/libpurple/media/backend-fs2.c
 
86
===================================================================
 
87
--- pidgin.orig/libpurple/media/backend-fs2.c   2012-04-04 16:29:46.329479343 -0400
 
88
+++ pidgin/libpurple/media/backend-fs2.c        2012-04-04 16:31:57.685483665 -0400
 
89
@@ -1,5 +1,5 @@
 
90
 /**
 
91
- * @file backend-fs2.c Farsight 2 backend for media API
 
92
+ * @file backend-fs2.c Farstream backend for media API
 
93
  * @ingroup core
 
94
  */
 
95
 
 
96
@@ -34,8 +34,9 @@
20
97
 #include "network.h"
21
98
 #include "media-gst.h"
22
99
 
24
101
-#include <gst/farsight/fs-element-added-notifier.h>
25
102
+#include <farstream/fs-conference.h>
26
103
+#include <farstream/fs-element-added-notifier.h>
 
104
+#include <farstream/fs-utils.h>
27
105
 
28
106
 /** @copydoc _PurpleMediaBackendFs2Class */
29
107
 typedef struct _PurpleMediaBackendFs2Class PurpleMediaBackendFs2Class;
30
 
@@ -867,13 +867,6 @@
31
 
                                                " strict."));
 
108
@@ -112,6 +113,8 @@
 
109
        gchar *participant;
 
110
        FsStream *stream;
 
111
 
 
112
+        gboolean supports_add;
 
113
+
 
114
        GstElement *src;
 
115
        GstElement *tee;
 
116
        GstElement *volume;
 
117
@@ -147,6 +150,8 @@
 
118
        FsConference *conference;
 
119
        gchar *conference_type;
 
120
 
 
121
+        FsElementAddedNotifier *notifier;
 
122
+
 
123
        GHashTable *sessions;
 
124
        GHashTable *participants;
 
125
 
 
126
@@ -212,6 +217,11 @@
 
127
 
 
128
        purple_debug_info("backend-fs2", "purple_media_backend_fs2_dispose\n");
 
129
 
 
130
+       if (priv->notifier) {
 
131
+               g_object_unref(priv->notifier);
 
132
+               priv->notifier = NULL;
 
133
+       }
 
134
+
 
135
        if (priv->confbin) {
 
136
                GstElement *pipeline;
 
137
 
 
138
@@ -846,7 +856,7 @@
 
139
                        priv->conference != FS_CONFERENCE(src))
 
140
                return;
 
141
 
 
142
-       if (gst_structure_has_name(msg->structure, "farsight-error")) {
 
143
+       if (gst_structure_has_name(msg->structure, "farstream-error")) {
 
144
                FsError error_no;
 
145
                gst_structure_get_enum(msg->structure, "error-no",
 
146
                                FS_TYPE_ERROR, (gint*)&error_no);
 
147
@@ -859,24 +869,9 @@
 
148
                                                " packages."));
32
149
                                purple_media_end(priv->media, NULL, NULL);
33
150
                                break;
 
151
-                       case FS_ERROR_NO_CODECS_LEFT:
 
152
-                               purple_media_error(priv->media, _("No codecs"
 
153
-                                               " left. Your codec"
 
154
-                                               " preferences in"
 
155
-                                               " fs-codecs.conf are too"
 
156
-                                               " strict."));
 
157
-                               purple_media_end(priv->media, NULL, NULL);
 
158
-                               break;
34
159
-                       case FS_ERROR_UNKNOWN_CNAME:
35
160
-                       /*
36
161
-                        * Unknown CName is only a problem for the
40
165
-                               break;
41
166
                        default:
42
167
                                purple_debug_error("backend-fs2",
43
 
                                                "farsight-error: %i: %s\n",
44
 
@@ -1220,7 +1213,7 @@
 
168
-                                               "farsight-error: %i: %s\n",
 
169
+                                               "farstream-error: %i: %s\n",
 
170
                                                error_no,
 
171
                                                gst_structure_get_string(
 
172
                                                msg->structure, "error-msg"));
 
173
@@ -885,11 +880,11 @@
 
174
 
 
175
                if (FS_ERROR_IS_FATAL(error_no)) {
 
176
                        purple_media_error(priv->media, _("A non-recoverable "
 
177
-                                       "Farsight2 error has occurred."));
 
178
+                                       "Farstream error has occurred."));
 
179
                        purple_media_end(priv->media, NULL, NULL);
 
180
                }
 
181
        } else if (gst_structure_has_name(msg->structure,
 
182
-                       "farsight-new-local-candidate")) {
 
183
+                       "farstream-new-local-candidate")) {
 
184
                const GValue *value;
 
185
                FsStream *stream;
 
186
                FsCandidate *local_candidate;
 
187
@@ -924,7 +919,7 @@
 
188
                                session->id, name, candidate);
 
189
                g_object_unref(candidate);
 
190
        } else if (gst_structure_has_name(msg->structure,
 
191
-                       "farsight-local-candidates-prepared")) {
 
192
+                       "farstream-local-candidates-prepared")) {
 
193
                const GValue *value;
 
194
                FsStream *stream;
 
195
                FsParticipant *participant;
 
196
@@ -942,7 +937,7 @@
 
197
                g_signal_emit_by_name(self, "candidates-prepared",
 
198
                                session->id, name);
 
199
        } else if (gst_structure_has_name(msg->structure,
 
200
-                       "farsight-new-active-candidate-pair")) {
 
201
+                       "farstream-new-active-candidate-pair")) {
 
202
                const GValue *value;
 
203
                FsStream *stream;
 
204
                FsCandidate *local_candidate;
 
205
@@ -976,7 +971,7 @@
 
206
                g_object_unref(lcandidate);
 
207
                g_object_unref(rcandidate);
 
208
        } else if (gst_structure_has_name(msg->structure,
 
209
-                       "farsight-recv-codecs-changed")) {
 
210
+                       "farstream-recv-codecs-changed")) {
 
211
                const GValue *value;
 
212
                GList *codecs;
 
213
                FsCodec *codec;
 
214
@@ -986,10 +981,10 @@
 
215
                codec = codecs->data;
 
216
 
 
217
                purple_debug_info("backend-fs2",
 
218
-                               "farsight-recv-codecs-changed: %s\n",
 
219
+                               "farstream-recv-codecs-changed: %s\n",
 
220
                                codec->encoding_name);
 
221
        } else if (gst_structure_has_name(msg->structure,
 
222
-                       "farsight-component-state-changed")) {
 
223
+                       "farstream-component-state-changed")) {
 
224
                const GValue *value;
 
225
                FsStreamState fsstate;
 
226
                guint component;
 
227
@@ -1025,11 +1020,11 @@
 
228
                }
 
229
 
 
230
                purple_debug_info("backend-fs2",
 
231
-                               "farsight-component-state-changed: "
 
232
+                               "farstream-component-state-changed: "
 
233
                                "component: %u state: %s\n",
 
234
                                component, state);
 
235
        } else if (gst_structure_has_name(msg->structure,
 
236
-                       "farsight-send-codec-changed")) {
 
237
+                       "farstream-send-codec-changed")) {
 
238
                const GValue *value;
 
239
                FsCodec *codec;
 
240
                gchar *codec_str;
 
241
@@ -1039,12 +1034,12 @@
 
242
                codec_str = fs_codec_to_string(codec);
 
243
 
 
244
                purple_debug_info("backend-fs2",
 
245
-                               "farsight-send-codec-changed: codec: %s\n",
 
246
+                               "farstream-send-codec-changed: codec: %s\n",
 
247
                                codec_str);
 
248
 
 
249
                g_free(codec_str);
 
250
        } else if (gst_structure_has_name(msg->structure,
 
251
-                       "farsight-codecs-changed")) {
 
252
+                       "farstream-codecs-changed")) {
 
253
                const GValue *value;
 
254
                FsSession *fssession;
 
255
                GList *sessions;
 
256
@@ -1220,8 +1215,12 @@
45
257
                                purple_media_is_initiator(media, sid, name))
46
258
                        return;
47
259
 
48
260
-               fs_stream_set_remote_candidates(stream->stream,
49
 
+               fs_stream_add_remote_candidates(stream->stream,
50
 
                                stream->remote_candidates, &err);
 
261
-                               stream->remote_candidates, &err);
 
262
+               if (stream->supports_add)
 
263
+                 fs_stream_add_remote_candidates(stream->stream,
 
264
+                               stream->remote_candidates, &err);
 
265
+               else
 
266
+                 fs_stream_force_remote_candidates(stream->stream,
 
267
+                               stream->remote_candidates, &err);
51
268
 
52
269
                if (err == NULL)
53
 
@@ -1612,7 +1605,7 @@
 
270
                        return;
 
271
@@ -1301,6 +1300,7 @@
 
272
        GstElement *pipeline;
 
273
        GstBus *bus;
 
274
        gchar *name;
 
275
+       GKeyFile *default_props;
 
276
 
 
277
        priv->conference = FS_CONFERENCE(
 
278
                        gst_element_factory_make(priv->conference_type, NULL));
 
279
@@ -1343,6 +1343,14 @@
 
280
                return FALSE;
 
281
        }
 
282
 
 
283
+       default_props = fs_utils_get_default_element_properties(GST_ELEMENT(priv->conference));
 
284
+       if (default_props != NULL) {
 
285
+               priv->notifier = fs_element_added_notifier_new();
 
286
+               fs_element_added_notifier_add(priv->notifier,
 
287
+                                             GST_BIN(priv->confbin));
 
288
+               fs_element_added_notifier_set_properties_from_keyfile(priv->notifier, default_props);
 
289
+       }
 
290
+
 
291
        g_signal_connect(G_OBJECT(bus), "message",
 
292
                        G_CALLBACK(gst_bus_cb), self);
 
293
        gst_object_unref(bus);
 
294
@@ -1559,7 +1567,7 @@
 
295
         * receiving the src-pad-added signal.
 
296
         * Only works for non-multicast FsRtpSessions.
 
297
         */
 
298
-       if (is_nice || !strcmp(transmitter, "rawudp"))
 
299
+       if (!!strcmp(transmitter, "multicast"))
 
300
                g_object_set(G_OBJECT(session->session),
 
301
                                "no-rtcp-timeout", 0, NULL);
 
302
 
 
303
@@ -1612,7 +1620,7 @@
54
304
        GError *err = NULL;
55
305
 
56
306
        participant = fs_conference_new_participant(
59
309
 
60
310
        if (err) {
61
311
                purple_debug_error("backend-fs2",
62
 
@@ -1858,8 +1851,7 @@
63
 
 
64
 
        fsstream = fs_session_new_stream(session->session, participant,
65
 
                        initiator == TRUE ? type_direction :
 
312
@@ -1622,6 +1630,12 @@
 
313
                return FALSE;
 
314
        }
 
315
 
 
316
+       if (g_object_class_find_property(G_OBJECT_GET_CLASS(participant),
 
317
+                                        "cname")) {
 
318
+         g_object_set(participant, "cname", name, NULL);
 
319
+       }
 
320
+
 
321
+
 
322
        if (!priv->participants) {
 
323
                purple_debug_info("backend-fs2",
 
324
                                "Creating hash table for participants\n");
 
325
@@ -1786,6 +1800,40 @@
 
326
                }
 
327
        }
 
328
 
 
329
+
 
330
+       session = get_session(self, sess_id);
 
331
+
 
332
+       if (session == NULL) {
 
333
+               purple_debug_error("backend-fs2",
 
334
+                               "Couldn't find session to create stream.\n");
 
335
+               return FALSE;
 
336
+       }
 
337
+
 
338
+       participant = get_participant(self, who);
 
339
+
 
340
+       if (participant == NULL) {
 
341
+               purple_debug_error("backend-fs2", "Couldn't find "
 
342
+                               "participant to create stream.\n");
 
343
+               return FALSE;
 
344
+       }
 
345
+
 
346
+       fsstream = fs_session_new_stream(session->session, participant,
 
347
+                       initiator == TRUE ? type_direction :
 
348
+                       (type_direction & FS_DIRECTION_RECV), &err);
 
349
+
 
350
+       if (fsstream == NULL) {
 
351
+               if (err) {
 
352
+                       purple_debug_error("backend-fs2",
 
353
+                                       "Error creating stream: %s\n",
 
354
+                                       err && err->message ?
 
355
+                                       err->message : "NULL");
 
356
+                       g_error_free(err);
 
357
+               } else
 
358
+                       purple_debug_error("backend-fs2",
 
359
+                                       "Error creating stream\n");
 
360
+               return FALSE;
 
361
+       }
 
362
+
 
363
        memcpy(_params, params, sizeof(GParameter) * num_params);
 
364
 
 
365
        /* set the controlling mode parameter */
 
366
@@ -1840,45 +1888,22 @@
 
367
                _num_params++;
 
368
        }
 
369
 
 
370
-       session = get_session(self, sess_id);
 
371
 
 
372
-       if (session == NULL) {
 
373
-               purple_debug_error("backend-fs2",
 
374
-                               "Couldn't find session to create stream.\n");
 
375
-               return FALSE;
 
376
-       }
 
377
-
 
378
-       participant = get_participant(self, who);
 
379
-
 
380
-       if (participant == NULL) {
 
381
-               purple_debug_error("backend-fs2", "Couldn't find "
 
382
-                               "participant to create stream.\n");
 
383
-               return FALSE;
 
384
+       if(!fs_stream_set_transmitter(fsstream, transmitter,
 
385
+                                     _params, _num_params, &err)) {
 
386
+            purple_debug_error("backend-fs2", "Could not set transmitter %s: %s.\n", transmitter, err->message);
 
387
+            g_clear_error(&err);
 
388
+            g_free(_params);
 
389
+            return FALSE;
 
390
        }
 
391
-
 
392
-       fsstream = fs_session_new_stream(session->session, participant,
 
393
-                       initiator == TRUE ? type_direction :
66
394
-                       (type_direction & FS_DIRECTION_RECV), transmitter,
67
395
-                       _num_params, _params, &err);
68
 
+                       (type_direction & FS_DIRECTION_RECV),  &err);
69
396
        g_free(_params);
70
397
 
71
 
        if (fsstream == NULL) {
72
 
@@ -1991,7 +1983,7 @@
 
398
-       if (fsstream == NULL) {
 
399
-               if (err) {
 
400
-                       purple_debug_error("backend-fs2",
 
401
-                                       "Error creating stream: %s\n",
 
402
-                                       err && err->message ?
 
403
-                                       err->message : "NULL");
 
404
-                       g_error_free(err);
 
405
-               } else
 
406
-                       purple_debug_error("backend-fs2",
 
407
-                                       "Error creating stream\n");
 
408
-               return FALSE;
 
409
-       }
 
410
 
 
411
        stream = g_new0(PurpleMediaBackendFs2Stream, 1);
 
412
        stream->participant = g_strdup(who);
 
413
        stream->session = session;
 
414
        stream->stream = fsstream;
 
415
+       stream->supports_add = !strcmp(transmitter, "nice");
 
416
 
 
417
        priv->streams = g_list_append(priv->streams, stream);
 
418
 
 
419
@@ -1991,7 +2016,11 @@
73
420
        if (purple_media_is_initiator(priv->media, sess_id, participant) ||
74
421
                        purple_media_accepted(
75
422
                        priv->media, sess_id, participant)) {
76
423
-               fs_stream_set_remote_candidates(stream->stream,
77
 
+               fs_stream_add_remote_candidates(stream->stream,
 
424
+               if (stream->supports_add)
 
425
+                    fs_stream_add_remote_candidates(stream->stream,
 
426
+                               stream->remote_candidates, &err);
 
427
+               else
 
428
+                    fs_stream_force_remote_candidates(stream->stream,
78
429
                                stream->remote_candidates, &err);
79
430
 
80
431
                if (err) {
81
 
Index: pidgin-2.10.2/libpurple/mediamanager.c
82
 
===================================================================
83
 
--- pidgin-2.10.2.orig/libpurple/mediamanager.c 2012-03-14 06:27:59.000000000 +0100
84
 
+++ pidgin-2.10.2/libpurple/mediamanager.c      2012-03-16 12:34:07.836066239 +0100
 
432
@@ -2016,6 +2045,7 @@
 
433
        if (sess_id != NULL) {
 
434
                PurpleMediaBackendFs2Session *session = get_session(
 
435
                                PURPLE_MEDIA_BACKEND_FS2(self), sess_id);
 
436
+               GList *codecs = NULL;
 
437
 
 
438
                if (session == NULL)
 
439
                        return FALSE;
 
440
@@ -2023,21 +2053,31 @@
 
441
                if (session->type & (PURPLE_MEDIA_SEND_AUDIO |
 
442
                                PURPLE_MEDIA_SEND_VIDEO))
 
443
                        g_object_get(session->session,
 
444
-                                       "codecs-ready", &ret, NULL);
 
445
+                                       "codecs", &codecs, NULL);
 
446
                else
 
447
                        ret = TRUE;
 
448
+               if (codecs) {
 
449
+                       fs_codec_list_destroy (codecs);
 
450
+                       ret = TRUE;
 
451
+               }
 
452
        } else {
 
453
                GList *values = g_hash_table_get_values(priv->sessions);
 
454
 
 
455
                for (; values; values = g_list_delete_link(values, values)) {
 
456
                        PurpleMediaBackendFs2Session *session = values->data;
 
457
+                       GList *codecs = NULL;
 
458
+
 
459
                        if (session->type & (PURPLE_MEDIA_SEND_AUDIO |
 
460
                                        PURPLE_MEDIA_SEND_VIDEO))
 
461
                                g_object_get(session->session,
 
462
-                                               "codecs-ready", &ret, NULL);
 
463
+                                               "codecs", &codecs, NULL);
 
464
                        else
 
465
                                ret = TRUE;
 
466
 
 
467
+                       if (codecs) {
 
468
+                               fs_codec_list_destroy (codecs);
 
469
+                               ret = TRUE;
 
470
+                       }
 
471
                        if (ret == FALSE)
 
472
                                break;
 
473
                }
 
474
Index: pidgin/libpurple/media.c
 
475
===================================================================
 
476
--- pidgin.orig/libpurple/media.c       2012-03-05 11:29:07.780354000 -0500
 
477
+++ pidgin/libpurple/media.c    2012-04-04 16:31:57.689483665 -0400
 
478
@@ -1067,7 +1067,6 @@
 
479
 {
 
480
 #ifdef USE_VV
 
481
        PurpleMediaSession *session;
 
482
-       PurpleMediaStream *stream = NULL;
 
483
 
 
484
        g_return_val_if_fail(PURPLE_IS_MEDIA(media), FALSE);
 
485
 
 
486
@@ -1103,7 +1102,7 @@
 
487
        }
 
488
 
 
489
        if (purple_media_get_stream(media, sess_id, who) == NULL) {
 
490
-               stream = purple_media_insert_stream(session, who, initiator);
 
491
+               purple_media_insert_stream(session, who, initiator);
 
492
 
 
493
                g_signal_emit(media, purple_media_signals[STATE_CHANGED],
 
494
                                0, PURPLE_MEDIA_STATE_NEW,
 
495
Index: pidgin/libpurple/mediamanager.c
 
496
===================================================================
 
497
--- pidgin.orig/libpurple/mediamanager.c        2012-04-04 16:29:46.285479342 -0400
 
498
+++ pidgin/libpurple/mediamanager.c     2012-04-04 16:31:57.689483665 -0400
85
499
@@ -39,7 +39,7 @@
86
500
 #ifdef USE_VV
87
501
 #include <media/backend-fs2.h>