~ubuntu-branches/ubuntu/trusty/portmidi/trusty

« back to all changes in this revision

Viewing changes to debian/patches/03_pm_test_Makefile.diff

  • Committer: Bazaar Package Importer
  • Author(s): Paul Brossier
  • Date: 2009-09-16 06:50:57 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20090916065057-lz24lbrrygyev85b
Tags: 1:131-1
* New upstream version, uses epoch (closes: #501132)
* debian/watch: update to match new download location and version
  numbering (closes: #450055), but still fails due to zip format
* Add depends on quilt, move patches to debian/patches
* Add Homepage to debian/control
* debian/control: use ${binary:Version}, bump to S-V 3.8.3
* debian/compat: bump to 5
* debian/copyright: update to match license.txt and add missing copyrights
* debian/patches/02_pmlinuxalsa.diff: remove merged hunks
* debian/patches/04_ptlinux.diff: remove merged hunks
* debian/patches/05_makefile.diff: merge and link portmidi to porttime,
  thanks to Willem van Engen (closes: #515712)
* debian/rules: use pm_linux/Makefile, ship CHANGELOG.txt and make sure
  source and header files are not executable
* debian/README.source: refer to quilt documentation
* debian/libportmidi-dev.install: do not try to install unexisting files
* debian/patches/{06_pm_test_mm,07_pm_test_sysex,08_pm_test_qtest}.diff:
  get rid of missing include and parenthesis, fix long int formatting
* debian/rules: do not compress header files

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- portmidi-20041117.orig/pm_test/Makefile
 
2
+++ portmidi-20041117/pm_test/Makefile
 
3
@@ -0,0 +1,32 @@
 
4
+# For debugging, define PM_CHECK_ERRORS
 
5
+PMFLAGS = -DPM_CHECK_ERRORS
 
6
+# Use this for linux alsa (0.9x) version
 
7
+ALSALIB = -lasound
 
8
+pmlib = -lportmidi
 
9
+ptlib = -lporttime
 
10
+VFLAGS = -DPMALSA
 
11
+
 
12
+CC = gcc $(CFLAGS) $(VFLAGS) $(PMFLAGS) -g
 
13
+
 
14
+all: test sysex midithread latency midithru
 
15
+
 
16
+test: test.o
 
17
+       $(CC) test.c -o test $(pmlib) $(ptlib) $(ALSALIB)
 
18
+
 
19
+sysex: sysex.o
 
20
+       $(CC) sysex.c -o sysex $(pmlib) $(ptlib) $(ALSALIB)
 
21
+
 
22
+midithread: midithread.o
 
23
+       $(CC) midithread.c -o midithread \
 
24
+               $(pmlib) $(ptlib) $(ALSALIB)
 
25
+
 
26
+latency: latency.o
 
27
+       $(CC) latency.c -o latency $(pmlib) $(ptlib) \
 
28
+               $(ALSALIB) -lpthread -lm
 
29
+
 
30
+midithru: midithru.o
 
31
+       $(CC) midithru.c -o midithru $(pmlib) $(ptlib) \
 
32
+               $(ALSALIB) -lpthread -lm
 
33
+
 
34
+clean:
 
35
+       rm -f midithru latency midithread sysex test