~ubuntu-branches/ubuntu/trusty/puppet/trusty

« back to all changes in this revision

Viewing changes to debian/patches/fix-symlink-2-1b0e812ad9e33b3cc148fac30a28490f60f40c63

  • Committer: Package Import Robot
  • Author(s): Robie Basak
  • Date: 2013-04-08 15:03:25 UTC
  • mfrom: (3.1.46 sid)
  • Revision ID: package-import@ubuntu.com-20130408150325-4o91hljzz2zca5fi
Tags: 2.7.18-4ubuntu1
* Merge from Debian unstable. This merges the vim addon fix in 2.7.18-2
  (LP: #1163927). Remaining changes:
  - debian/puppetmaster-passenger.postinst: Make sure we error if puppet
    config print doesn't work
  - debian/puppetmaster-passenger.postinst: Ensure upgrades from
    <= 2.7.11-1 fixup passenger apache configuration.
  - Drop Build-Depends on ruby-rspec (in universe):
    + debian/control: remove ruby-rspec from Build-Depends
    + debian/patches/no-rspec.patch: make Rakefile work anyway if rspec
      isn't installed so we can use it in debian/rules.
* Drop upstreamed patches:
  - debian/patches/security-mar-2013.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
commit 1b0e812ad9e33b3cc148fac30a28490f60f40c63
 
2
Author: Chris Boot <crb@tiger-computing.co.uk>
 
3
Date:   Thu Mar 14 17:56:39 2013 +0000
 
4
 
 
5
    Send the :links option to the file server
 
6
    
 
7
    Previously, the server was never asked to follow links when 'links =>
 
8
    follow' was used, so the server always provided the metadata for the
 
9
    link itself. With this patch, the server correctly follows the link
 
10
    server-side and the client can apply the catalog correctly.
 
11
 
 
12
--- a/lib/puppet/type/file/source.rb
 
13
+++ b/lib/puppet/type/file/source.rb
 
14
@@ -101,7 +101,7 @@
 
15
       return @content if @content
 
16
       raise Puppet::DevError, "No source for content was stored with the metadata" unless metadata.source
 
17
 
 
18
-      unless tmp = Puppet::FileServing::Content.indirection.find(metadata.source)
 
19
+      unless tmp = Puppet::FileServing::Content.indirection.find(metadata.source, :links => resource[:links])
 
20
         fail "Could not find any content at %s" % metadata.source
 
21
       end
 
22
       @content = tmp.content
 
23
@@ -154,7 +154,7 @@
 
24
       return nil unless value
 
25
       value.each do |source|
 
26
         begin
 
27
-          if data = Puppet::FileServing::Metadata.indirection.find(source)
 
28
+          if data = Puppet::FileServing::Metadata.indirection.find(source, :links => resource[:links])
 
29
             @metadata = data
 
30
             @metadata.source = source
 
31
             break