~ubuntu-branches/ubuntu/trusty/pyx/trusty

« back to all changes in this revision

Viewing changes to debian/patches/manual-mkhowto.patch

  • Committer: Bazaar Package Importer
  • Author(s): Stuart Prescott
  • Date: 2009-10-29 23:47:39 UTC
  • mfrom: (5.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20091029234739-cc178gmb3vp5828t
Tags: 0.10-1
* New maintainer (closes: #552750).
* Revert unneeded versioned build-dependency on python-all-dev.
* Add a preinst script to clean up after python-central (working around
  bug #479852 in python-central) (closes: #553271).
* Convert packaging to quilt.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Include mkhowto in the local directory for building documentation
 
2
--- pyx-0.10.orig/manual/Makefile
 
3
+++ pyx-0.10/manual/Makefile
 
4
@@ -10,7 +10,7 @@
 
5
 default: dvi
 
6
 
 
7
 clean:
 
8
-       -rm -fr manual.dvi *.eps *.pdf *.aux *.out *.toc *.log manual
 
9
+       -rm -fr manual.dvi *.eps *.pdf *.aux *.out *.toc *.log manual mkhowto
 
10
 
 
11
 all:
 
12
        make clean
 
13
@@ -24,15 +24,19 @@
 
14
 pdf: manual.pdf
 
15
 html: manual/manual.html
 
16
 
 
17
-manual.pdf: $(src) pdf_figs
 
18
+PYTHON_VERSION := $(shell $(PYTHON) -c 'import sys; print sys.version[:3]')
 
19
+mkhowto:
 
20
+       ln -s /usr/lib/python$(PYTHON_VERSION)/doc/tools/mkhowto
 
21
+
 
22
+manual.pdf: $(src) pdf_figs mkhowto
 
23
        #for index-with-own-hyperrefs debugging, anybody interested?
 
24
        #./mkhowto --a4 --pdf --keep manual.tex
 
25
        ./mkhowto --a4 --pdf manual.tex
 
26
 
 
27
-manual.dvi: $(src) eps_figs
 
28
+manual.dvi: $(src) eps_figs mkhowto
 
29
        ./mkhowto --a4 --dvi manual.tex
 
30
 
 
31
-manual/manual.html: $(src) eps_figs
 
32
+manual/manual.html: $(src) eps_figs mkhowto
 
33
        ./mkhowto --image-type png --favicon "/pyx.ico" \
 
34
                  --up-link "/" --up-title "PyX homepage" \
 
35
                  --html manual.tex