~ubuntu-branches/ubuntu/trusty/qsampler/trusty

« back to all changes in this revision

Viewing changes to debian/patches/00_cvs-makefile

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2009-12-10 21:07:40 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20091210210740-ddqqq7xnv7p4n4fs
Tags: 0.2.2-1
* New upstream release.
* Repack the tarball to remove upstream's debian dir:
  - debian/rules: Use the get-orig-source target to retrieve an updated
    tarball.
  - Remove debian/README.Debian, we don't follow those instructions to make
    the package.
* Switch to debhelper 7.
* Replace dpatch system with quilt.
* Remove all old patches, now unnecessary.
* debian/patches/01-fix_desktop.patch:
  - Fix desktop file as per spec.
* debian/patches/02-pass_flags_to_make.patch:
  - Pass CFLAGS/CXXFLAGS to the compiler.
* Add debian/menu file.
* Also install 32x32px icon (in XPM format).
* debian/control:
  - Bump Standards.
  - Set Debian Multimedia Maintainers as Maintainer.
  - Add myself to Uploaders.
  - Replace versioned automake build-dependency with automake.
  - Build-depend on libx11-dev.
* debian/copyright:
  - Update copyiright periods.
  - Add a comment about the tarball repacking.
* Remove debian/qsampler.desktop, unnecessary.
* debian/docs: Don't install the AUTHORS file, information provided by the
  copyright file are enough.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 10cvs-makefile.dpatch by Free Ekanayaka <freee@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Run automake
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9
 
    exit 1
10
 
fi  
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
    -patch) patch -p1 ${patch_opts} < $0;;
17
 
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
18
 
    *)
19
 
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
--- qsampler-0.1.3/Makefile.cvs 1970-01-01 01:00:00.000000000 +0100
27
 
+++ qsampler/Makefile.cvs       2005-08-24 19:44:03.000000000 +0200
28
 
@@ -0,0 +1,11 @@
29
 
+all:   configure
30
 
+
31
 
+configure:      Makefile.in configure.ac
32
 
+       @autoheader
33
 
+       @autoconf
34
 
+       @rm -rf *.cache
35
 
+
36
 
+clean:
37
 
+       @if [ -f Makefile ]; then make clean; fi || true
38
 
+       @rm -rvf Makefile configure config.*
39
 
+       @rm -rvf *.cache *.log *.status *.pro *.spec