~ubuntu-branches/ubuntu/trusty/qtscript-opensource-src/trusty

« back to all changes in this revision

Viewing changes to debian/patches/s390x_jscore.diff

  • Committer: Package Import Robot
  • Author(s): Lisandro Damián Nicanor Pérez Meyer, Pino Toscano, Lisandro Damián Nicanor Pérez Meyer
  • Date: 2013-06-20 19:45:49 UTC
  • Revision ID: package-import@ubuntu.com-20130620194549-psxc6wcso6h5u31o
Tags: 5.0.2+dfsg-3
[ Pino Toscano ]
* debian/control: remove extra ${misc:Pre-Depends} from qtscript5-examples.
* Copy patch s390x_jscore.diff from qt4-x11 (which is a backport of an
  upstream commit) to support s390/s390x.

[ Lisandro Damián Nicanor Pérez Meyer ]
* Build the documentation shipped with this submodule as a build-indep task:
  - Add the necessary indep build dependencies:
    * qttools5-dev-tools to use qhelpgenerator.
    * libqt5sql5-sqlite to generate qch doc.
  - Build and create packages for qch and HTML doc formats.
* Update symbols file.
* Make qtscript5-dbg M-A same to allow debugging symbols coinstalability.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Add support for s390/s390x architectures
 
2
Author: Dan Horák <dan@danny.cz>
 
3
Origin: vendor (http://trac.webkit.org/changeset?old_path=%2Ftrunk&old=71843+&new_path=%2Ftrunk&new=71844+)
 
4
Forwarded: no
 
5
Last-Update: 2011-08-03
 
6
 
 
7
---
 
8
 src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h |   14 +++++++++++++-
 
9
 1 file changed, 13 insertions(+), 1 deletion(-)
 
10
 
 
11
--- a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
 
12
+++ b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
 
13
@@ -189,6 +189,18 @@
 
14
 #define WTF_CPU_SPARC 1
 
15
 #endif
 
16
 
 
17
+/* CPU(S390X) - S390 64-bit */
 
18
+#if defined(__s390x__)
 
19
+#define WTF_CPU_S390X 1
 
20
+#define WTF_CPU_BIG_ENDIAN 1
 
21
+#endif
 
22
+
 
23
+/* CPU(S390) - S390 32-bit */
 
24
+#if defined(__s390__)
 
25
+#define WTF_CPU_S390 1
 
26
+#define WTF_CPU_BIG_ENDIAN 1
 
27
+#endif
 
28
+
 
29
 /* CPU(X86) - i386 / x86 32-bit */
 
30
 #if   defined(__i386__) \
 
31
     || defined(i386)     \
 
32
@@ -873,7 +885,7 @@
 
33
 #endif
 
34
 
 
35
 #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
 
36
-#if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64)
 
37
+#if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64) || CPU(S390X)
 
38
 #define WTF_USE_JSVALUE64 1
 
39
 #elif CPU(ARM) || CPU(PPC64)
 
40
 #define WTF_USE_JSVALUE32 1