~ubuntu-branches/ubuntu/trusty/rtmpdump/trusty

« back to all changes in this revision

Viewing changes to debian/patches/02_strtime-visibility.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2010-07-05 19:57:14 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100705195714-f4hefj53rge6g7vr
Tags: 2.3-1
* New upstream release:
  + debian/patches/02_fix_gnutls_teardown.diff:
    - Dropped, merged upstream.
  + debian/librtmp0.install,
    debian/librtmp0.symbols,
    debian/control,
    debian/librtmp-dev.install,
    debian/rules:
    - Add shared library package.
  + debian/patches/01_unbreak_makefile.diff:
    - Refreshed and fixed the clean rule too.
  + debian/patches/02_strtime-visibility.patch:
    - Hide the private strtime symbol by making it static
      to prevent any symbol conflicts.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: rtmpdump-2.3/librtmp/hashswf.c
 
2
===================================================================
 
3
--- rtmpdump-2.3.orig/librtmp/hashswf.c 2010-07-05 19:54:38.120781678 +0200
 
4
+++ rtmpdump-2.3/librtmp/hashswf.c      2010-07-05 19:54:48.908791094 +0200
 
5
@@ -435,7 +435,7 @@
 
6
 /* Convert a Unix time to a network time string
 
7
  * Weekday, DD-MMM-YYYY HH:MM:SS GMT
 
8
  */
 
9
-void
 
10
+static void
 
11
 strtime(time_t * t, char *s)
 
12
 {
 
13
   struct tm *tm;