~ubuntu-branches/ubuntu/trusty/rxvt-unicode/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_remove_rpath.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Eduard Bloch
  • Date: 2004-05-11 09:11:42 UTC
  • Revision ID: james.westby@ubuntu.com-20040511091142-l3sj8vkfjp8aaljo
Tags: 3.0-1
New upstream release

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 01_remove_rpath.dpatch by Eduard Bloch <blade@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Remove the rpath arguments from the linker calls
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
 
14
 
 
15
case "$1" in
 
16
    -patch) patch -p1 ${patch_opts} < $0;;
 
17
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
 
18
    *)
 
19
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
20
        exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
diff -urNad /home/inet/debian/dev/build-area/rxvt-unicode-1.8.obsolete.0.39377582453108/src/Makefile.in rxvt-unicode-1.8.obsolete.0.39377582453108/src/Makefile.in
 
27
--- /home/inet/debian/dev/build-area/rxvt-unicode-1.8.obsolete.0.39377582453108/src/Makefile.in 2004-01-31 05:13:49.000000000 +0100
 
28
+++ rxvt-unicode-1.8.obsolete.0.39377582453108/src/Makefile.in  2004-02-24 10:37:20.000000000 +0100
 
29
@@ -124,7 +124,7 @@
 
30
        date >.protos
 
31
 
 
32
 librxvt.la: $(LIBOBJS)
 
33
-       $(LIBTOOL) --mode=link $(LINK) -rpath $(libdir) -version-info $(LIBVERSION) $(LIBOBJS) $(LIBS) $(SUPLIB) -o $@
 
34
+       $(LIBTOOL) --mode=link $(LINK) -version-info $(LIBVERSION) $(LIBOBJS) $(LIBS) $(SUPLIB) -o $@
 
35
 #-------------------------------------------------------------------------
 
36
 tags: $(SRCS) $(HDRS) $(EXTRAHDRS)
 
37
        ctags $(SRCS) $(HDRS) $(EXTRAHDRS)