~ubuntu-branches/ubuntu/trusty/scotch/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/install.patch

  • Committer: Bazaar Package Importer
  • Author(s): "Adam C. Powell, IV", Christophe Trophime, Johannes Ring, Adam C. Powell, IV, Angel Abad
  • Date: 2011-03-27 14:55:43 UTC
  • Revision ID: james.westby@ubuntu.com-20110327145543-4z6ls5frctvzodla
Tags: 5.1.11.dfsg-4
[Christophe Trophime]
* Add support for multiple Integer size versions (closes: #619840)
* debian/rules : rewrite to support multiple integer size versions and remove
  cdbs

[Johannes Ring]
* Remove -DSCOTCH_PTHREAD option from debian/Makefile*.inc (closes: #612621)
* Removed no-extra-clean.patch (closes: #612606).

[ Adam C. Powell, IV ]
* Fixed a couple of issues in debian/rules clean target.
* Reinstated debugging package builds after cdbs removal.

[ Angel Abad ]
* Fix FTBFS with binutils-gold (closes: #612170)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: scotch-5.1.11.dfsg/src/Makefile
 
2
===================================================================
 
3
--- scotch-5.1.11.dfsg.orig/src/Makefile        2011-01-27 09:04:02.000000000 +0100
 
4
+++ scotch-5.1.11.dfsg/src/Makefile     2011-01-27 09:19:42.000000000 +0100
 
5
@@ -103,8 +103,16 @@
 
6
 
 
7
 install                                :       required        $(bindir)       $(includedir)   $(libdir)       $(mandir)/man1
 
8
                                        -$(CP) -f ../bin/[agm]*$(EXE) $(bindir)
 
9
+                                       -$(CP) -f ../bin/dg*$(EXE) $(bindir)
 
10
+                                       -$(CP) -f ../bin/*scotch_esmumps$(EXE) $(bindir)
 
11
                                        -$(CP) -f ../include/*scotch*.h $(includedir)
 
12
-                                       -$(CP) -f ../lib/*scotch*$(LIB) $(libdir)
 
13
+                                       -$(CP) -f ../include/*metis*.h $(includedir)
 
14
+                                       -$(CP) -f ../include/*esmumps*.h $(includedir)
 
15
+                                       -$(CP) -af ../lib/*scotch*$(LIB) $(libdir)
 
16
+                                       -$(CP) -af ../lib/*scotch*.so $(libdir)
 
17
+                                       -$(CP) -af ../lib/*esmumps*$(LIB) $(libdir)
 
18
+                                       -$(CP) -af ../lib/*esmumps*.so $(libdir)
 
19
+                                       -$(CP) -af ../lib/*metis*.so $(libdir)
 
20
                                        -$(CP) -Rf ../man/* $(mandir)
 
21
 
 
22
 clean                          :       required