~ubuntu-branches/ubuntu/trusty/silo-llnl/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/autoreconf.patch

  • Committer: Package Import Robot
  • Author(s): Alastair McKinstry
  • Date: 2011-09-10 09:43:46 UTC
  • mfrom: (5.1.1 experimental)
  • Revision ID: package-import@ubuntu.com-20110910094346-nssh4a88yurnfw0p
Tags: 4.8-7
* Don't trust pdbuilder, even after pbuilder --clean.
* B-D on autoconf,  automake for autoreconf,

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Alastair McKinstry <mckinstry@debian.org>
 
2
Description: Fixes needed for autoreconf to work on Debian
 
3
 When autoreconf is run, VL_LIB_READLINE is lost from aclocal, so included in config/
 
4
 Also include AX_CHECK_COMPLER_FLAG() which is not in autoconf (just autoconf-archive)
 
5
 AX_CHECK_COMPILER_FLAGS() is obsolete
 
6
Last-Updated: 2011-09-05
 
7
Forwarded: no
 
8
 
 
9
Index: silo-llnl-4.8/configure.ac
 
10
===================================================================
 
11
--- silo-llnl-4.8.orig/configure.ac     2011-09-09 20:02:41.000000000 +0100
 
12
+++ silo-llnl-4.8/configure.ac  2011-09-09 21:14:41.000000000 +0100
 
13
@@ -362,6 +362,9 @@
 
14
 dnl
 
15
 dnl     Alastair McKinstry, Fri Aug 25 17:24:00 BST 2011
 
16
 dnl     Add version script support.
 
17
+dnl
 
18
+dnl     Alastair McKinstry Mon Sep 5 09:55:00 IST 2011
 
19
+dnl     Add AC_PROG_F77 needed for autoreconf to work.
 
20
 dnl --------------------------------------------------------------------------
 
21
 
 
22
 dnl
 
23
@@ -409,6 +412,8 @@
 
24
 dnl This allows multiple src-dir builds within one host.
 
25
 AC_PREFIX_DEFAULT("SILO_TOP_SRC_DIR")
 
26
 
 
27
+AC_PROG_F77
 
28
+
 
29
 dnl
 
30
 dnl Handle the python module right away to determine if we need shared libs.
 
31
 dnl Ordinarily, we default to static libs
 
32
@@ -772,10 +777,10 @@
 
33
 # it is an argument to the -D argument. So, I think this is
 
34
 # just totally bogus!
 
35
 # Default to large file support
 
36
-AX_CHECK_COMPILER_FLAGS("-D_LARGEFILE_SOURCE",CFLAGS="$CFLAGS -D_LARGEFILE_SOURCE";)
 
37
-AX_CHECK_COMPILER_FLAGS("-D_LARGEFILE64_SOURCE",CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE";)
 
38
-AX_CHECK_COMPILER_FLAGS("-D_FILE_OFFSET_BITS=64",CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64";)
 
39
-AX_CHECK_COMPILER_FLAGS("-Wdeclaration-after-statement",CFLAGS="$CFLAGS -Wdeclaration-after-statement";)
 
40
+AX_CHECK_COMPILE_FLAG("-D_LARGEFILE_SOURCE",CFLAGS="$CFLAGS -D_LARGEFILE_SOURCE";)
 
41
+AX_CHECK_COMPILE_FLAG("-D_LARGEFILE64_SOURCE",CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE";)
 
42
+AX_CHECK_COMPILE_FLAG("-D_FILE_OFFSET_BITS=64",CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64";)
 
43
+AX_CHECK_COMPILE_FLAG("-Wdeclaration-after-statement",CFLAGS="$CFLAGS -Wdeclaration-after-statement";)
 
44
 
 
45
 #
 
46
 # Note: regardless of what the stuff above regarding large file support
 
47
@@ -1463,12 +1468,12 @@
 
48
             tools/silex/Makefile
 
49
             tools/silock/Makefile
 
50
            silo.pc])
 
51
-if test -n "$HZIP"; then
 
52
-  AC_CONFIG_FILES([src/hzip/Makefile])
 
53
-fi
 
54
-if test -n "$FPZIP"; then
 
55
-  AC_CONFIG_FILES([src/fpzip/Makefile])
 
56
-fi
 
57
+#if test -n "$HZIP"; then
 
58
+#  AC_CONFIG_FILES([src/hzip/Makefile])
 
59
+#fi
 
60
+#if test -n "$FPZIP"; then
 
61
+#  AC_CONFIG_FILES([src/fpzip/Makefile])
 
62
+#fi
 
63
 if test -n "$HDF5_DRV"; then
 
64
   AC_CONFIG_FILES([src/libsiloh5.settings])
 
65
 else
 
66
Index: silo-llnl-4.8/src/Makefile.am
 
67
===================================================================
 
68
--- silo-llnl-4.8.orig/src/Makefile.am  2011-09-09 20:02:41.000000000 +0100
 
69
+++ silo-llnl-4.8/src/Makefile.am       2011-09-09 20:02:41.000000000 +0100
 
70
@@ -75,17 +75,17 @@
 
71
 DRIVER_DIRS += taurus
 
72
 DRIVER_LIBS += taurus/libsilo_taurus.la
 
73
 endif
 
74
-if HZIP_NEEDED
 
75
-DRIVER_DIRS += hzip
 
76
-DRIVER_LIBS += hzip/libsilo_hzip.la
 
77
-endif
 
78
-if FPZIP_NEEDED
 
79
-DRIVER_DIRS += fpzip
 
80
-DRIVER_LIBS += fpzip/libsilo_fpzip.la
 
81
-endif
 
82
+#if HZIP_NEEDED
 
83
+#DRIVER_DIRS += hzip
 
84
+#DRIVER_LIBS += hzip/libsilo_hzip.la
 
85
+#endif
 
86
+#if FPZIP_NEEDED
 
87
+#DRIVER_DIRS += fpzip
 
88
+#DRIVER_LIBS += fpzip/libsilo_fpzip.la
 
89
+#endif
 
90
 SUBDIRS = score pdb silo debug \
 
91
 $(DRIVER_DIRS) unknown filters .
 
92
-DIST_SUBDIRS = . debug filters hdf5_drv hzip netcdf \
 
93
+DIST_SUBDIRS = . debug filters hdf5_drv netcdf \
 
94
 pdb pdb_drv pdbp_drv score silo taurus unknown
 
95
 MAKESETTINGS = make.settings
 
96