~ubuntu-branches/ubuntu/trusty/speech-dispatcher/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_warnings.patch

  • Committer: Package Import Robot
  • Author(s): Luke Yelavich, Samuel Thibault, Luke Yelavich, Jason White, David Henningsson
  • Date: 2013-11-11 16:38:46 UTC
  • mfrom: (1.1.19)
  • Revision ID: package-import@ubuntu.com-20131111163846-lvu37ypp5sy9z5so
Tags: 0.8-0ubuntu1
[ Samuel Thibault ]
* debian/control: Set libspeechd2 multi-arch: same.
* debian/rules: Set multiarch libdir.
* debian/libspeechd-dev.install,libspeechd2.install,
  speech-dispatcher.install: Use multiarch libdir.
* Do not depend on dpkg | install-info, now that we use the install-info
  trigger.
* Bump Standards-Version to 3.9.5.
* Bump dotconf dependency to >= 1.3.

[ Luke Yelavich ]
* New upstream release
* debian/patches/infinite-loop.patch: Refreshed
* Dropped patches:
  - debian/patches/build-doc.patch
  - debian/patches/procname.patch
  - debian/patches/paths+files.patch
  - debian/patches/pthread.patch
* Add libltdl-dev and intltool to build-depends
* Update packaging for speech-dispatcher python 3 bindings.
* Move speech-dispatcher modules to an architecture independant dir, since
  modules can be written in any language, and i386 only modules can be
  used on amd64 systems
* Create separate audio plugins package
* Convert to debhelper 7+ packaging.
* Use dh-autoreconf to handle autotools file rebuilds.
* Update standards version to 3.9.3.
* Add X-Python-Version related fields to debian/control.
* Patch in the speech-dispatcher-cs.texi file since it was forgotten in the
  0.8 tarball
* Add translations to speech-dispatcher
* Merge from debian unreleased git.  Remaining changes:
  - Moved the flite output module to a separate package, and added
    it to suggests, we don't want flite on the Ubuntu CD image
  - Don't build depend on libaudio-dev or libao-dev, Ubuntu CD size is an
    issue, every little bit helps
  - debian/gbp.conf: Adjust for the Ubuntu git branch
  - Python3-speechd needs to conflict against python-speechd

[ Jason White ]
* Raise level of subsection in fdl.texi to correct document structure.

[ David Henningsson ]
* debian/patches/pulse-default-latency.patch:
  Default to 20 ms latency instead of 1 ms latency (LP: #1208826)

[ Luke Yelavich ]
* spd_audio: Expose dlopened library's symbols to libs it loads. Thanks to
  Christopher Brannon <chris@the-brannons.com> for the patch, taken from
  the speech-dispatcher mailing list.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: speech-dispatcher/src/modules/module_utils.c
2
 
===================================================================
3
 
--- speech-dispatcher.orig/src/modules/module_utils.c   2013-08-28 05:06:19.131107575 +1000
4
 
+++ speech-dispatcher/src/modules/module_utils.c        2013-08-28 05:06:19.127107575 +1000
5
 
@@ -1006,7 +1006,7 @@
6
 
 {
7
 
     pthread_mutex_lock(&module_stdout_mutex);
8
 
     DBG("Printing reply: %s", text);
9
 
-    fprintf(stdout, text);
10
 
+    fprintf(stdout, "%s", text);
11
 
     fflush(stdout);
12
 
     DBG("Printed");
13
 
     pthread_mutex_unlock(&module_stdout_mutex);
14
 
Index: speech-dispatcher/src/modules/festival_client.c
15
 
===================================================================
16
 
--- speech-dispatcher.orig/src/modules/festival_client.c        2013-08-28 05:07:37.975109594 +1000
17
 
+++ speech-dispatcher/src/modules/festival_client.c     2013-08-28 05:15:00.951120936 +1000
18
 
@@ -437,7 +437,7 @@
19
 
         fd = fdopen(dup(info->server_fd),"wb"); \
20
 
         if (fd != NULL){ \
21
 
           str = g_strdup_printf(format"\n"); \
22
 
-          fprintf(fd, str); \
23
 
+          fprintf(fd, "%s", str); \
24
 
           DBG("-> Festival: |%s|", str); \
25
 
           free(str); \
26
 
           fclose(fd); \
27
 
@@ -453,7 +453,7 @@
28
 
         fd = fdopen(dup(info->server_fd),"wb"); \
29
 
         if (fd != NULL){ \
30
 
           str = g_strdup_printf(format"\n", args); \
31
 
-          fprintf(fd, str); \
32
 
+          fprintf(fd, "%s", str); \
33
 
           DBG("-> Festival: |%s|", str); \
34
 
           free(str); \
35
 
           fclose(fd); \
36
 
@@ -546,7 +546,7 @@
37
 
       str = g_strdup_printf("(%s \"", command);
38
 
     else
39
 
       str = g_strdup_printf("(%s '", command);
40
 
-    fprintf(fd, str);
41
 
+    fprintf(fd, "%s", str);
42
 
     /* Copy text over to server, escaping any quotes */
43
 
     for (p=text; p && (*p != '\0'); p++)
44
 
     {