~ubuntu-branches/ubuntu/trusty/spyder/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.0.3-1

  • Committer: Bazaar Package Importer
  • Author(s): Ludovic Aubry
  • Date: 2010-06-28 23:43:02 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100628234302-3xnz0gcu0w83282r
Tags: 1.1.1-1
* New upstream release
* New maintainer address (Closes: #586833)
* Build with python 2.6 (Closes: #586824)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Upstream changes introduced in version 1.0.3-1
2
 
 This patch has been created by dpkg-source during the package build.
3
 
 Here's the last changelog entry, hopefully it gives details on why
4
 
 those changes were made:
5
 
 .
6
 
 spyder (1.0.3-1) unstable; urgency=low
7
 
 .
8
 
   * Initial release (Closes: #553400)
9
 
   * use debian versions for pyflakes and jquery
10
 
 .
11
 
 The person named in the Author field signed this changelog entry.
12
 
Author: Ludovic Aubry <ludovic.aubry@logilab.fr>
13
 
Bug-Debian: http://bugs.debian.org/553400
14
 
 
15
 
---
16
 
The information above should follow the Patch Tagging Guidelines, please
17
 
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
18
 
are templates for supplementary fields that you might want to add:
19
 
 
20
 
Origin: <vendor|upstream|other>, <url of original patch>
21
 
Bug: <url in upstream bugtracker>
22
 
Bug-Debian: http://bugs.debian.org/<bugnumber>
23
 
Forwarded: <no|not-needed|url proving that it has been forwarded>
24
 
Reviewed-By: <name and email of someone who approved the patch>
25
 
Last-Update: <YYYY-MM-DD>
26
 
 
27
 
--- spyder-1.0.3.orig/setup.py
28
 
+++ spyder-1.0.3/setup.py
29
 
@@ -30,7 +30,7 @@ from spyderlib import __version__ as ver
30
 
 google_url = 'http://%s.googlecode.com' % libname
31
 
 download_url = '%s/files/%s-%s.tar.gz' % (google_url, name, version)
32
 
 packages = [libname+p for p in ['', '.widgets', '.widgets.externalshell',
33
 
-                                '.plugins', '.pyflakes', '.utils']]
34
 
+                                '.plugins', '.utils']]
35
 
 extensions = ('.qm', '.api', '.svg', '.png',
36
 
               '.html', '.js', '', '.inv', '.txt', '.css', '.ico', '.doctree')
37
 
 package_data={libname: get_package_data(libname, extensions)}
38
 
--- spyder-1.0.3.orig/spyderlib/spyder.py
39
 
+++ spyder-1.0.3/spyderlib/spyder.py
40
 
@@ -68,18 +68,8 @@ def get_python_doc_path():
41
 
     Return Python documentation path
42
 
     (Windows: return the PythonXX.chm path if available)
43
 
     """
44
 
-    python_doc = ''
45
 
-    doc_path = osp.join(sys.prefix, "Doc")
46
 
-    if osp.isdir(doc_path):
47
 
-        if os.name == 'nt':
48
 
-            python_chm = [ path for path in  os.listdir(doc_path) \
49
 
-                           if re.match(r"(?i)Python[0-9]{3}.chm", path) ]
50
 
-            if python_chm:
51
 
-                python_doc = osp.join(doc_path, python_chm[0])
52
 
-        if not python_doc:
53
 
-            python_doc = osp.join(doc_path, "index.html")
54
 
-    if osp.isfile(python_doc):
55
 
-        return python_doc
56
 
+    # Debian specific
57
 
+    return "/usr/share/doc/spyder/doc/index.html"
58
 
     
59
 
 def open_python_doc():
60
 
     """
61
 
--- spyder-1.0.3.orig/spyderlib/widgets/qscieditor.py
62
 
+++ spyder-1.0.3/spyderlib/widgets/qscieditor.py
63
 
@@ -43,7 +43,7 @@ from spyderlib.utils import sourcecode
64
 
 # Pyflakes code analysis
65
 
 #===============================================================================
66
 
 import compiler
67
 
-from spyderlib.pyflakes import checker
68
 
+from pyflakes import checker
69
 
 
70
 
 def check(filename):
71
 
     try:
72
 
--- /dev/null
73
 
+++ spyder-1.0.3/spyder.egg-info/entry_points.txt
74
 
@@ -0,0 +1,3 @@
75
 
+[gui_scripts]
76
 
+spyder = spyderlib.spyder:main
77
 
+
78
 
--- /dev/null
79
 
+++ spyder-1.0.3/spyder.egg-info/top_level.txt
80
 
@@ -0,0 +1 @@
81
 
+spyderlib
82
 
--- /dev/null
83
 
+++ spyder-1.0.3/spyder.egg-info/dependency_links.txt
84
 
@@ -0,0 +1 @@
85
 
+
86
 
--- /dev/null
87
 
+++ spyder-1.0.3/spyder.egg-info/PKG-INFO
88
 
@@ -0,0 +1,25 @@
89
 
+Metadata-Version: 1.1
90
 
+Name: spyder
91
 
+Version: 1.0.3
92
 
+Summary: Spyder development environment and its PyQt4-based IDE tools: interactive Python shell, Python code editor, workspace (dict/list/string/array editor), doc viewer, history log, environment variables editor, ...
93
 
+Home-page: http://spyderlib.googlecode.com
94
 
+Author: Pierre Raybaut
95
 
+Author-email: contact@pythonxy.com
96
 
+License: MIT
97
 
+Download-URL: http://spyderlib.googlecode.com/files/spyder-1.0.3.tar.gz
98
 
+Description: spyderlib is intended to be an extension to PyQt4 providing a simple development environment named "Spyder" - a powerful alternative to IDLE (see screenshots: http://spyderlib.googlecode.com) based on independent widgets interacting with each other: workspace (globals explorer with dict/list editor and numpy arrays editor), docstring viewer (calltip), history log, multiline code editor (support drag and drop, autocompletion, syntax coloring, ...), environment variables editor (including a Windows-specific editor to change current user environement variables) and working directory browser.
99
 
+Keywords: PyQt4 shell console widgets IDE
100
 
+Platform: any
101
 
+Classifier: Development Status :: 5 - Production/Stable
102
 
+Classifier: Topic :: Scientific/Engineering
103
 
+Classifier: Topic :: Software Development :: Widget Sets
104
 
+Classifier: License :: OSI Approved :: MIT License
105
 
+Classifier: Operating System :: MacOS
106
 
+Classifier: Operating System :: Microsoft :: Windows
107
 
+Classifier: Operating System :: OS Independent
108
 
+Classifier: Operating System :: POSIX
109
 
+Classifier: Operating System :: Unix
110
 
+Classifier: Programming Language :: Python :: 2.5
111
 
+Classifier: Programming Language :: Python :: 2.6
112
 
+Requires: QScintilla2 (>2.1)
113
 
+Requires: PyQt4 (>4.3)
114
 
--- /dev/null
115
 
+++ spyder-1.0.3/spyder.egg-info/SOURCES.txt
116
 
@@ -0,0 +1,63 @@
117
 
+README
118
 
+setup.py
119
 
+spyder
120
 
+spyder.egg-info/PKG-INFO
121
 
+spyder.egg-info/SOURCES.txt
122
 
+spyder.egg-info/dependency_links.txt
123
 
+spyder.egg-info/entry_points.txt
124
 
+spyder.egg-info/top_level.txt
125
 
+spyderlib/__init__.py
126
 
+spyderlib/config.py
127
 
+spyderlib/interpreter.py
128
 
+spyderlib/spyder.py
129
 
+spyderlib/userconfig.py
130
 
+spyderlib/plugins/__init__.py
131
 
+spyderlib/plugins/console.py
132
 
+spyderlib/plugins/docviewer.py
133
 
+spyderlib/plugins/editor.py
134
 
+spyderlib/plugins/explorer.py
135
 
+spyderlib/plugins/externalconsole.py
136
 
+spyderlib/plugins/figure.py
137
 
+spyderlib/plugins/findinfiles.py
138
 
+spyderlib/plugins/history.py
139
 
+spyderlib/plugins/pylintgui.py
140
 
+spyderlib/plugins/workdir.py
141
 
+spyderlib/plugins/workspace.py
142
 
+spyderlib/utils/__init__.py
143
 
+spyderlib/utils/dochelpers.py
144
 
+spyderlib/utils/encoding.py
145
 
+spyderlib/utils/environ.py
146
 
+spyderlib/utils/iofuncs.py
147
 
+spyderlib/utils/programs.py
148
 
+spyderlib/utils/qthelpers.py
149
 
+spyderlib/utils/sourcecode.py
150
 
+spyderlib/widgets/__init__.py
151
 
+spyderlib/widgets/arrayeditor.py
152
 
+spyderlib/widgets/classbrowser.py
153
 
+spyderlib/widgets/classparser.py
154
 
+spyderlib/widgets/comboboxes.py
155
 
+spyderlib/widgets/dicteditor.py
156
 
+spyderlib/widgets/explorer.py
157
 
+spyderlib/widgets/figureoptions.py
158
 
+spyderlib/widgets/findinfiles.py
159
 
+spyderlib/widgets/findreplace.py
160
 
+spyderlib/widgets/formlayout.py
161
 
+spyderlib/widgets/importwizard.py
162
 
+spyderlib/widgets/interactiveshell.py
163
 
+spyderlib/widgets/objecteditor.py
164
 
+spyderlib/widgets/pathmanager.py
165
 
+spyderlib/widgets/pylintgui.py
166
 
+spyderlib/widgets/qscibase.py
167
 
+spyderlib/widgets/qscieditor.py
168
 
+spyderlib/widgets/qtebase.py
169
 
+spyderlib/widgets/shell.py
170
 
+spyderlib/widgets/shellhelpers.py
171
 
+spyderlib/widgets/tabs.py
172
 
+spyderlib/widgets/texteditor.py
173
 
+spyderlib/widgets/externalshell/__init__.py
174
 
+spyderlib/widgets/externalshell/globalsexplorer.py
175
 
+spyderlib/widgets/externalshell/monitor.py
176
 
+spyderlib/widgets/externalshell/pythonshell.py
177
 
+spyderlib/widgets/externalshell/sitecustomize.py
178
 
+spyderlib/widgets/externalshell/startup.py
179
 
+spyderlib/widgets/externalshell/systemshell.py
180
 
\ No newline at end of file