~ubuntu-branches/ubuntu/trusty/subversion/trusty-updates

« back to all changes in this revision

Viewing changes to debian/patches/ruby19.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2013-12-02 10:03:16 UTC
  • Revision ID: package-import@ubuntu.com-20131202100316-vzokr9c3bajxzkw8
Tags: 1.7.13-2ubuntu3
* debian/control, debian/rules: build against default ruby, instead of
  ruby1.8. (LP: #1254052)
* debian/patches/ruby19.patch: disable check for ruby 1.8, and backport
  a few changes to the test suite.
* debian/control: added ruby-test-unit to Build-Depends

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: disable check for ruby 1.8, and backport a few changes
 
2
 to the test suite from subversion 1.8.5.
 
3
Author: Marc Deslauriers <marc.deslauriers@canonical.com>
 
4
 
 
5
Index: subversion-1.7.13/configure.ac
 
6
===================================================================
 
7
--- subversion-1.7.13.orig/configure.ac 2013-12-02 11:07:23.214207468 -0500
 
8
+++ subversion-1.7.13/configure.ac      2013-12-02 11:07:23.206207428 -0500
 
9
@@ -1136,13 +1136,6 @@
 
10
 
 
11
     AC_SUBST(RUBY_MAJOR)
 
12
     AC_SUBST(RUBY_MINOR)
 
13
-    if test ! \( "$RUBY_MAJOR" -eq "1" -a "$RUBY_MINOR" -eq "8" \); then
 
14
-      # Disallow Ruby 1.9 or later until the binding tests get fixed
 
15
-      # to run with those versions.
 
16
-      RUBY="none"
 
17
-      AC_MSG_WARN([The detected Ruby is too new for Subversion to use])
 
18
-      AC_MSG_WARN([Only 1.8.x releases are supported at this time])
 
19
-    fi
 
20
   else
 
21
     AC_MSG_RESULT([no])
 
22
     RUBY="none"
 
23
Index: subversion-1.7.13/subversion/bindings/swig/ruby/test/test_core.rb
 
24
===================================================================
 
25
--- subversion-1.7.13.orig/subversion/bindings/swig/ruby/test/test_core.rb      2013-12-02 11:07:23.214207468 -0500
 
26
+++ subversion-1.7.13/subversion/bindings/swig/ruby/test/test_core.rb   2013-12-02 11:07:23.206207428 -0500
 
27
@@ -1,3 +1,4 @@
 
28
+# encoding = utf-8
 
29
 # ====================================================================
 
30
 #    Licensed to the Apache Software Foundation (ASF) under one
 
31
 #    or more contributor license agreements.  See the NOTICE file
 
32
Index: subversion-1.7.13/subversion/bindings/swig/ruby/test/test-unit-ext.rb
 
33
===================================================================
 
34
--- subversion-1.7.13.orig/subversion/bindings/swig/ruby/test/test-unit-ext.rb  2009-11-30 13:18:42.000000000 -0500
 
35
+++ subversion-1.7.13/subversion/bindings/swig/ruby/test/test-unit-ext.rb       2013-12-02 11:07:55.774368927 -0500
 
36
@@ -17,7 +17,7 @@
 
37
 #    under the License.
 
38
 # ====================================================================
 
39
 
 
40
-require "test-unit-ext/always-show-result"
 
41
+require "test-unit-ext/always-show-result" if RUBY_VERSION < '1.9.3'
 
42
 require "test-unit-ext/priority"
 
43
-require "test-unit-ext/backtrace-filter"
 
44
-require "test-unit-ext/long-display-for-emacs"
 
45
+require "test-unit-ext/backtrace-filter" if RUBY_VERSION < '1.9.3'
 
46
+require "test-unit-ext/long-display-for-emacs" if RUBY_VERSION < '1.9.3'