~ubuntu-branches/ubuntu/trusty/ucl/trusty

« back to all changes in this revision

Viewing changes to debian/patches/01-Examples.patch

  • Committer: Package Import Robot
  • Author(s): Robert Luberda
  • Date: 2012-01-08 20:45:02 UTC
  • mfrom: (3.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20120108204502-ds3stjc0fqs4omis
Tags: 1.03-5
* Switch to `3.0 (quilt)' format. Add initial 01-Examples.patch
  containing previous changes.
* Switch to debhelper v9 and tiny rules file:
  + use dh_autotools-dev to update config.{sub,guess} files;
  + multi-arch support;
  + use dpkg-buildflags to set CFLAGS and LDFLAGS;
  + bump build-dependencies on debhelper and dpkg-dev.
* Fix examples/Makefile not to remove original *.c.gz files.
* debian/control:
  + add VCS fields.
  + drop ancient Conflicts/Replaces/Provides on libucl;
  + Standards-Version: 3.9.2 (no changes);
  + sort dependency fields with wrap-and-sort.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Robert Luberda <robert@debian.org>
 
2
Date: Mon, 26 Jul 2004 20:44:00 +0200
 
3
Subject: 01 Examples.
 
4
 
 
5
Fix examples.
 
6
---
 
7
 examples/portab.h  |    2 +-
 
8
 examples/simple.c  |    2 +-
 
9
 examples/uclpack.c |    2 +-
 
10
 3 files changed, 3 insertions(+), 3 deletions(-)
 
11
 
 
12
diff --git a/examples/portab.h b/examples/portab.h
 
13
index 6cf0752..719839c 100644
 
14
--- a/examples/portab.h
 
15
+++ b/examples/portab.h
 
16
@@ -28,7 +28,7 @@
 
17
 
 
18
 #include <ucl/uclconf.h>
 
19
 
 
20
-#if 1
 
21
+#if 0
 
22
 
 
23
 #include "examples/portab_a.h"
 
24
 
 
25
diff --git a/examples/simple.c b/examples/simple.c
 
26
index 5fd54be..faecf60 100644
 
27
--- a/examples/simple.c
 
28
+++ b/examples/simple.c
 
29
@@ -32,7 +32,7 @@
 
30
 
 
31
 /* portability layer */
 
32
 #define WANT_UCL_MALLOC 1
 
33
-#include "examples/portab.h"
 
34
+#include "portab.h"
 
35
 
 
36
 
 
37
 /*************************************************************************
 
38
diff --git a/examples/uclpack.c b/examples/uclpack.c
 
39
index a340c24..a104876 100644
 
40
--- a/examples/uclpack.c
 
41
+++ b/examples/uclpack.c
 
42
@@ -60,7 +60,7 @@
 
43
 #define WANT_UCL_UCLOCK 1
 
44
 #endif
 
45
 #define WANT_UCL_WILDARGV 1
 
46
-#include "examples/portab.h"
 
47
+#include "portab.h"
 
48
 
 
49
 
 
50
 static const char *progname = NULL;
 
51
--