~ubuntu-branches/ubuntu/trusty/unity-greeter/trusty

« back to all changes in this revision

Viewing changes to debian/patches/spawn-gsd-directly.patch

  • Committer: Package Import Robot
  • Author(s): Michael Terry
  • Date: 2013-03-15 14:04:08 UTC
  • mfrom: (1.1.22)
  • Revision ID: package-import@ubuntu.com-20130315140408-m2kwmrmxtyn0j9hk
Tags: 13.04.2-0ubuntu1
* New upstream release.
  - Fix duplicate entries showing for multiple users on the same remote
    login service.
  - Add custom indicator support for system administrators (LP: #1155157)
* debian/control:
  - Switch Vcs-Bzr to point at Unity Greeter trunk, since we are inlining
    the packaging
  - Use debhelper 9
* debian/rules:
  - Use upstream ./autogen.sh for autoreconf
* debian/patches/do-not-read-password.patch,
  debian/patches/move-nm-applet.patch,
  debian/patches/spawn-gsd-directly.patch:
  - Drop, included upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'configure.ac'
2
 
Index: unity-greeter-13.04.1/configure.ac
3
 
===================================================================
4
 
--- unity-greeter-13.04.1.orig/configure.ac     2013-01-30 15:09:40.019896479 -0500
5
 
+++ unity-greeter-13.04.1/configure.ac  2013-01-30 15:09:40.015896479 -0500
6
 
@@ -30,6 +30,12 @@
7
 
 INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
8
 
 AC_SUBST(INDICATORDIR)
9
 
 
10
 
+GSD_BINARY=`$PKG_CONFIG --variable=binary gnome-settings-daemon`
11
 
+if test -z "$GSD_BINARY"; then
12
 
+    AC_MSG_ERROR([Could not find path to gnome-settings-daemon binary])
13
 
+fi
14
 
+AC_DEFINE_UNQUOTED([GSD_BINARY], ["$GSD_BINARY"], [Path to g-s-d])
15
 
+
16
 
 dnl ###########################################################################
17
 
 dnl Internationalization
18
 
 dnl ###########################################################################
19
 
Index: unity-greeter-13.04.1/src/config.vapi
20
 
===================================================================
21
 
--- unity-greeter-13.04.1.orig/src/config.vapi  2013-01-30 15:09:40.019896479 -0500
22
 
+++ unity-greeter-13.04.1/src/config.vapi       2013-01-30 15:23:20.139905047 -0500
23
 
@@ -1,4 +1,4 @@
24
 
-[CCode (cprefix = "", lower_case_cprefix = "")]
25
 
+[CCode (cprefix = "", lower_case_cprefix = "", cheader_filename = "config.h")]
26
 
 namespace Config
27
 
 {
28
 
   public const string GETTEXT_PACKAGE;
29
 
@@ -7,4 +7,5 @@
30
 
   public const string CONFIG_FILE;
31
 
   public const string PKGDATADIR;
32
 
   public const string INDICATORDIR;
33
 
+  public const string GSD_BINARY;
34
 
 }
35
 
Index: unity-greeter-13.04.1/src/settings-daemon.vala
36
 
===================================================================
37
 
--- unity-greeter-13.04.1.orig/src/settings-daemon.vala 2013-01-30 15:09:40.019896479 -0500
38
 
+++ unity-greeter-13.04.1/src/settings-daemon.vala      2013-01-30 15:09:40.019896479 -0500
39
 
@@ -79,22 +79,13 @@
40
 
 
41
 
     private async void run ()
42
 
     {
43
 
-        /* Activate g-s-d over dbus */
44
 
         try
45
 
         {
46
 
-            var proxy = new GLib.DBusProxy.for_bus_sync (GLib.BusType.SESSION,
47
 
-                                                         GLib.DBusProxyFlags.NONE, null,
48
 
-                                                         "org.gnome.SettingsDaemon",
49
 
-                                                         "/org/gnome/SettingsDaemon",
50
 
-                                                         "org.gnome.SettingsDaemon",
51
 
-                                                         null);
52
 
-
53
 
-            /* This tells g-s-d to activate its plugins */
54
 
-            yield proxy.call ("Awake", null, GLib.DBusCallFlags.NONE, -1, null);
55
 
+            Process.spawn_command_line_async (Config.GSD_BINARY);
56
 
         }
57
 
-        catch (Error e)
58
 
+        catch (SpawnError e)
59
 
         {
60
 
-            debug ("Could not start gnome-settings-daemon over DBus: %s", e.message);
61
 
+            debug ("Could not start gnome-settings-daemon: %s", e.message);
62
 
         }
63
 
     }
64
 
 }