~ubuntu-branches/ubuntu/trusty/wide-dhcpv6/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_bugfixes_20061227.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jeremie Corbier
  • Date: 2007-01-05 16:01:17 UTC
  • mfrom: (6.1.1 feisty)
  • Revision ID: james.westby@ubuntu.com-20070105160117-sen1pm6d20sc0s86
Tags: 20061016-2
* debian/control: added lsb-base as a dependency.
* debian/patches:
  -> Added 01_bugfixes_20061227.dpatch:
    + Bug fixes from CVS 20061227.
    + dhcp6relay accepts Unique Local IPv6 unicast Addresses.
    + Fix an IA allocation failure from pool in dhcp6s.
    + Fix "-P" option in dhcp6s.
  -> Updated 02_Makefile.in.dpatch.
* debian/scripts/dhcp6c-ifupdown: check whether dhcp6c is running and exit
  silently if not. Avoid errors when network is brought up before the client
  is started (Closes: #404887).
* debian/dhcp6c.conf: corrected typo in comment (Closes: #404584).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01_CVS_20061227.dpatch by Jeremie Corbier <jeremie.corbier@resel.enst-bretagne.fr>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Include bug fixes available in CVS as of 12/27/2006.
 
6
 
 
7
@DPATCH@
 
8
 
 
9
diff -Naur -x .bzr -x CVS upstream/dhcp6c.8 upstream-cvs/dhcp6c.8
 
10
--- upstream/dhcp6c.8   2006-07-30 03:24:19.000000000 -0700
 
11
+++ upstream-cvs/dhcp6c.8       2006-12-06 09:01:45.000000000 -0800
 
12
@@ -74,7 +74,19 @@
 
13
 it prints the messages to standard error if this option is
 
14
 specified.
 
15
 .It Fl i
 
16
-Info-req mode.  In this mode, stateless DHCPv6 is executed with an automatic configuration, and the obtained info is written to stdout.  After this output, the program is terminated.  (suits for a use in shell-script etc)
 
17
+Info-req mode.  In this mode, stateless DHCPv6 is executed with the folllowing configuration, and the obtained info is written to stdout.  After this output,
 
18
+.Nm
 
19
+is terminated.  (suits for a use in shell-script etc).
 
20
+.Bd -literal -offset
 
21
+ interface (interface given in the argument) {
 
22
+       information-only;
 
23
+       script (a script which displays the received information to stdout);
 
24
+ };
 
25
+.Ed
 
26
+.Pp
 
27
+Since the configuration is internally generated, you cannot provide a configuration in this mode.  If you want to have different actions for the stateless DHCPv6 information, you should write an appropriate configuration and invoke
 
28
+.Nm
 
29
+without this option.
 
30
 .It Fl p Ar pid-file
 
31
 Use
 
32
 .Ar pid-file
 
33
diff -Naur -x .bzr -x CVS upstream/dhcp6relay.c upstream-cvs/dhcp6relay.c
 
34
--- upstream/dhcp6relay.c       2006-07-28 18:42:09.000000000 -0700
 
35
+++ upstream-cvs/dhcp6relay.c   2006-12-06 09:01:46.000000000 -0800
 
36
@@ -100,6 +100,7 @@
 
37
 static char *global_strings[] = {
 
38
        /* "fec0::/10", site-local unicast addresses were deprecated */
 
39
        "2000::/3",
 
40
+       "FC00::/7",  /* Unique Local Address (RFC4193) */
 
41
        NULL
 
42
 };
 
43
 
 
44
diff -Naur -x .bzr -x CVS upstream/dhcp6s.c upstream-cvs/dhcp6s.c
 
45
--- upstream/dhcp6s.c   2006-08-06 21:35:32.000000000 -0700
 
46
+++ upstream-cvs/dhcp6s.c       2006-11-18 13:18:22.000000000 -0800
 
47
@@ -279,6 +279,7 @@
 
48
                        break;
 
49
                case 'P':
 
50
                        pid_file = optarg;
 
51
+                       break;
 
52
                default:
 
53
                        usage();
 
54
                        /* NOTREACHED */
 
55
@@ -2500,13 +2501,12 @@
 
56
                    bia = TAILQ_NEXT(bia, link)) {
 
57
                        if ((v = dhcp6_find_listval(conflist,
 
58
                            bia->type, &bia->uv, 0)) != NULL) {
 
59
-                               found++;
 
60
                                TAILQ_REMOVE(conflist, v, link);
 
61
                                dhcp6_clear_listval(v);
 
62
                        }
 
63
                }
 
64
 
 
65
-               return (found);
 
66
+               return (1);
 
67
        }
 
68
 
 
69
        /*
 
70
diff -Naur -x .bzr -x CVS upstream/Makefile.in upstream-cvs/Makefile.in
 
71
--- upstream/Makefile.in        2006-10-13 05:19:12.000000000 -0700
 
72
+++ upstream-cvs/Makefile.in    2006-11-18 13:18:22.000000000 -0800
 
73
@@ -38,7 +38,7 @@
 
74
        -DLOCALDBDIR=\"${localdbdir}\"
 
75
 LDFLAGS=@LDFLAGS@
 
76
 LIBOBJS=@LIBOBJS@
 
77
-LIBS=  @LIBS@ -ly -ll
 
78
+LIBS=  @LIBS@ @LEXLIB@
 
79
 CC=    @CC@
 
80
 TARGET=        dhcp6c dhcp6s dhcp6relay dhcp6ctl
 
81
 
 
82
@@ -94,7 +94,7 @@
 
83
        expand bootp-dhcp-parameters | perl gentab.pl > ianaopts.h
 
84
 
 
85
 install::
 
86
-       -mkdir -p $(sbindir) $(mandir)
 
87
+       -mkdir -p $(sbindir) $(mandir)/man5 $(mandir)/man8
 
88
        $(INSTALL_PROGRAM) -s -o bin -g bin $(TARGET) $(sbindir)
 
89
        $(INSTALL_DATA) -o bin -g bin dhcp6c.8 $(mandir)/man8
 
90
        $(INSTALL_DATA) -o bin -g bin dhcp6s.8 $(mandir)/man8