~ubuntu-branches/ubuntu/trusty/wvstreams/trusty

« back to all changes in this revision

Viewing changes to debian/patches/07_buildflags.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-03-14 11:51:08 UTC
  • Revision ID: package-import@ubuntu.com-20130314115108-1hjx8ce7v9d3wgjd
Tags: 4.6.1-6
* QA upload.
* Suggest tk8.5 instead of tk8.4.
* Build using hardening flags.
* Enable verbose build.
* debian/control: Remove Homepage attribute, doesn't exist anymore.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: b/gen-cc
 
2
===================================================================
 
3
--- a/gen-cc
 
4
+++ b/gen-cc
 
5
@@ -15,6 +15,11 @@
 
6
        shift
 
7
        shift
 
8
        
 
9
+       echo $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
 
10
+               -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
 
11
+               $CPPFLAGS \\
 
12
+               $CFLAGS \\
 
13
+               "\$@"
 
14
        $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
 
15
                -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
 
16
                $CPPFLAGS \\
 
17
Index: b/wvrules-posix.mk
 
18
===================================================================
 
19
--- a/wvrules-posix.mk
 
20
+++ b/wvrules-posix.mk
 
21
@@ -35,11 +35,6 @@
 
22
 # Default compiler we use for linking
 
23
 WVLINK_CC = $(CXX)
 
24
 
 
25
-ifneq ("$(enable_optimization)", "no")
 
26
-  CXXFLAGS+=-O2
 
27
-  CFLAGS+=-O2
 
28
-endif
 
29
-
 
30
 ifneq ("$(enable_warnings)", "no")
 
31
   CXXFLAGS+=-Wall -Woverloaded-virtual
 
32
   CFLAGS+=-Wall