~ubuntu-branches/ubuntu/trusty/xemacs21/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_debian_patch.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): OHURA Makoto
  • Date: 2007-10-18 00:26:27 UTC
  • Revision ID: james.westby@ubuntu.com-20071018002627-upxsfw9ie57ndiyp
Tags: 21.4.20-3
debian/control.in: Changed Build-Dependency.  Use libdb-dev instead of
libdb4.5-dev.  (Closes: #441525)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_debian_patch.dpatch by  <schizo@debian.org>
 
1
#! /bin/sh -e
 
2
## XX_PATCHNAME.dpatch by YOUR NAME <YOUR EMAIL>
3
3
##
4
4
## All lines beginning with `## DP:' are a description of the patch.
5
5
## DP: No description.
6
6
 
7
 
@DPATCH@
8
 
diff -urNad xemacs21-21.4.20~/configure.in xemacs21-21.4.20/configure.in
9
 
--- xemacs21-21.4.20~/configure.in      2006-12-07 22:31:16.000000000 -0500
10
 
+++ xemacs21-21.4.20/configure.in       2007-07-23 08:33:12.525611004 -0400
 
7
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
8
patch_opts="${patch_opts:--f --no-backup-if-mismatch ${2:+-d $2}}"
 
9
 
 
10
if [ $# -lt 1 ]; then
 
11
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
12
    exit 1
 
13
fi
 
14
case "$1" in
 
15
       -patch) patch $patch_opts -p1 < $0;;
 
16
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
17
        *)
 
18
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
19
                exit 1;;
 
20
esac
 
21
 
 
22
exit 0
 
23
 
 
24
--- xemacs21-21.4.15.orig/configure.in
 
25
+++ xemacs21-21.4.15/configure.in
11
26
@@ -349,7 +349,7 @@
12
27
 with_menubars=''
13
28
 with_scrollbars=''
17
32
 with_dialogs=''
18
33
 with_file_coding=''
19
34
 cpp='' cppflags='' libs='' ldflags=''
20
 
@@ -2040,10 +2040,10 @@
 
35
@@ -2039,10 +2044,10 @@
21
36
 dnl #### Should make this Solaris-friendly.
22
37
 dnl Link with -z nocombreloc for now.
23
38
 if test "$pdump" != "yes"; then
30
45
     *) AC_MSG_RESULT(no) ;;
31
46
   esac
32
47
 fi
33
 
@@ -4619,7 +4619,7 @@
 
48
@@ -4500,7 +4506,8 @@
34
49
     AC_MSG_RESULT(2); dbfunc=db_open])],[
35
50
     AC_MSG_RESULT(1); dbfunc=dbopen])
36
51
     AC_CHECK_FUNC($dbfunc,     with_database_berkdb=yes need_libdb=no, [
37
52
-    AC_CHECK_LIB(db, $dbfunc,  with_database_berkdb=yes need_libdb=yes)])
38
 
+    AC_CHECK_LIB(db-4.5, $dbfunc,  with_database_berkdb=yes need_libdb=yes)])
 
53
+    AC_CHECK_LIB(db, $dbfunc,  with_database_berkdb=yes need_libdb=yes, [
 
54
+    AC_CHECK_LIB(db, [${dbfunc}_4001], with_database_berkdb=yes need_libdb=yes) ])])
39
55
   fi
40
56
 
41
57
   if test "$with_database_berkdb" = "yes"; then
42
 
@@ -4975,6 +4975,7 @@
 
58
@@ -4856,6 +4863,7 @@
43
59
   esac
44
60
 done
45
61
 AC_SUBST(DOCDIR)
47
63
 
48
64
 AC_SUBST(archlibdir)
49
65
 AC_SUBST(ARCHLIBDIR_USER_DEFINED)
50
 
@@ -5203,7 +5204,7 @@
 
66
@@ -5084,7 +5092,7 @@
51
67
 echo "  Relocating allocator for buffers:  $rel_alloc"
52
68
 echo "  GNU version of malloc:             ${GNU_MALLOC}${GNU_MALLOC_reason}"
53
69
 case "$ld_switch_site" in
56
72
     - Consider configuring with --pdump." ;;
57
73
 esac
58
74
 
59
 
diff -urNad xemacs21-21.4.20~/lisp/ChangeLog xemacs21-21.4.20/lisp/ChangeLog
60
 
--- xemacs21-21.4.20~/lisp/ChangeLog    2006-12-09 19:13:47.000000000 -0500
61
 
+++ xemacs21-21.4.20/lisp/ChangeLog     2007-07-23 08:30:58.510076301 -0400
62
 
@@ -848,6 +848,12 @@
 
75
--- xemacs21-21.4.15.orig/lisp/ChangeLog
 
76
+++ xemacs21-21.4.15/lisp/ChangeLog
 
77
@@ -430,6 +430,12 @@
63
78
 
64
79
        * XEmacs 21.4.9 "Informed Management" is released.
65
80
 
72
87
 2002-06-22  Ville Skytt�  <ville.skytta@xemacs.org>
73
88
 
74
89
        * subr.el (add-to-list): Sync with GNU Emacs 21.2, adding the
75
 
diff -urNad xemacs21-21.4.20~/lisp/font-menu.el xemacs21-21.4.20/lisp/font-menu.el
76
 
--- xemacs21-21.4.20~/lisp/font-menu.el 2001-10-23 04:35:21.000000000 -0400
77
 
+++ xemacs21-21.4.20/lisp/font-menu.el  2007-07-23 08:30:58.510076301 -0400
 
90
--- xemacs21-21.4.15.orig/lisp/font-menu.el
 
91
+++ xemacs21-21.4.15/lisp/font-menu.el
78
92
@@ -158,6 +158,11 @@
79
93
   :type '(choice (string :tag "Format string")
80
94
                 (function)))
87
101
 (defvar font-menu-preferred-resolution
88
102
   (make-specifier-and-init 'generic '((global ((mswindows) . ":")
89
103
                                              ((gtk) . "*-*")
90
 
diff -urNad xemacs21-21.4.20~/lisp/gnuserv.el xemacs21-21.4.20/lisp/gnuserv.el
91
 
--- xemacs21-21.4.20~/lisp/gnuserv.el   2007-07-21 00:41:56.000000000 -0400
92
 
+++ xemacs21-21.4.20/lisp/gnuserv.el    2007-07-23 08:30:58.510076301 -0400
93
 
@@ -408,6 +408,13 @@
 
104
--- xemacs21-21.4.15.orig/lisp/gnuserv.el
 
105
+++ xemacs21-21.4.15/lisp/gnuserv.el
 
106
@@ -399,6 +399,13 @@
94
107
   (eval form))
95
108
 
96
109
 
104
117
 ;; "Execute" a client connection, called by gnuclient.  This is the
105
118
 ;; backbone of gnuserv.el.
106
119
 (defun gnuserv-edit-files (type list &rest flags)
107
 
@@ -440,7 +447,7 @@
 
120
@@ -431,7 +438,7 @@
108
121
                          (case (car type)
109
122
                            (tty (apply 'make-tty-device (cdr type)))
110
123
                            (gtk (make-gtk-device))
113
126
                            (mswindows   (make-mswindows-device))
114
127
                            (t   (error "Invalid device type"))))
115
128
                         (t
116
 
diff -urNad xemacs21-21.4.20~/lisp/x-font-menu.el xemacs21-21.4.20/lisp/x-font-menu.el
117
 
--- xemacs21-21.4.20~/lisp/x-font-menu.el       2001-04-12 14:21:40.000000000 -0400
118
 
+++ xemacs21-21.4.20/lisp/x-font-menu.el        2007-07-23 08:30:58.510076301 -0400
 
129
--- xemacs21-21.4.15.orig/lisp/x-font-menu.el
 
130
+++ xemacs21-21.4.15/lisp/x-font-menu.el
119
131
@@ -89,7 +89,8 @@
120
132
        family size weight entry monospaced-p
121
133
        dev-cache cache families sizes weights)
126
138
                        ((stringp debug) (split-string debug "\n"))
127
139
                        (t debug)))
128
140
       (when (and (string-match x-font-regexp-ascii name)
129
 
diff -urNad xemacs21-21.4.20~/src/ChangeLog xemacs21-21.4.20/src/ChangeLog
130
 
--- xemacs21-21.4.20~/src/ChangeLog     2006-12-09 19:13:47.000000000 -0500
131
 
+++ xemacs21-21.4.20/src/ChangeLog      2007-07-23 08:30:58.510076301 -0400
132
 
@@ -1184,6 +1184,11 @@
 
141
--- xemacs21-21.4.15.orig/src/ChangeLog
 
142
+++ xemacs21-21.4.15/src/ChangeLog
 
143
@@ -311,6 +315,11 @@
133
144
 
134
145
        * specifier.c (Fvalid_specifier_type_p): Typo in comment.
135
146
 
141
152
 2002-11-13  Stephen J. Turnbull  <stephen@xemacs.org>
142
153
 
143
154
        * event-Xt.c (Xt_timeout):
144
 
diff -urNad xemacs21-21.4.20~/src/config.h.in xemacs21-21.4.20/src/config.h.in
145
 
--- xemacs21-21.4.20~/src/config.h.in   2005-11-27 21:10:19.000000000 -0500
146
 
+++ xemacs21-21.4.20/src/config.h.in    2007-07-23 08:30:58.510076301 -0400
147
 
@@ -915,6 +915,7 @@
 
155
--- xemacs21-21.4.15.orig/src/config.h.in
 
156
+++ xemacs21-21.4.15/src/config.h.in
 
157
@@ -905,6 +905,7 @@
148
158
 #undef MODULEDIR_USER_DEFINED
149
159
 #undef SITEMODULEDIR_USER_DEFINED
150
160
 #undef DOCDIR_USER_DEFINED
152
162
 #undef LISPDIR_USER_DEFINED
153
163
 #undef PACKAGE_PATH_USER_DEFINED
154
164
 #undef SITELISPDIR_USER_DEFINED
155
 
diff -urNad xemacs21-21.4.20~/src/console.h xemacs21-21.4.20/src/console.h
156
 
--- xemacs21-21.4.20~/src/console.h     2002-10-31 10:07:32.000000000 -0500
157
 
+++ xemacs21-21.4.20/src/console.h      2007-07-23 08:30:58.510076301 -0400
 
165
--- xemacs21-21.4.15.orig/src/console.h
 
166
+++ xemacs21-21.4.15/src/console.h
158
167
@@ -238,7 +238,8 @@
159
168
                                                Error_behavior errb);
160
169
   Lisp_Object (*font_instance_properties_method) (Lisp_Font_Instance *);
165
174
   Lisp_Object (*find_charset_font_method) (Lisp_Object device,
166
175
                                           Lisp_Object font,
167
176
                                           Lisp_Object charset);
168
 
diff -urNad xemacs21-21.4.20~/src/dumper.c xemacs21-21.4.20/src/dumper.c
169
 
--- xemacs21-21.4.20~/src/dumper.c      2006-07-01 01:19:56.000000000 -0400
170
 
+++ xemacs21-21.4.20/src/dumper.c       2007-07-23 08:30:58.510076301 -0400
 
177
--- xemacs21-21.4.15.orig/src/dumper.c
 
178
+++ xemacs21-21.4.15/src/dumper.c
171
179
@@ -1322,9 +1322,24 @@
172
180
 }
173
181
 #endif /* !WIN32_NATIVE */
213
221
     {
214
222
       pdump_load_finish ();
215
223
       return 1;
216
 
diff -urNad xemacs21-21.4.20~/src/glyphs-gtk.c xemacs21-21.4.20/src/glyphs-gtk.c
217
 
--- xemacs21-21.4.20~/src/glyphs-gtk.c  2005-11-24 21:01:57.000000000 -0500
218
 
+++ xemacs21-21.4.20/src/glyphs-gtk.c   2007-07-23 08:30:58.510076301 -0400
219
 
@@ -2094,6 +2094,21 @@
220
 
        {
221
 
          gtk_widget_map (wid);
 
224
--- xemacs21-21.4.15.orig/src/glyphs-gtk.c
 
225
+++ xemacs21-21.4.15/src/glyphs-gtk.c
 
226
@@ -2103,6 +2104,21 @@
 
227
            }
 
228
          GTK_WIDGET_FLAGS(FRAME_GTK_TEXT_WIDGET (f)) = old_flags;
222
229
        }
223
230
+      else
224
231
+       {
236
243
+           }
237
244
+       }
238
245
 
239
 
       gtk_widget_draw (wid, NULL);
240
 
     }
241
 
@@ -2213,7 +2228,6 @@
 
246
       if (!IMAGE_INSTANCE_SUBWINDOW_DISPLAYEDP (p))
 
247
        {
 
248
@@ -2219,7 +2235,6 @@
242
249
   /* This function can GC */
243
250
   Lisp_Image_Instance *ii = XIMAGE_INSTANCE (image_instance);
244
251
   Lisp_Object device = IMAGE_INSTANCE_DEVICE (ii);
246
253
 
247
254
   if (!DEVICE_GTK_P (XDEVICE (device)))
248
255
     signal_simple_error ("Not a GTK device", device);
249
 
diff -urNad xemacs21-21.4.20~/src/objects-gtk.c xemacs21-21.4.20/src/objects-gtk.c
250
 
--- xemacs21-21.4.20~/src/objects-gtk.c 2005-12-26 17:25:46.000000000 -0500
251
 
+++ xemacs21-21.4.20/src/objects-gtk.c  2007-07-23 08:30:58.510076301 -0400
 
256
--- xemacs21-21.4.15.orig/src/objects-gtk.c
 
257
+++ xemacs21-21.4.15/src/objects-gtk.c
252
258
@@ -369,7 +369,7 @@
253
259
 }
254
260
 
258
264
 {
259
265
   const char *patternext;
260
266
 
261
 
diff -urNad xemacs21-21.4.20~/src/objects-msw.c xemacs21-21.4.20/src/objects-msw.c
262
 
--- xemacs21-21.4.20~/src/objects-msw.c 2001-04-12 14:24:09.000000000 -0400
263
 
+++ xemacs21-21.4.20/src/objects-msw.c  2007-07-23 08:30:58.510076301 -0400
 
267
--- xemacs21-21.4.15.orig/src/objects-msw.c
 
268
+++ xemacs21-21.4.15/src/objects-msw.c
264
269
@@ -1592,7 +1592,8 @@
265
270
 }
266
271
 
271
276
 {
272
277
   Lisp_Object fonttail, result = Qnil;
273
278
   char *extpattern;
274
 
diff -urNad xemacs21-21.4.20~/src/objects-tty.c xemacs21-21.4.20/src/objects-tty.c
275
 
--- xemacs21-21.4.20~/src/objects-tty.c 2001-04-12 14:24:09.000000000 -0400
276
 
+++ xemacs21-21.4.20/src/objects-tty.c  2007-07-23 08:30:58.510076301 -0400
 
279
--- xemacs21-21.4.15.orig/src/objects-tty.c
 
280
+++ xemacs21-21.4.15/src/objects-tty.c
277
281
@@ -275,7 +275,7 @@
278
282
 }
279
283
 
283
287
 {
284
288
   return list1 (build_string ("normal"));
285
289
 }
286
 
diff -urNad xemacs21-21.4.20~/src/objects-x.c xemacs21-21.4.20/src/objects-x.c
287
 
--- xemacs21-21.4.20~/src/objects-x.c   2005-12-06 19:07:50.000000000 -0500
288
 
+++ xemacs21-21.4.20/src/objects-x.c    2007-07-23 08:30:58.510076301 -0400
 
290
--- xemacs21-21.4.15.orig/src/objects-x.c
 
291
+++ xemacs21-21.4.15/src/objects-x.c
289
292
@@ -862,17 +862,23 @@
290
293
 }
291
294
 
312
315
   while (count--)
313
316
     result = Fcons (build_ext_string (names[count], Qx_font_name_encoding),
314
317
                    result);
315
 
diff -urNad xemacs21-21.4.20~/src/objects.c xemacs21-21.4.20/src/objects.c
316
 
--- xemacs21-21.4.20~/src/objects.c     2005-01-30 21:55:25.000000000 -0500
317
 
+++ xemacs21-21.4.20/src/objects.c      2007-07-23 08:30:58.510076301 -0400
 
318
--- xemacs21-21.4.15.orig/src/objects.c
 
319
+++ xemacs21-21.4.15/src/objects.c
318
320
@@ -459,17 +459,18 @@
319
321
                             font_instance_properties, (f));
320
322
 }