~ubuntu-branches/ubuntu/utopic/adios/utopic

« back to all changes in this revision

Viewing changes to debian/patches/underlinkage.patch

  • Committer: Package Import Robot
  • Author(s): Daniel T Chen
  • Date: 2014-01-27 12:53:17 UTC
  • Revision ID: package-import@ubuntu.com-20140127125317-2aa074klxl8w7kig
Tags: 1.5.0-1ubuntu3
Add another missing lib to link for Ubuntu/ppc64el.

Show diffs side-by-side

added added

removed removed

Lines of Context:
14
14
Index: adios-1.5.0/utils/bp2ncd/Makefile.am
15
15
===================================================================
16
16
--- adios-1.5.0.orig/utils/bp2ncd/Makefile.am   2013-12-09 10:23:31.000000000 -0500
17
 
+++ adios-1.5.0/utils/bp2ncd/Makefile.am        2014-01-27 12:23:11.691392729 -0500
 
17
+++ adios-1.5.0/utils/bp2ncd/Makefile.am        2014-01-27 12:54:10.806482546 -0500
18
18
@@ -13,7 +13,7 @@
19
19
     bp2ncd_CPPFLAGS = $(ADIOSLIB_EXTRA_CPPFLAGS) $(ADIOSLIB_CPPFLAGS)
20
20
     bp2ncd_CFLAGS = $(ADIOSLIB_CFLAGS) 
21
21
     bp2ncd_LDFLAGS = $(ADIOSLIB_LDFLAGS) -static-libtool-libs
22
22
-    bp2ncd_LDADD = $(top_builddir)/src/libadios.a $(ADIOSLIB_LDADD)
23
 
+    bp2ncd_LDADD = $(top_builddir)/src/libadios.a $(ADIOSLIB_LDADD) -lm
 
23
+    bp2ncd_LDADD = $(top_builddir)/src/libadios.a $(ADIOSLIB_LDADD) -lm -lcurl
24
24
 else
25
25
     bp2ncd_CPPFLAGS = $(ADIOSLIB_EXTRA_CPPFLAGS) $(ADIOSLIB_INT_CPPFLAGS) $(ADIOSLIB_INT_CFLAGS)
26
26
     bp2ncd_LDFLAGS = $(ADIOSLIB_INT_LDFLAGS) -static-libtool-libs