~ubuntu-branches/ubuntu/utopic/gdis/utopic

« back to all changes in this revision

Viewing changes to debian/patches/debian_make.patch

  • Committer: Package Import Robot
  • Author(s): Daniel Leidert (dale)
  • Date: 2012-05-02 00:23:38 UTC
  • mfrom: (3.1.6 sid)
  • Revision ID: package-import@ubuntu.com-20120502002338-mgsnnj122flffu6w
Tags: 0.90-4
* makefile.debian: Moved into debian/patches/debian_make.patch.
* debian/compat: Increased compatibility level to 7.
* debian/control (Standards-Version): Bumped to 3.9.3.
  (Build-Depends): Dropped dpatch. Increased required debhelper version.
  (Vcs-Browser): Fixed.
  (Conflicts): Changed into Breaks according to lintian.
* debian/gdis.manpages: Added.
* debian/rules: Rewritten for dh 7.
* debian/source.lintian-overrides: Dropped obsolete file.
* debian/README.source: Dropped obsolete file.
* debian/patches/Debian_make.dpatch: Renamed to
  debian/patches/debian_path.patch.
* debian/patches/debian_make.patch: Added.
  - Moved makefile.debian into this patch.
* debian/patches/00list: Renamed to debian/patches/series and adjusted.
* debian/source/format: Added for quilt-based format 3.0 (closes: #667757).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Daniel Leidert <daniel.leidert@wgdd.de>
 
2
Description: Makefile for Debian.
 
3
 
 
4
--- /dev/null
 
5
+++ b/makefile.debian
 
6
@@ -0,0 +1,19 @@
 
7
+CFLAGS ?= -g -Wall -O2
 
8
+
 
9
+override CFLAGS += `pkg-config --cflags gtk+-2.0 gthread-2.0 gtkglext-1.0 gmodule-2.0`
 
10
+override LDLIBS += `pkg-config --libs gtk+-2.0 gthread-2.0 gtkglext-1.0 gmodule-2.0`
 
11
+
 
12
+USE_GUI = YES
 
13
+override CFLAGS += -DWITH_GUI
 
14
+USE_GRISU = NO
 
15
+override CFLAGS += -UWITH_GRISU
 
16
+
 
17
+include makefile.src
 
18
+
 
19
+OBJ = $(SRC:.c=.o)
 
20
+
 
21
+gdis: $(OBJ)
 
22
+       $(CC) $^ $(LDFLAGS) -o $@ $(LDLIBS)
 
23
+
 
24
+clean:
 
25
+       $(RM) $(OBJ) gdis