~ubuntu-branches/ubuntu/utopic/gnome-settings-daemon/utopic

« back to all changes in this revision

Viewing changes to debian/patches/48_register_client_before_idle_callbacks.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Sebastien Bacher, Robert Ancell, Rico Tzschichholz, Iain Lane
  • Date: 2012-11-21 17:16:23 UTC
  • mfrom: (1.1.62)
  • Revision ID: package-import@ubuntu.com-20121121171623-k7iufrs14qoiozeq
Tags: 3.6.3-0ubuntu1
[ Sebastien Bacher ]
* New upstream version (lp: #1008840)
* debian/patches/git*,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/power-ignore-bad-dbus-requests.patch,
  debian/patches/10_smaller_syndaemon_timeout.patch: 
  - dropped, those fixes are in the new version
* debian/control.in:
  - restore build-depends on libgnomekbd-dev, libxklavier-dev,
    drop the build-depends on libxkbfile-dev
* debian/patches/20_migrate_background_uri.patch:
  - dropped, it was only needed until the LTS
* debian/patches/40_xres_lcddefault.patch:
  - dropped, that was a workaround for libreoffice that shouldn't be
    needed and we should better fix libreoffice
* debian/patches/61_unity_use_application_indicator.patch:
  - drop the keyboard indicator code, that will need to be turned 
    into a proper indicator refactored to handle the new ibus config
* debian/patches/90_set_gmenus_xsettings.patch:
  - refreshed for the new version
* debian/patches/revert_new_ibus_use.patch:
  - revert keyboard code to our 3.4 version
* debian/patches/sync_keyboard_layout_to_accountsservice.patch:
  - dropped, the changes are included in the previous patch

[ Robert Ancell ]
* New upstream release
* debian/control:
  - Bump build-depends on libgnome-desktop-3-dev, libwacom-dev
  - Drop build-depends on libgnomekbd-dev, libxklavier-dev
  - Add build-depends on libxkbfile-dev

[ Rico Tzschichholz ]
* debian/control.in:
  - Build-depend on gtk-doc-tools

[ Iain Lane ]
* New upstream release
* Refresh patches and remove those applied upstream.
* Remove gstreamer BDs which are now obsolete. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-settings-daemon-3.3.91/gnome-settings-daemon/main.c
 
1
Index: gnome-settings-daemon-3.6.1/gnome-settings-daemon/main.c
2
2
===================================================================
3
 
--- gnome-settings-daemon-3.3.91.orig/gnome-settings-daemon/main.c      2012-03-05 21:04:12.757981058 +0100
4
 
+++ gnome-settings-daemon-3.3.91/gnome-settings-daemon/main.c   2012-03-05 21:04:12.817981061 +0100
5
 
@@ -219,36 +219,6 @@
6
 
         g_object_unref (locale_settings);
 
3
--- gnome-settings-daemon-3.6.1.orig/gnome-settings-daemon/main.c       2012-10-26 10:19:49.467004174 +0200
 
4
+++ gnome-settings-daemon-3.6.1/gnome-settings-daemon/main.c    2012-10-26 10:19:49.527004177 +0200
 
5
@@ -303,28 +303,6 @@
7
6
 }
 
7
 #endif
8
8
 
9
9
-static void
10
10
-got_session_proxy (GObject      *source_object,
19
19
-                g_debug ("Could not connect to the Session manager: %s", error->message);
20
20
-                g_error_free (error);
21
21
-        } else {
22
 
-                const char *startup_id;
23
 
-
24
 
-                /* Register the daemon with gnome-session */
25
 
-                g_signal_connect (G_OBJECT (proxy), "g-signal",
26
 
-                                  G_CALLBACK (on_session_over), NULL);
27
 
-                startup_id = g_getenv ("DESKTOP_AUTOSTART_ID");
28
 
-                g_dbus_proxy_call (proxy,
29
 
-                                   "RegisterClient",
30
 
-                                   g_variant_new ("(ss)", "gnome-settings-daemon", startup_id ? startup_id : ""),
31
 
-                                   G_DBUS_CALL_FLAGS_NONE,
32
 
-                                   -1,
33
 
-                                   NULL,
34
 
-                                   (GAsyncReadyCallback) on_client_registered,
35
 
-                                   manager);
 
22
-#ifdef HAVE_IBUS
 
23
-                /* This will register with gnome-session after calling Setenv. */
 
24
-                set_legacy_ibus_env_vars (proxy);
 
25
-#else
 
26
-                register_with_gnome_session (proxy);
 
27
-#endif
36
28
-        }
37
29
-}
38
30
-
39
31
 static gboolean
40
32
 on_term_signal_pipe_closed (GIOChannel *source,
41
33
                             GIOCondition condition,
42
 
@@ -298,16 +268,6 @@
 
34
@@ -374,16 +352,6 @@
43
35
 {
44
36
         g_assert (bus != NULL);
45
37
 
56
48
         watch_for_term_signal (manager);
57
49
 }
58
50
 
59
 
@@ -330,6 +290,56 @@
 
51
@@ -406,6 +374,56 @@
60
52
         gtk_main_quit ();
61
53
 }
62
54
 
113
105
 static void
114
106
 bus_register (void)
115
107
 {
116
 
@@ -423,6 +433,8 @@
 
108
@@ -499,6 +517,8 @@
117
109
 
118
110
         notify_init ("gnome-settings-daemon");
119
111