~ubuntu-branches/ubuntu/utopic/graphmonkey/utopic

« back to all changes in this revision

Viewing changes to debian/patches/correct-location

  • Committer: Bazaar Package Importer
  • Author(s): Jo Shields
  • Date: 2010-01-06 15:40:45 UTC
  • mfrom: (2.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20100106154045-s5emb5cotmmhzt7y
Tags: 1.7-2
* debian/control,
  debian/rules:
  + Use mono-csc from mono-devel 2.4.3 (Closes: #562330)
* debian/control:
  + No-change bump to Standards 3.8.3
  + Use GTK#-s -cil-dev packages
* debian/rules,
  debian/graphmonkey.desktop:
  + Include a .desktop entry with an icon - thanks to David Futcher 
    (Closes: #561030)
* debian/graphmonkey.1:
  + Update manpage - thanks to David Futcher (Closes: #561032)
* debian/copyright:
  + Fix dates in copyright - thanks to David Futcher (Closes: #561031)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/Makefile
 
2
+++ b/Makefile
 
3
@@ -1,7 +1,5 @@
 
4
 CC=mcs
 
5
 EXEC=GraphMonkey.exe
 
6
-SHARE=/usr/local/share
 
7
-BIN=/usr/local/bin
 
8
 
 
9
 all: 
 
10
        $(CC) -target:exe -out:"$(EXEC)" -pkg:gtk-sharp-2.0  ./Main.cs ./MyWindow.cs ./Ecran_Form.cs ./operation.cs ./About_Form.cs
 
11
@@ -10,6 +8,7 @@
 
12
        rm -rf $(EXEC)
 
13
 
 
14
 install:
 
15
-       mkdir -p $(SHARE)/graphmonkey
 
16
-       cp -f $(EXEC) $(SHARE)/graphmonkey
 
17
-       cp -f graphmonkey $(BIN)
 
18
+       mkdir -p $(DESTDIR)/usr/lib/graphmonkey
 
19
+       cp $(EXEC) $(DESTDIR)/usr/lib/graphmonkey/
 
20
+       mkdir -p $(DESTDIR)/usr/bin
 
21
+       cp graphmonkey $(DESTDIR)/usr/bin/
 
22
--- a/graphmonkey
 
23
+++ b/graphmonkey
 
24
@@ -1,2 +1,2 @@
 
25
 #!/bin/sh
 
26
-mono /usr/local/share/graphmonkey/GraphMonkey.exe
 
27
+mono /usr/lib/graphmonkey/GraphMonkey.exe