~ubuntu-branches/ubuntu/utopic/grub/utopic

« back to all changes in this revision

Viewing changes to debian/patches/xsi_mkbimage.diff

  • Committer: Bazaar Package Importer
  • Author(s): Colin Watson
  • Date: 2005-11-30 18:00:45 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20051130180045-q90uxa58hf9pdrrp
Tags: 0.97-1ubuntu1
* Resynchronise with Debian.
* Drop Nathaniel McCallum's nonaltoptions patch, done differently in
  Debian (as defoptions); added migration code to deal with old Ubuntu
  menu.lst files.
* Drop Matthew Garrett's stage 2 drive fallback patch, since upstream has
  implemented a different solution which appears to address essentially
  the same problem.
* Generated debian/control once from debian/control.in using
  type-handling, but continue to avoid the build-dependency on
  type-handling; the generated debian/control is in the source package.
* Disable fix_amd64_compile.diff for now; it causes configure to fail with
  "GRUB requires a working absolute objcopy; upgrade your binutils".

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
 
2
 
Copyright: not significant
3
 
Upstream: committed
4
 
 
5
 
--- grub-0.95+cvs20040624.old/util/mkbimage     2004-04-29 21:45:11.000000000 +0200
6
 
+++ grub-0.95+cvs20040624/util/mkbimage 2004-07-21 15:47:15.000000000 +0200
7
 
@@ -232,10 +232,10 @@
8
 
 
9
 
 if [ ! "$image_type" ]; then
10
 
        image_type=hd;
11
 
-elif [ "$image_type" != "1.20" -a "$image_type" != "1.44" \
12
 
-  -a "$image_type" != "1.60" -a "$image_type" != "1.68" \
13
 
-  -a "$image_type" != "2.88" -a "$image_type" != "1.74" \
14
 
-  -a "$image_type" != "hd" -a "$image_type" != "1.60" ] ; then
15
 
+elif [ "$image_type" != "1.20" ] && [ "$image_type" != "1.44" ] \
16
 
+  && [ "$image_type" != "1.60" ] && [ "$image_type" != "1.68" ] \
17
 
+  && [ "$image_type" != "2.88" ] && [ "$image_type" != "1.74" ] \
18
 
+  && [ "$image_type" != "hd" ] && [ "$image_type" != "1.60" ] ; then
19
 
   error wrong_type ;
20
 
 fi
21