~ubuntu-branches/ubuntu/utopic/haproxy/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bashism

  • Committer: Package Import Robot
  • Author(s): Vincent Bernat, Apollon Oikonomopoulos, Vincent Bernat, Prach Pongpanich
  • Date: 2013-05-06 20:02:14 UTC
  • mfrom: (1.1.12)
  • Revision ID: package-import@ubuntu.com-20130506200214-36s6p81fsa5zqybt
Tags: 1.4.23-1
[ Apollon Oikonomopoulos ]
* New upstream version (Closes: #643650, #678953)
   + This fixes CVE-2012-2942 (Closes: #674447)
   + This fixes CVE-2013-1912 (Closes: #704611)
* Ship vim addon as vim-haproxy (Closes: #702893)
* Check for the configuration file after sourcing /etc/default/haproxy
  (Closes: #641762)
* Use /dev/log for logging by default (Closes: #649085)

[ Vincent Bernat ]
* debian/control:
   + add Vcs-* fields
   + switch maintenance to Debian HAProxy team. (Closes: #706890)
   + drop dependency to quilt: 3.0 (quilt) format is in use.
* debian/rules:
   + don't explicitly call dh_installchangelog.
   + use dh_installdirs to install directories.
   + use dh_install to install error and configuration files.
   + switch to `linux2628` Makefile target for Linux.
* debian/postrm:
   + remove haproxy user and group on purge.
* Ship a more minimal haproxy.cfg file: no `listen` blocks but `global`
  and `defaults` block with appropriate configuration to use chroot and
  logging in the expected way.

[ Prach Pongpanich ]
* debian/copyright:
   + add missing copyright holders
   + update years of copyright
* debian/rules:
   + build with -Wl,--as-needed to get rid of unnecessary depends
* Remove useless files in debian/haproxy.{docs,examples}
* Update debian/watch file, thanks to Bart Martens

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: haproxy-1.4.13/examples/debugfind
2
 
===================================================================
3
 
--- haproxy-1.4.13.orig/examples/debugfind      2011-03-11 00:05:38.000000000 +0000
4
 
+++ haproxy-1.4.13/examples/debugfind   2011-03-11 00:05:43.000000000 +0000
5
 
@@ -1,4 +1,4 @@
6
 
-#!/bin/bash
7
 
+#!/bin/sh
8
 
 if [ $# -lt 2 ]; then
9
 
        echo "Usage: $0 regex debug_file > extracted_file"
10
 
        exit 1
11
 
Index: haproxy-1.4.13/examples/stats_haproxy.sh
12
 
===================================================================
13
 
--- haproxy-1.4.13.orig/examples/stats_haproxy.sh       2011-03-11 00:05:11.000000000 +0000
14
 
+++ haproxy-1.4.13/examples/stats_haproxy.sh    2011-03-11 00:05:25.000000000 +0000
15
 
@@ -1,4 +1,4 @@
16
 
-#!/bin/bash
17
 
+#!/bin/sh
18
 
 
19
 
 ## contrib by prizee.com
20
 
 
21
 
@@ -11,7 +11,7 @@
22
 
 
23
 
 printUsage ()
24
 
 {
25
 
-    echo -e "Usage : $(basename $0) [options] -s section
26
 
+    printf "Usage : $(basename $0) [options] -s section
27
 
 --section -s section\t: section to use ( --list format)
28
 
 Options :
29
 
 --socket -S [socket]\t: socket to use (default: /var/run/haproxy.stat)