~ubuntu-branches/ubuntu/utopic/jenkins-job-builder/utopic

« back to all changes in this revision

Viewing changes to debian/patches/0001-Documentation-fixes-to-make-Sphinx-happy.patch

  • Committer: Package Import Robot
  • Author(s): Paul Belanger
  • Date: 2013-07-28 10:32:09 UTC
  • mfrom: (1.1.2)
  • Revision ID: package-import@ubuntu.com-20130728103209-6q9hrv6oljkp0qng
Tags: 0.5.0-1
* New upstream release (Closes: #718126)
* debian/patches: Merged upstream
  - 0001-Documentation-fixes-to-make-Sphinx-happy.patch
  - 0002-Remove-setuptools-git-from-setup.py.patch
* debian/patches: Add upstream fixes for packaging
  - 0001-Fixing-documentation.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 656915f66d159f0e2ff3ba7846d87604e6a793ef Mon Sep 17 00:00:00 2001
2
 
From: Paul Belanger <paul.belanger@polybeacon.com>
3
 
Date: Wed, 16 Jan 2013 22:18:27 -0500
4
 
Subject: [PATCH] Documentation fixes to make Sphinx happy
5
 
 
6
 
On this note, we have an issue with our current gate test for
7
 
documentation not properly catching these issues.  I'll be attempting to
8
 
address the issue in a future patch.
9
 
 
10
 
Change-Id: I7d0bea70ef98d1744200815ce12f1436729349e8
11
 
Signed-off-by: Paul Belanger <paul.belanger@polybeacon.com>
12
 
Reviewed-on: https://review.openstack.org/19889
13
 
Reviewed-by: Clark Boylan <clark.boylan@gmail.com>
14
 
Reviewed-by: James E. Blair <corvus@inaugust.com>
15
 
Approved: James E. Blair <corvus@inaugust.com>
16
 
Tested-by: Jenkins
17
 
---
18
 
 doc/source/configuration.rst     |    2 ++
19
 
 doc/source/general.rst           |    4 ++--
20
 
 jenkins_jobs/modules/wrappers.py |   22 ++++++++++++----------
21
 
 3 files changed, 16 insertions(+), 12 deletions(-)
22
 
 
23
 
diff --git a/doc/source/configuration.rst b/doc/source/configuration.rst
24
 
index cee8d5b..01fd2ae 100644
25
 
--- a/doc/source/configuration.rst
26
 
+++ b/doc/source/configuration.rst
27
 
@@ -259,6 +259,8 @@ the generic macro ``add``.  Whenever you forget a parameter from a macro,
28
 
 it will not be expanded and left as is, which will most probably cause havoc in
29
 
 your Jenkins builds.
30
 
 
31
 
+.. _defaults:
32
 
+
33
 
 Defaults
34
 
 ^^^^^^^^
35
 
 
36
 
diff --git a/doc/source/general.rst b/doc/source/general.rst
37
 
index 9e6d7d8..206cd33 100644
38
 
--- a/doc/source/general.rst
39
 
+++ b/doc/source/general.rst
40
 
@@ -28,9 +28,9 @@ later.  There are a few basic optional fields for a Job definition::
41
 
       Defaults to "freestyle", but "maven" can also be specified.
42
 
 
43
 
     * **defaults**:
44
 
-      Specifies a set of `Defaults`_ to use for this job, defaults to
45
 
+      Specifies a set of :ref:`defaults` to use for this job, defaults to
46
 
       ''global''.  If you have values that are common to all of your jobs,
47
 
-      create a ``global`` `Defaults`_ object to hold them, and no further
48
 
+      create a ``global`` :ref:`defaults` object to hold them, and no further
49
 
       configuration of individual jobs is necessary.  If some jobs
50
 
       should not use the ``global`` defaults, use this field to specify a
51
 
       different set of defaults.
52
 
diff --git a/jenkins_jobs/modules/wrappers.py b/jenkins_jobs/modules/wrappers.py
53
 
index 6a93176..71caf6c 100644
54
 
--- a/jenkins_jobs/modules/wrappers.py
55
 
+++ b/jenkins_jobs/modules/wrappers.py
56
 
@@ -276,6 +276,7 @@ def inject(parser, xml_parent, data):
57
 
     :arg str script-content: contents of a script (default '')
58
 
 
59
 
     Example::
60
 
+
61
 
       wrappers:
62
 
         - inject:
63
 
             properties-file-path: /usr/local/foo
64
 
@@ -309,18 +310,19 @@ def jclouds(parser, xml_parent, data):
65
 
                                  the instance (default: False).
66
 
 
67
 
     Example::
68
 
+
69
 
       wrappers:
70
 
         - jclouds:
71
 
-          single-use: True
72
 
-          instances:
73
 
-            - jenkins-dev-slave:
74
 
-                cloud-name: mycloud1
75
 
-                count: 1
76
 
-                stop-on-terminate: True
77
 
-            - jenkins-test-slave:
78
 
-                cloud-name: mycloud2
79
 
-                count: 2
80
 
-                stop-on-terminate: False
81
 
+            single-use: True
82
 
+            instances:
83
 
+              - jenkins-dev-slave:
84
 
+                  cloud-name: mycloud1
85
 
+                  count: 1
86
 
+                  stop-on-terminate: True
87
 
+              - jenkins-test-slave:
88
 
+                  cloud-name: mycloud2
89
 
+                  count: 2
90
 
+                  stop-on-terminate: False
91
 
     """
92
 
     buildWrapper = XML.SubElement(xml_parent,
93
 
                                   'jenkins.plugins.jclouds.compute.'
94
 
1.7.9.5
95