~ubuntu-branches/ubuntu/utopic/lazygal/utopic

« back to all changes in this revision

Viewing changes to debian/patches/manpage-installation.patch

  • Committer: Package Import Robot
  • Author(s): Michal Čihař
  • Date: 2011-11-30 09:24:25 UTC
  • mfrom: (1.2.9)
  • Revision ID: package-import@ubuntu.com-20111130092425-2jim1l762xdmorz7
Tags: 0.7.1-1
* New upstream release.
  - Patch was merged upstream. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Michal Čihař <nijel@debian.org>
2
 
Subject: Fix manpages installation path
3
 
 
4
 
--- a/setup.py
5
 
+++ b/setup.py
6
 
@@ -77,12 +77,13 @@
7
 
 
8
 
         for xmlmanpage in self.manpages:
9
 
             manpage = xmlmanpage[:-4] # remove '.xml' at the end
10
 
+            section = manpage[-1:]
11
 
             if newer(xmlmanpage, manpage):
12
 
                 cmd = (self.executable, "--nonet", "-o", self.mandir, db2man,
13
 
                        xmlmanpage)
14
 
                 self.spawn(cmd)
15
 
 
16
 
-            targetpath = os.path.join("share", "man", 'man1')
17
 
+            targetpath = os.path.join("share", "man", 'man%s' % section)
18
 
             data_files.append((targetpath, (manpage, ), ))
19
 
 
20