~ubuntu-branches/ubuntu/utopic/libavg/utopic

« back to all changes in this revision

Viewing changes to debian/patches/0001-do-not-build-tests-by-default.patch

  • Committer: Bazaar Package Importer
  • Author(s): Torsten Werner
  • Date: 2010-05-02 23:50:04 UTC
  • mfrom: (1.1.4 upstream) (2.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100502235004-i6u38zelbi2k12ii
Tags: 1.0.1-1
* new upstream release (Closes: #565512)
* Remove patches that have been merged upstream.
* Add a patch that avoids building tests by default.
* Remove .py extension from two more scripts in /usr/bin .
* Add 2 example files to /usr/share/doc/python-libavg/examples/ .
* Describe a workaround for bug #579937 in README.Debian.
* Install debian/libavg.pth into /usr/share/pyshared/ .
  (Closes: #575551)
* Add get-orig-source target to debian/rules.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Torsten Werner <twerner@debian.org>
 
2
Date: Sat, 20 Mar 2010 23:34:07 +0100
 
3
Subject: [PATCH] do not build tests by default
 
4
 
 
5
---
 
6
 configure.in    |    9 +++++++++
 
7
 src/Makefile.am |    6 +++++-
 
8
 2 files changed, 14 insertions(+), 1 deletions(-)
 
9
 
 
10
diff --git a/configure.in b/configure.in
 
11
index bd288e1..d28745f 100644
 
12
--- a/configure.in
 
13
+++ b/configure.in
 
14
@@ -120,6 +120,15 @@ fi
 
15
 
 
16
 AM_CONDITIONAL(APPLE, test $target_vendor = apple)
 
17
 
 
18
+AC_ARG_ENABLE([tests],
 
19
+AC_HELP_STRING([--enable-tests], [build tests]),
 
20
+[case "${enableval}" in
 
21
+  yes) tests=true ;;
 
22
+  no)  tests=false ;;
 
23
+  *)   AC_MSG_ERROR([bad value ${enableval} for --enable-tests]) ;;
 
24
+esac], [tests=false])
 
25
+AM_CONDITIONAL(ENABLE_TESTS, test x$tests = xtrue)
 
26
+
 
27
 PREFIX=$prefix
 
28
 AC_SUBST(PREFIX)
 
29
 AM_CONFIG_HEADER(src/avgconfig.h)
 
30
diff --git a/src/Makefile.am b/src/Makefile.am
 
31
index dc866c2..3b752f9 100644
 
32
--- a/src/Makefile.am
 
33
+++ b/src/Makefile.am
 
34
@@ -1,4 +1,8 @@
 
35
+if ENABLE_TESTS
 
36
+  TESTDIRS = test
 
37
+endif
 
38
+
 
39
 SUBDIRS = base graphics imaging lmfit audio video player conradrelais parport anim \
 
40
-        wrapper python test utils
 
41
+        wrapper python utils $(TESTDIRS)
 
42
 
 
43
 EXTRA_DIST = avgrc avgconfigwrapper.h api.h avgconfig_win.h
 
44
--